summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlothar-mar2015-06-11 16:07:38 +0100
committerlothar-mar2015-06-11 16:07:38 +0100
commiteeaefc4eeee7879ed0f5a36f3aa5e9b25a3285f0 (patch)
tree93252d8462efef348fe5cbe79c0121069b339da3
downloadaur-eeaefc4eeee7879ed0f5a36f3aa5e9b25a3285f0.tar.gz
Initial commit.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD45
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d5acda8fbfe3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = epanet2.toolkit-git
+ pkgdesc = The EPANET Toolkit allows researchers to use the simulation engine within other applications, such as optimisation algorithms.
+ pkgver = 1.5
+ pkgrel = 1
+ url = http://www.epa.gov/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = epanet2-git
+ provides = epanet2.toolkit
+ conflicts = epanet2.toolkit
+ options = staticlibs
+ source = git+https://bitbucket.org/lothar_m/epanet2.toolkit/epanet2.toolkit.git
+ md5sums = SKIP
+
+pkgname = epanet2.toolkit-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..378e723303f2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+#Maintainer: Lothar_m <lothar_m at riseup dot net>
+
+pkgname='epanet2.toolkit-git'
+_gitname='epanet2.toolkit'
+pkgver=1.5
+pkgrel=1
+arch=('i686' 'x86_64')
+url="http://www.epa.gov/"
+depends=('epanet2-git')
+#optdepends=()
+makedepends=('git')
+license=('GPL')
+pkgdesc="The EPANET Toolkit allows researchers to use the simulation engine within other applications, such as optimisation algorithms."
+options=('staticlibs')
+provides=(epanet2.toolkit)
+conflicts=(epanet2.toolkit)
+#source=("https://bitbucket.org/lothar_m/"$_gitname"/"$_gitname".git")
+source=("git+https://bitbucket.org/lothar_m/"$_gitname"/"$_gitname".git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ # Use the tag of the last commit
+ git describe --long --tags | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${_gitname}"
+ cd "$srcdir/$_gitname"
+
+ # make the executable and shared object library
+ #cd "$srcdir/$_gitname/src"
+ cd "$srcdir/$_gitname/src"
+ make toolkit
+}
+
+package() {
+# install header file to /usr/include
+ install -D -m755 "$srcdir/$_gitname/toolkit.h" "$pkgdir/usr/include/toolkit.h"
+# install library to /usr/lib
+ install -D -m755 "$srcdir/$_gitname/libtoolkit.a" "$pkgdir/usr/lib/libtoolkit.a"
+# install license
+ install -D -m644 "$srcdir/$_gitname/src/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+