summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy_Vetrov2019-03-23 23:49:37 +0300
committerAndy_Vetrov2019-03-23 23:49:37 +0300
commit3a4b719f5786ecbd88abf544550890477e09e0ca (patch)
tree9f4636558a6d1c774a73cff51f7b8a126278547d
downloadaur-3a4b719f5786ecbd88abf544550890477e09e0ca.tar.gz
Initial commit
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD34
-rw-r--r--patch.txt20
3 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d10a98d7107b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = epdfview-gtk3
+ pkgdesc = Lightweight PDF document viewer. GTK3 version.
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = https://github.com/Flow-It/epdfview
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ makedepends = meson
+ makedepends = ninja
+ makedepends = doxygen
+ depends = gtk3
+ depends = poppler-glib
+ depends = desktop-file-utils
+ depends = hicolor-icon-theme
+ provides = epdfview
+ conflicts = epdfview
+ replaces = epdfview
+ source = git+https://github.com/Flow-It/epdfview.git
+ source = patch.txt
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = epdfview-gtk3
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3b8bbc2869b9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Andrey Vetrov <vetrov at mail dot ru>
+
+pkgname=epdfview-gtk3
+pkgver=0.2.0
+pkgrel=1
+pkgdesc='Lightweight PDF document viewer. GTK3 version.'
+url='https://github.com/Flow-It/epdfview'
+arch=('x86_64')
+license=('GPL2')
+provides=('epdfview')
+conflicts=('epdfview')
+replaces=('epdfview')
+depends=('gtk3' 'poppler-glib' 'desktop-file-utils' 'hicolor-icon-theme')
+makedepends=('git' 'meson' 'ninja' 'doxygen')
+source=("git+https://github.com/Flow-It/epdfview.git"
+ 'patch.txt')
+md5sums=('SKIP' 'SKIP')
+
+prepare() {
+ cd "${srcdir}/${pkgname%-*}"
+ patch -Np1 -i ../patch.txt
+}
+
+build() {
+ mkdir build
+ meson --prefix=/usr \
+ --buildtype=plain \
+ "${srcdir}/${pkgname%-*}" build
+ ninja -C build
+}
+
+package() {
+ DESTDIR="${pkgdir}" ninja -C build install
+}
diff --git a/patch.txt b/patch.txt
new file mode 100644
index 000000000000..f16cbdcc676e
--- /dev/null
+++ b/patch.txt
@@ -0,0 +1,20 @@
+--- a/src/gtk/MainView.cxx
++++ b/src/gtk/MainView.cxx
+@@ -1050,7 +1050,7 @@
+
+ GError *error = NULL;
+ if ( !gtk_ui_manager_add_ui_from_file (m_UIManager,
+- DATADIR"/ui/epdfview-ui.xml",
++ DATADIR"/epdfview/ui/epdfview-ui.xml",
+ &error) )
+ {
+ g_critical (_("Error building UI manager: %s\n"), error->message);
+@@ -1060,7 +1060,7 @@
+
+ #if defined (HAVE_CUPS)
+ if ( !gtk_ui_manager_add_ui_from_file (m_UIManager,
+- DATADIR"/ui/epdfview-ui-print.xml",
++ DATADIR"/epdfview/ui/epdfview-ui-print.xml",
+ &error) )
+ {
+ g_critical (_("Error building UI manager: %s\n"), error->message);