summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTinu Weber2017-05-24 00:26:12 +0200
committerTinu Weber2017-06-11 11:04:45 +0200
commit1e5eb5f2bb8dac888221cff57f4b0fe9e822de4e (patch)
tree175c4c85a2c9e5810e4a8a34cc7b7cb3b843a414
parent302a5829d6e198ca17cdfd22ffa2503d1a5aec72 (diff)
downloadaur-1e5eb5f2bb8dac888221cff57f4b0fe9e822de4e.tar.gz
Update for python3 port and beautifulsoup4
We call setup.py explicitly with `python3` to get the right shebang (yes, seriously).
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 93268ebf907e..05cd05768f24 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = epfl-menu-git
pkgdesc = Pretty-print the lunch and supper menus at the EPFL
- pkgver = r10.9b4a45c
+ pkgver = r15.9ac9496
pkgrel = 1
url = https://github.com/gcmalloc/epfl-menu
arch = any
license = custom:Beerware
- makedepends = python2-setuptools
+ makedepends = python-setuptools
source = git+https://github.com/gcmalloc/epfl-menu
md5sums = SKIP
pkgname = epfl-menu-git
- depends = python2-beautifulsoup3
- depends = python2-urllib3
+ depends = python-beautifulsoup4
+ depends = python-urllib3
diff --git a/PKGBUILD b/PKGBUILD
index 02e47ece81ad..aec253540fb7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Tinu Weber <martin.weber@epfl.ch>
pkgname=epfl-menu-git
-pkgver=r10.9b4a45c
+pkgver=r15.9ac9496
pkgrel=1
pkgdesc='Pretty-print the lunch and supper menus at the EPFL'
arch=('any')
url='https://github.com/gcmalloc/epfl-menu'
license=('custom:Beerware')
-makedepends=('python2-setuptools')
+makedepends=('python-setuptools')
source=('git+https://github.com/gcmalloc/epfl-menu')
md5sums=('SKIP')
@@ -18,13 +18,13 @@ pkgver() {
build() {
cd "$srcdir/$pkgname"
- python2 setup.py build
+ python3 setup.py build
}
package() {
- depends=('python2-beautifulsoup3' 'python2-urllib3')
+ depends=('python-beautifulsoup4' 'python-urllib3')
cd "$srcdir/$pkgname"
- python2 setup.py install --root="$pkgdir" --optimize=1
+ python3 setup.py install --root="$pkgdir" --optimize=1
mv "$pkgdir"/usr/bin/menu "$pkgdir"/usr/bin/epfl-menu
mkdir -p "$pkgdir"/usr/share/licenses/epfl-menu
head -n 8 epfl/menu.py > "$pkgdir"/usr/share/licenses/epfl-menu/LICENSE