summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTinu Weber2017-05-23 17:55:54 +0200
committerTinu Weber2017-06-11 11:03:46 +0200
commit302a5829d6e198ca17cdfd22ffa2503d1a5aec72 (patch)
treec5af21d31830b62d030da7519b65f10126281a18
downloadaur-302a5829d6e198ca17cdfd22ffa2503d1a5aec72.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD31
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..93268ebf907e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = epfl-menu-git
+ pkgdesc = Pretty-print the lunch and supper menus at the EPFL
+ pkgver = r10.9b4a45c
+ pkgrel = 1
+ url = https://github.com/gcmalloc/epfl-menu
+ arch = any
+ license = custom:Beerware
+ makedepends = python2-setuptools
+ source = git+https://github.com/gcmalloc/epfl-menu
+ md5sums = SKIP
+
+pkgname = epfl-menu-git
+ depends = python2-beautifulsoup3
+ depends = python2-urllib3
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0866100e9dd9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/epfl-menu/
+/src/
+/pkg/
+/*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..02e47ece81ad
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Tinu Weber <martin.weber@epfl.ch>
+
+pkgname=epfl-menu-git
+pkgver=r10.9b4a45c
+pkgrel=1
+pkgdesc='Pretty-print the lunch and supper menus at the EPFL'
+arch=('any')
+url='https://github.com/gcmalloc/epfl-menu'
+license=('custom:Beerware')
+makedepends=('python2-setuptools')
+source=('git+https://github.com/gcmalloc/epfl-menu')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ python2 setup.py build
+}
+
+package() {
+ depends=('python2-beautifulsoup3' 'python2-urllib3')
+ cd "$srcdir/$pkgname"
+ python2 setup.py install --root="$pkgdir" --optimize=1
+ mv "$pkgdir"/usr/bin/menu "$pkgdir"/usr/bin/epfl-menu
+ mkdir -p "$pkgdir"/usr/share/licenses/epfl-menu
+ head -n 8 epfl/menu.py > "$pkgdir"/usr/share/licenses/epfl-menu/LICENSE
+}