summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorayekat2017-06-19 11:32:55 +0200
committerayekat2017-06-19 12:28:00 +0200
commit0b8be1d6bc05a4caff301b8d8fe132868a0f392a (patch)
treea939c70388933c83f8163a9b005803cb1189c6a2
downloadaur-0b8be1d6bc05a4caff301b8d8fe132868a0f392a.tar.gz
Initial commit
This PKGBUILD currently points to a fork, since some bug fixes [1] have not been merged upstream yet. [1] https://gitlab.gnugen.ch/gnugen/epfl-scripts/merge_requests/6
-rw-r--r--.SRCINFO26
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD32
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fa714e5f1649
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = epfl-scripts-git
+ pkgdesc = Collection of scripts for simplifying one's life at the EPFL
+ pkgver = r46.d6570b3
+ pkgrel = 1
+ url = https://gitlab.gnugen.ch/mtweber/epfl-scripts
+ arch = any
+ license = Apache
+ depends = coreutils
+ provides = epfl-scripts
+ conflicts = epfl-scripts
+ source = git+https://gitlab.gnugen.ch/mtweber/epfl-scripts.git
+ md5sums = SKIP
+
+pkgname = epfl-scripts-git
+ depends = coreutils
+ depends = curl
+ depends = file
+ depends = openconnect
+ depends = perl-html-tree
+ depends = perl-io-stringy
+ depends = perl-lwp-protocol-https
+ depends = perl-html-treebuilder-xpath
+ depends = perl-www-mechanize
+ depends = perl-xml-xpathengine
+ depends = sh
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4064b5f217f6
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/epfl-scripts/
+/src/
+/pkg/
+/*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c73722e4842b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Tinu Weber <martin.weber@epfl.ch>
+
+pkgname=epfl-scripts-git
+_pkgname=epfl-scripts
+pkgver=r46.d6570b3
+pkgrel=1
+pkgdesc="Collection of scripts for simplifying one's life at the EPFL"
+arch=('any')
+url='https://gitlab.gnugen.ch/mtweber/epfl-scripts'
+license=('Apache')
+provides=(epfl-scripts)
+conflicts=(epfl-scripts)
+depends=(coreutils)
+source=('git+https://gitlab.gnugen.ch/mtweber/epfl-scripts.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ depends+=(curl file openconnect perl-html-tree perl-io-stringy
+ perl-lwp-protocol-https perl-html-treebuilder-xpath
+ perl-www-mechanize perl-xml-xpathengine sh)
+ cd "$srcdir"/"$_pkgname"
+ install -Dm 755 bin/epfl-vpn "$pkgdir"/usr/bin/epfl-vpn
+ install -Dm 755 bin/gnupaste "$pkgdir"/usr/bin/gnupaste
+ install -Dm 755 bin/pastegnugen.pl "$pkgdir"/usr/bin/pastegnugen.pl
+ install -Dm 755 bin/tl.pl "$pkgdir"/usr/bin/tl.pl
+ install -Dm 755 bin/velo.pl "$pkgdir"/usr/bin/velo.pl
+}