summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorayekat2018-05-09 11:36:40 +0200
committerayekat2018-05-09 11:36:40 +0200
commitd53286016bfa1625b7abb25a07eafca39323bc78 (patch)
tree7f481bcd48560d270d64b5805ee4c215187ad263
parent36422922a4f83483a6d868a00541b067a554912d (diff)
downloadaur-d53286016bfa1625b7abb25a07eafca39323bc78.tar.gz
Bump version
* gnupaste: Correctly detect MIME encoding in text files. * PKGBUILD: Add missing dependency on `sh` (for systems where bash does not provide sh) + move around a few lines.
-rw-r--r--PKGBUILD15
1 files changed, 7 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 84a151d1aef3..931d229e5eb1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,11 @@
# Maintainer: Tinu Weber <martin.weber@epfl.ch>
pkgname=epfl-scripts-git
-_pkgname=epfl-scripts
-pkgver=r59.69f6024
+pkgver=r64.6f19292
pkgrel=1
+arch=(any)
pkgdesc="Collection of scripts for simplifying one's life at EPFL"
-arch=(any)
url='https://gitlab.gnugen.ch/gnugen/epfl-scripts'
license=(Apache)
@@ -14,23 +13,23 @@ provides=(epfl-scripts)
conflicts=(epfl-scripts)
depends=(coreutils)
+optdepends=('iproute2: network-namespaces in epfl-vpn'
+ 'iptables: network-namespaces in epfl-vpn')
source=('git+https://gitlab.gnugen.ch/gnugen/epfl-scripts.git')
md5sums=(SKIP)
pkgver() {
- cd "$_pkgname"
+ cd epfl-scripts
printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {
depends+=(curl bash file openconnect perl-html-tree perl-io-stringy
perl-lwp-protocol-https perl-html-treebuilder-xpath
- perl-www-mechanize perl-xml-xpathengine)
- optdepends=('iproute2: network-namespaces in epfl-vpn'
- 'iptables: network-namespaces in epfl-vpn')
+ perl-www-mechanize perl-xml-xpathengine sh)
- cd "$srcdir"/"$_pkgname"
+ cd epfl-scripts
install -Dm 755 bin/epfl-vpn "$pkgdir"/usr/bin/epfl-vpn
install -Dm 755 bin/gnupaste "$pkgdir"/usr/bin/gnupaste
install -Dm 755 bin/pastegnugen.pl "$pkgdir"/usr/bin/pastegnugen.pl