summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLouis Tim Larsen2020-03-24 23:30:20 +0100
committerLouis Tim Larsen2020-03-24 23:30:20 +0100
commit9ad9fe9bb9123eddf7be00f08e9fe03209979b0d (patch)
tree4361276f75509a457f153681b2a56d692d99d6db
downloadaur-9ad9fe9bb9123eddf7be00f08e9fe03209979b0d.tar.gz
v. 6.3.1
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD33
-rw-r--r--disable_paid_and_native_infobars.patch17
-rw-r--r--ephemeral.install15
4 files changed, 92 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8e4f08fd1b19
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = ephemeral
+ pkgdesc = A private-by-default, always-incognito browser for elementary OS.
+ pkgver = 6.3.1
+ pkgrel = 1
+ url = https://github.com/cassidyjames/ephemeral
+ install = ephemeral.install
+ arch = x86_64
+ license = GPL3
+ makedepends = meson
+ makedepends = vala
+ depends = dconf
+ depends = desktop-file-utils
+ depends = glib2>=2.49.2
+ depends = granite>=5.2.3
+ depends = gtk3>=3.22.29
+ depends = hicolor-icon-theme
+ depends = libdazzle>=3.25.3
+ depends = libgee>=0.8.3
+ depends = libsoup>=2.32.2
+ depends = webkit2gtk>=2.15.4
+ source = ephemeral_6.3.1.tar.gz::https://github.com/cassidyjames/ephemeral/archive/6.3.1.tar.gz
+ source = disable_paid_and_native_infobars.patch
+ sha512sums = b0663bf63906e08c15f3e9864ed8920af197fff84139d6e829bf3389bae33cadfa486b13484dd9c3581143d543dbef6430b87335350988b774901a48a57d062f
+ sha512sums = f02f2a25b9acffc52df02322813d0536ea823fdc5deec234b4e49e9441054421d8c2621911b64acf78cc2e6f156d6193e8b100b780e76fd4e0e7b554e1c83b16
+
+pkgname = ephemeral
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a51f43d28978
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Louis Tim Larsen <louis(a)louis.dk>
+
+pkgname=ephemeral
+pkgver=6.3.1
+pkgrel=1
+pkgdesc="A private-by-default, always-incognito browser for elementary OS."
+arch=('x86_64')
+url="https://github.com/cassidyjames/ephemeral"
+license=('GPL3')
+makedepends=('meson' 'vala')
+depends=('dconf' 'desktop-file-utils' 'glib2>=2.49.2' 'granite>=5.2.3' 'gtk3>=3.22.29' 'hicolor-icon-theme' 'libdazzle>=3.25.3' 'libgee>=0.8.3' 'libsoup>=2.32.2' 'webkit2gtk>=2.15.4')
+install=${pkgname}.install
+source=("${pkgname}_${pkgver}.tar.gz::https://github.com/cassidyjames/${pkgname}/archive/${pkgver}.tar.gz"
+ "disable_paid_and_native_infobars.patch")
+sha512sums=('b0663bf63906e08c15f3e9864ed8920af197fff84139d6e829bf3389bae33cadfa486b13484dd9c3581143d543dbef6430b87335350988b774901a48a57d062f'
+ 'f02f2a25b9acffc52df02322813d0536ea823fdc5deec234b4e49e9441054421d8c2621911b64acf78cc2e6f156d6193e8b100b780e76fd4e0e7b554e1c83b16')
+
+#prepare() {
+# cd "${srcdir}/${pkgname}-${pkgver}"
+## Disable InfoBar warnings for donation recommendation and app not running on ElementaryOS.
+# patch -Np1 < ../../disable_paid_and_native_infobars.patch
+#}
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ meson build --prefix=/usr
+ ninja -C build
+}
+
+package(){
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ DESTDIR="$pkgdir" ninja -C build install
+}
diff --git a/disable_paid_and_native_infobars.patch b/disable_paid_and_native_infobars.patch
new file mode 100644
index 000000000000..8b4262aad348
--- /dev/null
+++ b/disable_paid_and_native_infobars.patch
@@ -0,0 +1,17 @@
+ {a => b}/src/Application.vala | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+diff --git a/src/Application.vala b/src/Application.vala
+index 74f5cd2..7d7dbde 100644
+--- a/src/Application.vala
++++ b/src/Application.vala
+@@ -40,8 +40,8 @@ public class Ephemeral.Application : Gtk.Application {
+ public Gtk.IconSize icon_size = Gtk.IconSize.SMALL_TOOLBAR;
+
+ public bool ask_default_for_session = true;
+- public bool warn_native_for_session = true;
+- public bool warn_paid_for_session = true;
++ public bool warn_native_for_session = false;
++ public bool warn_paid_for_session = false;
+ public int64 last_external_open = int64.MIN;
+
+ private bool opening_link = false;
diff --git a/ephemeral.install b/ephemeral.install
new file mode 100644
index 000000000000..604fc3d5935c
--- /dev/null
+++ b/ephemeral.install
@@ -0,0 +1,15 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ update-desktop-database -q
+}
+
+