summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLouis Tim Larsen2019-06-06 23:20:29 +0200
committerLouis Tim Larsen2019-06-06 23:20:29 +0200
commit464b9e73d6c284190f7167244bcd01a7791ad022 (patch)
tree0a28a6dac9c74435bc2c857ac38092ada2dc0d52
downloadaur-464b9e73d6c284190f7167244bcd01a7791ad022.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD32
-rw-r--r--ephemeral-bin.install13
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1e3ea5a3aa7a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = ephemeral-bin
+ pkgdesc = The always-incognito web browser. Browse the Internet in private without leaving a trace of history on your computer.
+ pkgver = 5.1.0
+ pkgrel = 1
+ url = https://github.com/cassidyjames/ephemeral
+ install = ephemeral-bin.install
+ arch = x86_64
+ license = GPL3
+ depends = dconf
+ depends = desktop-file-utils
+ depends = glib2>=2.49.2
+ depends = granite>=5.2.3
+ depends = gtk3>=3.22.29
+ depends = hicolor-icon-theme
+ depends = libdazzle>=3.25.3
+ depends = libgee>=0.8.3
+ depends = libsoup>=2.32.2
+ depends = webkit2gtk>=2.15.4
+ source = http://packages.elementary.io/appcenter/pool/main/c/com.github.cassidyjames.ephemeral/com.github.cassidyjames.ephemeral5.1.0-be6d31.deb
+ sha512sums = 2ad4b35bf95129b91fb4149bd3515a852beb65ae4d32bf79f072a4e1d33826398c4483f3d74eae24681916b773d86494d1df77aa8cdd611056f9b29202d53011
+
+pkgname = ephemeral-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0af248aeec8e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Louis Tim Larsen <louis(a)louis.dk>
+pkgname=ephemeral-bin
+_appname=ephemeral
+_projectname=com.github.cassidyjames.ephemeral
+pkgver=5.1.0
+_subver=be6d31
+pkgrel=1
+pkgdesc="The always-incognito web browser. Browse the Internet in private without leaving a trace of history on your computer."
+arch=('x86_64')
+url="https://github.com/cassidyjames/ephemeral"
+license=('GPL3')
+depends=('dconf' 'desktop-file-utils' 'glib2>=2.49.2' 'granite>=5.2.3' 'gtk3>=3.22.29' 'hicolor-icon-theme' 'libdazzle>=3.25.3' 'libgee>=0.8.3' 'libsoup>=2.32.2' 'webkit2gtk>=2.15.4')
+install=${pkgname}.install
+source=("http://packages.elementary.io/appcenter/pool/main/c/${_projectname}/${_projectname}${pkgver}-${_subver}.deb")
+sha512sums=('2ad4b35bf95129b91fb4149bd3515a852beb65ae4d32bf79f072a4e1d33826398c4483f3d74eae24681916b773d86494d1df77aa8cdd611056f9b29202d53011')
+
+package(){
+
+ # Extract package data
+ tar xf data.tar.xz -C "${pkgdir}"
+
+ # Rename major files from for better system integration
+ mv "${pkgdir}/usr/bin/${_projectname}" "${pkgdir}/usr/bin/${_appname}"
+ mv "${pkgdir}/usr/share/applications/${_projectname}.desktop" "${pkgdir}/usr/share/applications/${_appname}.desktop"
+ mv "${pkgdir}/usr/share/doc/${_projectname}" "${pkgdir}/usr/share/doc/${_appname}"
+ # Update desktop file to match renamed package binary
+ sed -i "s/Exec=${_projectname}/Exec=${_appname}/" "${pkgdir}/usr/share/applications/${_appname}.desktop"
+
+ # Install license file
+ install -D -m644 "${srcdir}/usr/share/doc/${_projectname}/copyright" "${pkgdir}/usr/share/licenses/${_appname}/LICENSE"
+
+}
diff --git a/ephemeral-bin.install b/ephemeral-bin.install
new file mode 100644
index 000000000000..b50ffb36e4a2
--- /dev/null
+++ b/ephemeral-bin.install
@@ -0,0 +1,13 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ update-desktop-database -q
+}