summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-08-03 13:39:57 +0800
committerzxp198210052023-08-03 13:39:57 +0800
commit12241f9a1abc26f7e7be04f7bfb716c379330688 (patch)
treed3cf9ece9337021e3d0da5aef0aaa00e90396466
parentc6ad8d5ce0dba50df9948c9fdbae50e6fe8481d5 (diff)
downloadaur-12241f9a1abc26f7e7be04f7bfb716c379330688.tar.gz
optimized PKGBUILD
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
-rw-r--r--epherome.sh6
3 files changed, 16 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d9ed88453131..1b0efd28559f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
pkgbase = epherome-bin
pkgdesc = Powerful Minecraft Launcher
pkgver = 0.7.1
- pkgrel = 2
+ pkgrel = 3
url = https://epherome.com/
arch = x86_64
license = GPL3
+ depends = bash
depends = electron22
+ provides = epherome-0.7.1
conflicts = epherome
source = epherome-0.7.1.deb::https://github.com/ResetPower/Epherome/releases/download/0.7.1/Epherome-0.7.1.deb
source = epherome.sh
sha256sums = 7dc740a18e73eb11aaa1ef7dad8342857ab043fb81112dac36129a1f895e49a5
- sha256sums = 27f62dc41f3ef267428cd283b3149c6e31cac8aa891a659e2cf9c5eea1f3fb51
+ sha256sums = 0931eb0e8554fa09bc8f4e401d7d54ac5c2d67910189f402b35944194455d907
pkgname = epherome-bin
diff --git a/PKGBUILD b/PKGBUILD
index a83fad0eadf3..47c4b9e4a446 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,25 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
-pkgname="epherome-bin"
+pkgname=epherome-bin
+_appname=Epherome
pkgver=0.7.1
-pkgrel=2
+pkgrel=3
pkgdesc="Powerful Minecraft Launcher"
arch=('x86_64')
license=('GPL3')
+provides=("${pkgname%-bin}-${pkgver}")
conflicts=("${pkgname%-bin}")
url="https://epherome.com/"
_githuburl="https://github.com/ResetPower/Epherome"
-depends=('electron22')
+depends=('bash' 'electron22')
source=("${pkgname%-bin}-${pkgver}.deb::${_githuburl}/releases/download/${pkgver}/Epherome-${pkgver}.deb"
"${pkgname%-bin}.sh")
sha256sums=('7dc740a18e73eb11aaa1ef7dad8342857ab043fb81112dac36129a1f895e49a5'
- '27f62dc41f3ef267428cd283b3149c6e31cac8aa891a659e2cf9c5eea1f3fb51')
+ '0931eb0e8554fa09bc8f4e401d7d54ac5c2d67910189f402b35944194455d907')
package(){
bsdtar -xf "${srcdir}/data.tar.xz"
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}"
- install -Dm644 "${srcdir}/opt/Epherome/resources/app.asar" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}.asar"
- sed "s|/opt/Epherome/${pkgname%-bin} %U||g" -i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
+ install -Dm644 "${srcdir}/opt/${_appname}/resources/app.asar" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}.asar"
+ sed "s|/opt/${_appname}/${pkgname%-bin} %U||g" -i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
install -Dm644 "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
install -Dm644 "${srcdir}/usr/share/icons/hicolor/0x0/apps/${pkgname%-bin}.png" -t "${pkgdir}/usr/share/pixmaps"
} \ No newline at end of file
diff --git a/epherome.sh b/epherome.sh
index a2fedfd41500..887f423e8e38 100644
--- a/epherome.sh
+++ b/epherome.sh
@@ -1,6 +1,8 @@
#!/bin/bash
+_ELECTRON=/usr/bin/electron24
+_ASAR="/opt/epherome/epherome.asar"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron22 /opt/epherome/epherome.asar "$@"
+ exec ${_ELECTRON} ${_ASAR} "$@"
else
- exec electron22 --no-sandbox /opt/epherome/epherome.asar "$@"
+ exec ${_ELECTRON} ${_ASAR} --no-sandbox "$@"
fi \ No newline at end of file