summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-11-14 10:08:08 +0800
committerzxp198210052023-11-14 10:08:08 +0800
commit6c9b70edf26225862de667c8d4fd5854f9245862 (patch)
tree5d40009c2b2533de34cc3ee9919578592e4b0498
parent88f41c610e576f7b0e58234f1494564c179ca916 (diff)
downloadaur-6c9b70edf26225862de667c8d4fd5854f9245862.tar.gz
fix errors
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD20
-rw-r--r--epherome.sh5
3 files changed, 18 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d3968e90db22..cd233c05b937 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
pkgbase = epherome-bin
pkgdesc = Powerful Minecraft Launcher
pkgver = 0.7.1
- pkgrel = 5
+ pkgrel = 6
url = https://epherome.com/
arch = x86_64
license = GPL3
- depends = bash
depends = electron22
provides = epherome=0.7.1
conflicts = epherome
source = epherome-0.7.1.deb::https://github.com/ResetPower/Epherome/releases/download/0.7.1/Epherome-0.7.1.deb
source = epherome.sh
sha256sums = 7dc740a18e73eb11aaa1ef7dad8342857ab043fb81112dac36129a1f895e49a5
- sha256sums = 11473bfa2ed6789f116a8d75e4e93d98ecfaecaa979d3ec7f777f597c0a512ad
+ sha256sums = 57044c59941da6ee1faf765cca7401fb9d796591c63738e3282d8d05c58dd6b8
pkgname = epherome-bin
diff --git a/PKGBUILD b/PKGBUILD
index 7330d71888e8..b32f34345f9a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,26 +2,30 @@
pkgname=epherome-bin
_pkgname=Epherome
pkgver=0.7.1
-pkgrel=5
+pkgrel=6
pkgdesc="Powerful Minecraft Launcher"
url="https://epherome.com/"
-_githuburl="https://github.com/ResetPower/Epherome"
+_ghurl="https://github.com/ResetPower/Epherome"
arch=('x86_64')
license=('GPL3')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
-depends=('bash' 'electron22')
-source=("${pkgname%-bin}-${pkgver}.deb::${_githuburl}/releases/download/${pkgver}/${_pkgname}-${pkgver}.deb"
- "${pkgname%-bin}.sh")
+depends=(
+ 'electron22'
+)
+source=(
+ "${pkgname%-bin}-${pkgver}.deb::${_ghurl}/releases/download/${pkgver}/${_pkgname}-${pkgver}.deb"
+ "${pkgname%-bin}.sh"
+)
sha256sums=('7dc740a18e73eb11aaa1ef7dad8342857ab043fb81112dac36129a1f895e49a5'
- '11473bfa2ed6789f116a8d75e4e93d98ecfaecaa979d3ec7f777f597c0a512ad')
-prepare() {
+ '57044c59941da6ee1faf765cca7401fb9d796591c63738e3282d8d05c58dd6b8')
+build() {
bsdtar -xf "${srcdir}/data.tar.xz"
sed "s|/opt/${_pkgname}/${pkgname%-bin} %U|${pkgname%-bin}|g" -i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
- install -Dm644 "${srcdir}/opt/${_pkgname}/resources/app.asar" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}.asar"
+ install -Dm644 "${srcdir}/opt/${_pkgname}/resources/app.asar" -t "${pkgdir}/usr/lib/${pkgname%-bin}"
install -Dm644 "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
install -Dm644 "${srcdir}/usr/share/icons/hicolor/0x0/apps/${pkgname%-bin}.png" -t "${pkgdir}/usr/share/pixmaps"
} \ No newline at end of file
diff --git a/epherome.sh b/epherome.sh
index e850be0c4bbb..7fab2ba2a074 100644
--- a/epherome.sh
+++ b/epherome.sh
@@ -1,6 +1,9 @@
#!/bin/bash
_ELECTRON=/usr/bin/electron22
-_ASAR="/opt/epherome/epherome.asar"
+APPDIR="/usr/lib/epherome"
+export PATH="${APPDIR}:${PATH}"
+#export LD_LIBRARY_PATH="${APPDIR}/swiftshader:${LD_LIBRARY_PATH}"
+_ASAR="${APPDIR}/app.asar"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
exec ${_ELECTRON} ${_ASAR} "$@"
else