summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-08-03 13:40:37 +0800
committerzxp198210052023-08-03 13:40:37 +0800
commit7040eca14c024a397fb8bdde8c15fd28afc4163a (patch)
tree20f7f2de6a8c43e01f68593b04ae0a1f062bdac1
parent12241f9a1abc26f7e7be04f7bfb716c379330688 (diff)
downloadaur-7040eca14c024a397fb8bdde8c15fd28afc4163a.tar.gz
optimized PKGBUILD
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--epherome.sh2
3 files changed, 3 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1b0efd28559f..08b02097044f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -12,6 +12,6 @@ pkgbase = epherome-bin
source = epherome-0.7.1.deb::https://github.com/ResetPower/Epherome/releases/download/0.7.1/Epherome-0.7.1.deb
source = epherome.sh
sha256sums = 7dc740a18e73eb11aaa1ef7dad8342857ab043fb81112dac36129a1f895e49a5
- sha256sums = 0931eb0e8554fa09bc8f4e401d7d54ac5c2d67910189f402b35944194455d907
+ sha256sums = 11473bfa2ed6789f116a8d75e4e93d98ecfaecaa979d3ec7f777f597c0a512ad
pkgname = epherome-bin
diff --git a/PKGBUILD b/PKGBUILD
index 47c4b9e4a446..20d19b9181e5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,7 +14,7 @@ depends=('bash' 'electron22')
source=("${pkgname%-bin}-${pkgver}.deb::${_githuburl}/releases/download/${pkgver}/Epherome-${pkgver}.deb"
"${pkgname%-bin}.sh")
sha256sums=('7dc740a18e73eb11aaa1ef7dad8342857ab043fb81112dac36129a1f895e49a5'
- '0931eb0e8554fa09bc8f4e401d7d54ac5c2d67910189f402b35944194455d907')
+ '11473bfa2ed6789f116a8d75e4e93d98ecfaecaa979d3ec7f777f597c0a512ad')
package(){
bsdtar -xf "${srcdir}/data.tar.xz"
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}"
diff --git a/epherome.sh b/epherome.sh
index 887f423e8e38..e850be0c4bbb 100644
--- a/epherome.sh
+++ b/epherome.sh
@@ -1,5 +1,5 @@
#!/bin/bash
-_ELECTRON=/usr/bin/electron24
+_ELECTRON=/usr/bin/electron22
_ASAR="/opt/epherome/epherome.asar"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
exec ${_ELECTRON} ${_ASAR} "$@"