summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-03-19 09:21:51 +0800
committerzxp198210052024-03-19 09:21:51 +0800
commit933caca6b5708e0c7063ee7288253cdee1a77c8b (patch)
tree7fd88aa6b352b76005e4645217ed5bf64f3c1b04
parent4976ea488a754dd21ddbc789902c229105c0bc9c (diff)
downloadaur-933caca6b5708e0c7063ee7288253cdee1a77c8b.tar.gz
fix errors
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
-rw-r--r--epherome.sh5
3 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fac2d72ac9d1..09566b9c0b43 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = epherome-bin
pkgdesc = Powerful Minecraft Launcher
pkgver = 0.7.1
- pkgrel = 9
+ pkgrel = 10
url = https://epherome.com/
arch = x86_64
license = GPL-3.0-only
@@ -11,6 +11,6 @@ pkgbase = epherome-bin
source = epherome-0.7.1.deb::https://github.com/ResetPower/Epherome/releases/download/0.7.1/Epherome-0.7.1.deb
source = epherome.sh
sha256sums = 7dc740a18e73eb11aaa1ef7dad8342857ab043fb81112dac36129a1f895e49a5
- sha256sums = 50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe
+ sha256sums = dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8
pkgname = epherome-bin
diff --git a/PKGBUILD b/PKGBUILD
index 39867f341e12..e6fee64a9125 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgname=epherome-bin
_pkgname=Epherome
pkgver=0.7.1
_electronversion=22
-pkgrel=9
+pkgrel=10
pkgdesc="Powerful Minecraft Launcher"
url="https://epherome.com/"
_ghurl="https://github.com/ResetPower/Epherome"
@@ -19,11 +19,12 @@ source=(
"${pkgname%-bin}.sh"
)
sha256sums=('7dc740a18e73eb11aaa1ef7dad8342857ab043fb81112dac36129a1f895e49a5'
- '50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe')
+ 'dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
build() {
sed -e "s|@electronversion@|${_electronversion}|g" \
-e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@runname@|app.asar|g" \
+ -e "s|@options@||g" \
-i "${srcdir}/${pkgname%-bin}.sh"
bsdtar -xf "${srcdir}/data."*
sed "s|/opt/${_pkgname}/${pkgname%-bin}|${pkgname%-bin}|g" -i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
diff --git a/epherome.sh b/epherome.sh
index 86cb3dc6a9bf..7ddcaab8d734 100644
--- a/epherome.sh
+++ b/epherome.sh
@@ -2,6 +2,7 @@
set -e
_APPDIR="/usr/lib/@appname@"
_RUNNAME="${_APPDIR}/@runname@"
+_OPTIONS="@options@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
@@ -9,7 +10,7 @@ export ELECTRON_FORCE_IS_PACKAGED=true
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" "$@" || exit $?
else
- exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" --no-sandbox "$@" || exit $?
fi \ No newline at end of file