summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-07-13 09:21:07 +0800
committerzxp198210052023-07-13 09:21:07 +0800
commitc6ad8d5ce0dba50df9948c9fdbae50e6fe8481d5 (patch)
tree4da54b0588c8b94f901ac5616ebce884c95d25f9
parent901f5333bb019cdbaf2404eb00169d5201537cbf (diff)
downloadaur-c6ad8d5ce0dba50df9948c9fdbae50e6fe8481d5.tar.gz
optimized PKGBUILD
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD18
-rw-r--r--epherome.sh6
3 files changed, 22 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eced9c8da1d2..d9ed88453131 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,36 +1,15 @@
pkgbase = epherome-bin
pkgdesc = Powerful Minecraft Launcher
pkgver = 0.7.1
- pkgrel = 1
+ pkgrel = 2
url = https://epherome.com/
arch = x86_64
license = GPL3
- depends = alsa-lib
- depends = mesa
- depends = hicolor-icon-theme
- depends = libxcb
- depends = libcups
- depends = gtk3
- depends = dbus
- depends = libxdamage
- depends = gcc-libs
- depends = nspr
- depends = nss
- depends = libxext
- depends = libx11
- depends = libxkbcommon
- depends = cairo
- depends = libxcomposite
- depends = libdrm
- depends = libxrandr
- depends = expat
- depends = glibc
- depends = glib2
- depends = pango
- depends = at-spi2-core
- depends = libxfixes
+ depends = electron22
conflicts = epherome
source = epherome-0.7.1.deb::https://github.com/ResetPower/Epherome/releases/download/0.7.1/Epherome-0.7.1.deb
+ source = epherome.sh
sha256sums = 7dc740a18e73eb11aaa1ef7dad8342857ab043fb81112dac36129a1f895e49a5
+ sha256sums = 27f62dc41f3ef267428cd283b3149c6e31cac8aa891a659e2cf9c5eea1f3fb51
pkgname = epherome-bin
diff --git a/PKGBUILD b/PKGBUILD
index 55de8c382a54..a83fad0eadf3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,23 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname="epherome-bin"
pkgver=0.7.1
-pkgrel=1
+pkgrel=2
pkgdesc="Powerful Minecraft Launcher"
arch=('x86_64')
license=('GPL3')
conflicts=("${pkgname%-bin}")
url="https://epherome.com/"
_githuburl="https://github.com/ResetPower/Epherome"
-depends=('alsa-lib' 'mesa' 'hicolor-icon-theme' 'libxcb' 'libcups' 'gtk3' 'dbus' 'libxdamage' 'gcc-libs' 'nspr' 'nss' \
- 'libxext' 'libx11' 'libxkbcommon' 'cairo' 'libxcomposite' 'libdrm' 'libxrandr' 'expat' 'glibc' 'glib2' 'pango' 'at-spi2-core' 'libxfixes')
-source=("${pkgname%-bin}-${pkgver}.deb::${_githuburl}/releases/download/${pkgver}/Epherome-${pkgver}.deb")
-sha256sums=('7dc740a18e73eb11aaa1ef7dad8342857ab043fb81112dac36129a1f895e49a5')
+depends=('electron22')
+source=("${pkgname%-bin}-${pkgver}.deb::${_githuburl}/releases/download/${pkgver}/Epherome-${pkgver}.deb"
+ "${pkgname%-bin}.sh")
+sha256sums=('7dc740a18e73eb11aaa1ef7dad8342857ab043fb81112dac36129a1f895e49a5'
+ '27f62dc41f3ef267428cd283b3149c6e31cac8aa891a659e2cf9c5eea1f3fb51')
package(){
- bsdtar -xf "${srcdir}/data.tar.xz" -C "${pkgdir}"
+ bsdtar -xf "${srcdir}/data.tar.xz"
+ install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/opt/Epherome/resources/app.asar" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}.asar"
+ sed "s|/opt/Epherome/${pkgname%-bin} %U||g" -i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
+ install -Dm644 "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
+ install -Dm644 "${srcdir}/usr/share/icons/hicolor/0x0/apps/${pkgname%-bin}.png" -t "${pkgdir}/usr/share/pixmaps"
} \ No newline at end of file
diff --git a/epherome.sh b/epherome.sh
new file mode 100644
index 000000000000..a2fedfd41500
--- /dev/null
+++ b/epherome.sh
@@ -0,0 +1,6 @@
+#!/bin/bash
+if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
+ exec electron22 /opt/epherome/epherome.asar "$@"
+else
+ exec electron22 --no-sandbox /opt/epherome/epherome.asar "$@"
+fi \ No newline at end of file