summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-01-25 18:35:31 +0800
committerzxp198210052024-01-25 18:35:31 +0800
commitd59a564e548589a3780166164469072e4ab07a76 (patch)
tree203c957d0ffc431170084834f0aca9f897d3800f
parentf72441813534690b7d5db1dcea45127cb813e3f9 (diff)
downloadaur-d59a564e548589a3780166164469072e4ab07a76.tar.gz
fix errors
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--epherome.sh9
3 files changed, 9 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1796e92b7dcd..75b5ff09a525 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = epherome-bin
pkgdesc = Powerful Minecraft Launcher
pkgver = 0.7.1
- pkgrel = 7
+ pkgrel = 8
url = https://epherome.com/
arch = x86_64
- license = GPL3
+ license = GPL-3.0-only
depends = electron22
provides = epherome=0.7.1
conflicts = epherome
source = epherome-0.7.1.deb::https://github.com/ResetPower/Epherome/releases/download/0.7.1/Epherome-0.7.1.deb
source = epherome.sh
sha256sums = 7dc740a18e73eb11aaa1ef7dad8342857ab043fb81112dac36129a1f895e49a5
- sha256sums = 5ce46265f0335b03568aa06f7b4c57c5f8ffade7a226489ea39796be91a511bf
+ sha256sums = 1d3f21d54a2d9d1a53661bd91c2afd00df79b0ce4057a66b4c953febfc464cd8
pkgname = epherome-bin
diff --git a/PKGBUILD b/PKGBUILD
index 23440004b439..2e70fd8b7115 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,12 @@ pkgname=epherome-bin
_pkgname=Epherome
pkgver=0.7.1
_electronversion=22
-pkgrel=7
+pkgrel=8
pkgdesc="Powerful Minecraft Launcher"
url="https://epherome.com/"
_ghurl="https://github.com/ResetPower/Epherome"
arch=('x86_64')
-license=('GPL3')
+license=('GPL-3.0-only')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
depends=(
@@ -19,7 +19,7 @@ source=(
"${pkgname%-bin}.sh"
)
sha256sums=('7dc740a18e73eb11aaa1ef7dad8342857ab043fb81112dac36129a1f895e49a5'
- '5ce46265f0335b03568aa06f7b4c57c5f8ffade7a226489ea39796be91a511bf')
+ '1d3f21d54a2d9d1a53661bd91c2afd00df79b0ce4057a66b4c953febfc464cd8')
build() {
sed -e "s|@electronversion@|${_electronversion}|g" \
-e "s|@appname@|${pkgname%-bin}|g" \
diff --git a/epherome.sh b/epherome.sh
index c77c53567639..0d20cddc70ca 100644
--- a/epherome.sh
+++ b/epherome.sh
@@ -6,12 +6,9 @@ export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
export NODE_ENV=production
+cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- cd "${_APPDIR}"
- exec electron@electronversion@ "${_ASAR}" "$@"
- exit
+ exec electron@electronversion@ "${_ASAR}" "$@" || exit $?
else
- cd "${_APPDIR}"
- exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
- exit
+ exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@" || exit $?
fi \ No newline at end of file