summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-12-20 18:17:19 +0800
committerzxp198210052023-12-20 18:17:19 +0800
commitf72441813534690b7d5db1dcea45127cb813e3f9 (patch)
treee45413e47cd2348ec6ad153f63aa3f104a7a54dc
parent6c9b70edf26225862de667c8d4fd5854f9245862 (diff)
downloadaur-f72441813534690b7d5db1dcea45127cb813e3f9.tar.gz
update to 0.38.3
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
-rw-r--r--epherome.sh22
3 files changed, 25 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cd233c05b937..1796e92b7dcd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = epherome-bin
pkgdesc = Powerful Minecraft Launcher
pkgver = 0.7.1
- pkgrel = 6
+ pkgrel = 7
url = https://epherome.com/
arch = x86_64
license = GPL3
@@ -11,6 +11,6 @@ pkgbase = epherome-bin
source = epherome-0.7.1.deb::https://github.com/ResetPower/Epherome/releases/download/0.7.1/Epherome-0.7.1.deb
source = epherome.sh
sha256sums = 7dc740a18e73eb11aaa1ef7dad8342857ab043fb81112dac36129a1f895e49a5
- sha256sums = 57044c59941da6ee1faf765cca7401fb9d796591c63738e3282d8d05c58dd6b8
+ sha256sums = 5ce46265f0335b03568aa06f7b4c57c5f8ffade7a226489ea39796be91a511bf
pkgname = epherome-bin
diff --git a/PKGBUILD b/PKGBUILD
index b32f34345f9a..23440004b439 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,8 @@
pkgname=epherome-bin
_pkgname=Epherome
pkgver=0.7.1
-pkgrel=6
+_electronversion=22
+pkgrel=7
pkgdesc="Powerful Minecraft Launcher"
url="https://epherome.com/"
_ghurl="https://github.com/ResetPower/Epherome"
@@ -11,17 +12,21 @@ license=('GPL3')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
depends=(
- 'electron22'
+ "electron${_electronversion}"
)
source=(
"${pkgname%-bin}-${pkgver}.deb::${_ghurl}/releases/download/${pkgver}/${_pkgname}-${pkgver}.deb"
"${pkgname%-bin}.sh"
)
sha256sums=('7dc740a18e73eb11aaa1ef7dad8342857ab043fb81112dac36129a1f895e49a5'
- '57044c59941da6ee1faf765cca7401fb9d796591c63738e3282d8d05c58dd6b8')
+ '5ce46265f0335b03568aa06f7b4c57c5f8ffade7a226489ea39796be91a511bf')
build() {
+ sed -e "s|@electronversion@|${_electronversion}|g" \
+ -e "s|@appname@|${pkgname%-bin}|g" \
+ -e "s|@appasar@|app.asar|g" \
+ -i "${srcdir}/${pkgname%-bin}.sh"
bsdtar -xf "${srcdir}/data.tar.xz"
- sed "s|/opt/${_pkgname}/${pkgname%-bin} %U|${pkgname%-bin}|g" -i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
+ sed "s|/opt/${_pkgname}/${pkgname%-bin}|${pkgname%-bin}|g" -i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
diff --git a/epherome.sh b/epherome.sh
index 7fab2ba2a074..c77c53567639 100644
--- a/epherome.sh
+++ b/epherome.sh
@@ -1,11 +1,17 @@
-#!/bin/bash
-_ELECTRON=/usr/bin/electron22
-APPDIR="/usr/lib/epherome"
-export PATH="${APPDIR}:${PATH}"
-#export LD_LIBRARY_PATH="${APPDIR}/swiftshader:${LD_LIBRARY_PATH}"
-_ASAR="${APPDIR}/app.asar"
+#!/bin/sh
+set -e
+_APPDIR="/usr/lib/@appname@"
+_ASAR="${_APPDIR}/@appasar@"
+export PATH="${_APPDIR}:${PATH}"
+export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
+export ELECTRON_IS_DEV=0
+export NODE_ENV=production
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec ${_ELECTRON} ${_ASAR} "$@"
+ cd "${_APPDIR}"
+ exec electron@electronversion@ "${_ASAR}" "$@"
+ exit
else
- exec ${_ELECTRON} ${_ASAR} --no-sandbox "$@"
+ cd "${_APPDIR}"
+ exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
+ exit
fi \ No newline at end of file