summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSergey Malkin2018-02-02 10:18:44 +0300
committerSergey Malkin2018-02-02 10:18:44 +0300
commit81e6943fb491bffc25b542fe0cf3af3dd54b0a5a (patch)
tree8983486ffe8da99f7605735addcc55b121a3201a
downloadaur-81e6943fb491bffc25b542fe0cf3af3dd54b0a5a.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD23
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5cb91368c053
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Fri Feb 2 07:18:39 UTC 2018
+pkgbase = ephyviewer
+ pkgdesc = A Python package for handling physical quantities.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = http://packages.python.org/quantities
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ depends = python
+ depends = python-neo-git
+ depends = python-pyqtgraph
+ source = https://github.com/NeuralEnsemble/ephyviewer/archive/1.0.0.tar.gz
+ md5sums = d2cb03ebdd881fd5c9ccc306ee970156
+
+pkgname = ephyviewer
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..46ac5a44fd2f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Sergey Malkin <adresatt@gmail.com>
+
+pkgname=ephyviewer
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="A Python package for handling physical quantities."
+url="http://packages.python.org/quantities"
+arch=("any")
+license=("BSD")
+depends=("python" "python-neo-git" "python-pyqtgraph")
+makedepends=("python-setuptools")
+source=("https://github.com/NeuralEnsemble/${pkgname}/archive/${pkgver}.tar.gz")
+md5sums=("d2cb03ebdd881fd5c9ccc306ee970156")
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python setup.py install --prefix=/usr --root=${pkgdir}
+}