summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYosef Or Boczko2015-06-08 18:04:01 +0300
committerYosef Or Boczko2015-06-08 18:04:01 +0300
commit3fe5aaf320699fd7f1c293aec48b118ed4291f97 (patch)
tree78bf2268878f8966972b2ef509ef59dd48b0f967
downloadaur-3fe5aaf320699fd7f1c293aec48b118ed4291f97.tar.gz
Initial import
-rw-r--r--.SRCINFO44
-rw-r--r--PKGBUILD49
-rw-r--r--epiphany.install13
3 files changed, 106 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4bb51e12f438
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,44 @@
+pkgbase = epiphany-git
+ pkgdesc = A GNOME web browser based on the WebKit rendering engine.
+ pkgver = 3.16.1.6.ga966acc
+ pkgrel = 1
+ url = http://www.gnome.org/projects/epiphany/
+ install = epiphany.install
+ arch = i686
+ arch = x86_64
+ groups = gnome
+ license = GPL
+ makedepends = intltool
+ makedepends = gnome-doc-utils
+ makedepends = gnome-common
+ makedepends = git
+ makedepends = startup-notification
+ makedepends = yelp-tools
+ depends = glib2
+ depends = gtk3>=3.13.0
+ depends = libsoup>=2.48.0
+ depends = libnotify
+ depends = gsettings-desktop-schemas
+ depends = webkit2gtk>=2.7.4
+ depends = nss
+ depends = iso-codes
+ depends = dconf
+ depends = gobject-introspection
+ depends = desktop-file-utils
+ depends = libxml2
+ depends = libsecret
+ depends = hicolor-icon-theme
+ depends = gcr
+ depends = gnome-desktop
+ depends = libwnck3
+ depends = avahi
+ provides = epiphany=3.16.1
+ conflicts = epiphany
+ replaces = epiphany
+ options = !libtool
+ options = !emptydirs
+ source = git://git.gnome.org/epiphany
+ sha256sums = SKIP
+
+pkgname = epiphany-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1587709c265e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Yosef Or Boczko <yoseforb@gnome.org>
+
+_pkgname=epiphany
+pkgname=$_pkgname-git
+pkgver=3.16.1.6.ga966acc
+pkgrel=1
+_realver=3.16.1
+install=epiphany.install
+pkgdesc="A GNOME web browser based on the WebKit rendering engine."
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=("glib2" "gtk3>=3.13.0" "libsoup>=2.48.0" 'libnotify' 'gsettings-desktop-schemas' 'webkit2gtk>=2.7.4'
+ 'nss' 'iso-codes' 'dconf' 'gobject-introspection' 'desktop-file-utils' 'libxml2' 'libsecret'
+ 'hicolor-icon-theme' 'gcr' 'gnome-desktop' 'libwnck3' 'avahi')
+makedepends=('intltool' 'gnome-doc-utils' 'gnome-common' 'git' 'startup-notification' 'yelp-tools')
+options=('!libtool' '!emptydirs')
+groups=('gnome')
+url="http://www.gnome.org/projects/epiphany/"
+replaces=('epiphany')
+provides=("epiphany=${_realver}")
+conflicts=('epiphany')
+source=('git://git.gnome.org/epiphany')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --always | sed 's|-|.|g'
+}
+
+prepare() {
+ cd "$srcdir/$_pkgname"
+ # git bz apply bugzilla.gnome.org:710004
+ # git bz apply bugzilla.gnome.org:729726
+ # git bz apply bugzilla.gnome.org:741808
+ # git bz apply bugzilla.gnome.org:737085
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ ./autogen.sh --prefix=/usr --sysconfdir=/etc \
+ --localstatedir=/var --disable-maintainer-mode \
+ --disable-deprecations --enable-debug
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ make DESTDIR="$pkgdir" install
+}
diff --git a/epiphany.install b/epiphany.install
new file mode 100644
index 000000000000..712a22e07e17
--- /dev/null
+++ b/epiphany.install
@@ -0,0 +1,13 @@
+post_install() {
+ glib-compile-schemas usr/share/glib-2.0/schemas
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}