summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorQue Quotion2018-03-12 23:39:30 +0900
committerQue Quotion2018-03-12 23:39:30 +0900
commit7b37f21aabb9a195d48abc2f5774d99a3d87fe07 (patch)
treeb5e48c6e67e34add511e0c08fdd43d11f591acb1
parentdd857968b00c87b262fed5ce20dc00ab0831d07e (diff)
downloadaur-7b37f21aabb9a195d48abc2f5774d99a3d87fe07.tar.gz
Update to 3.27.90!
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD71
-rw-r--r--pluginsdir.diff21
3 files changed, 40 insertions, 81 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 79ec89de5336..e007ba0e8682 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,14 @@
-# Generated by mksrcinfo v8
-# Fri May 19 01:22:30 UTC 2017
pkgbase = epiphany-pantheon-bzr
- pkgdesc = A GNOME web browser based on the WebKit rendering engine, with ElementaryOS patchset
- pkgver = 3.18.5.r11
- pkgrel = 2
+ pkgdesc = A GNOME web browser based on the WebKit rendering engine, with Elementary OS patches
+ pkgver = 3.27.90.1ubuntu1.r19
+ pkgrel = 1
url = http://www.gnome.org/projects/epiphany/
arch = i686
arch = x86_64
groups = pantheon-unstable
groups = pantheon-qq
license = GPL
- makedepends = intltool
- makedepends = itstool
+ makedepends = meson
makedepends = docbook-xml
makedepends = startup-notification
makedepends = lsb-release
@@ -19,26 +16,18 @@ pkgbase = epiphany-pantheon-bzr
makedepends = yelp-tools
makedepends = autoconf-archive
makedepends = appstream-glib
- makedepends = bzr
makedepends = git
- depends = webkit2gtk
+ depends = webkit2gtk>=2.19.4
depends = gcr
- depends = gnome-desktop
+ depends = libhttpseverywhere
+ depends = libdazzle
provides = epiphany
conflicts = epiphany
replaces = epiphany
- source = https://git.gnome.org/browse/epiphany/snapshot/epiphany-3.18.5.tar.xz
- source = bzr+lp:~elementary-os/elementaryos/os-patch-epiphany-browser-xenial
- source = git+https://git.gnome.org/browse/libgd
- source = git://git.gnome.org/gvdb
+ source = bzr+lp:~elementary-os/elementaryos/os-patch-epiphany-browser-bionic
source = pluginsdir.diff
- source = webkit-update.patch
- sha256sums = 8ada9f9af99902539d69fcba32607f5d8f80921d0475293088bc2f191499a8ef
sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = 5fae0813c0f0e4451613ea4702b12df94c94e3545fd3eae96370446abbed2f48
- sha256sums = f569c4a01e4fe9c207b0ed22f6fbd4d25ac29868c59f585d658aa478695f1617
+ sha256sums = 3e648118d7d45fc1cce04d45c7443ed0cc54e3a65aefcb4fb12ce5e01014c53e
pkgname = epiphany-pantheon-bzr
diff --git a/PKGBUILD b/PKGBUILD
index 9bcd8b904614..48e9a374f635 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,76 +3,47 @@
_pkgname=epiphany
pkgname=$_pkgname-pantheon-bzr
-ephyver=3.18.5
-ubunturel=xenial
-pkgver=3.18.5.r11
-pkgrel=2
-pkgdesc="A GNOME web browser based on the WebKit rendering engine, with ElementaryOS patchset"
+ephyver=3.27.90-1ubuntu1
+ubunturel=bionic
+pkgver=3.27.90.1ubuntu1.r19
+pkgrel=1
+pkgdesc="A GNOME web browser based on the WebKit rendering engine, with Elementary OS patches"
url="http://www.gnome.org/projects/epiphany/"
arch=('i686' 'x86_64')
license=('GPL')
-depends=(webkit2gtk gcr gnome-desktop)
-makedepends=(intltool itstool docbook-xml startup-notification lsb-release
- gobject-introspection yelp-tools autoconf-archive appstream-glib bzr git)
+depends=('webkit2gtk>=2.19.4' gcr libhttpseverywhere libdazzle)
+makedepends=(meson docbook-xml startup-notification lsb-release
+ gobject-introspection yelp-tools autoconf-archive appstream-glib git)
groups=(pantheon-unstable pantheon-qq)
replaces=(epiphany)
provides=(epiphany)
conflicts=(epiphany)
-source=("https://git.gnome.org/browse/$_pkgname/snapshot/$_pkgname-$ephyver.tar.xz"
- "bzr+lp:~elementary-os/elementaryos/os-patch-epiphany-browser-$ubunturel"
- "git+https://git.gnome.org/browse/libgd"
- "git://git.gnome.org/gvdb"
- "pluginsdir.diff"
- "webkit-update.patch")
-sha256sums=('8ada9f9af99902539d69fcba32607f5d8f80921d0475293088bc2f191499a8ef'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- '5fae0813c0f0e4451613ea4702b12df94c94e3545fd3eae96370446abbed2f48'
- 'f569c4a01e4fe9c207b0ed22f6fbd4d25ac29868c59f585d658aa478695f1617')
+source=("bzr+lp:~elementary-os/elementaryos/os-patch-epiphany-browser-$ubunturel"
+ "pluginsdir.diff")
+sha256sums=('SKIP'
+ '3e648118d7d45fc1cce04d45c7443ed0cc54e3a65aefcb4fb12ce5e01014c53e')
pkgver() {
cd "os-patch-epiphany-browser-$ubunturel"
- echo "$ephyver.r$(bzr revno)"
+ echo "${ephyver/-/.}.r$(bzr revno)"
}
prepare() {
- cd $_pkgname-$ephyver
-
- # Apply Patches
- for i in $(grep -v '#' "$srcdir/os-patch-epiphany-browser-$ubunturel/debian/patches/series" | sort); do
- [[ "${i}" =~ ^# || -z "${i}" ]] || \
- [[ "${i}" == 99_toolbar_add_bookmark_button.patch ]] || \
- [[ "${i}" == 99_tabs_double_click_opens_new_tab.patch ]] && continue
- msg2 "Applying $i ..."
- patch -Np1 < "$srcdir/os-patch-epiphany-browser-$ubunturel/debian/patches/$i"
- done
+ cd "os-patch-epiphany-browser-$ubunturel"
msg2 "Plugins Directory"
- patch -Np1 < ../pluginsdir.diff
-
- msg2 "Minor fix"
- patch -Np2 < ../webkit-update.patch
-
- git submodule init
- git config --local submodule.libgd.url "$srcdir/libgd"
- git config --local gvdb.url "${srcdir}/gvdb/gvdb"
- git submodule update
+ #patch -Np1 < ../pluginsdir.diff
}
build() {
- cd "$_pkgname-$ephyver"
- ./autogen.sh --prefix=/usr --sysconfdir=/etc \
- --localstatedir=/var --libexecdir=/usr/lib/$pkgname --enable-compile-warnings=yes
-
- # https://bugzilla.gnome.org/show_bug.cgi?id=655517
- sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
-
- make
+ cd "os-patch-epiphany-browser-$ubunturel"
+ [ -d build ] && rm -rf build
+ meson build --prefix=/usr --sysconfdir=/etc --localstatedir=/var --libexecdir=/usr/lib/$_pkgname --buildtype=release -Denable_https_everywhere=true
+ ninja -C build
}
package() {
- cd "$_pkgname-$ephyver"
- make DESTDIR="$pkgdir" install
+ cd "os-patch-epiphany-browser-$ubunturel"
+ DESTDIR=${pkgdir} ninja -C build install
}
diff --git a/pluginsdir.diff b/pluginsdir.diff
index 59d6b6e4f4fe..f1ce3311a6c8 100644
--- a/pluginsdir.diff
+++ b/pluginsdir.diff
@@ -8,14 +8,13 @@
g_object_unref (manager);
}
---- a/embed/Makefile.am.orig 2017-04-08 12:22:50.192861523 +0000
-+++ b/embed/Makefile.am 2017-04-08 12:23:13.926290709 +0000
-@@ -61,6 +61,7 @@
- libephyembed_la_CFLAGS = \
- -DDATADIR="\"$(datadir)\"" \
- -DSHARE_DIR=\"$(pkgdatadir)\" \
-+ -DEPHY_PLUGINS_DIR=\""$(libdir)/epiphany/plugins"\" \
- -DEPHY_WEB_EXTENSIONS_DIR=\""$(libdir)/epiphany/$(EPIPHANY_MAJOR)/web-extensions"\" \
- $(DEPENDENCIES_CFLAGS) \
- $(CODE_COVERAGE_CFLAGS) \
-
+--- a/meson.build
++++ a/meson.build
+@@ -17,6 +17,7 @@
+ pkglibdir = join_paths(libdir, 'epiphany')
+ pkglibexecdir = join_paths(libexecdir, 'epiphany')
+ webextensionsdir = join_paths(pkglibdir, 'web-extensions')
++pluginsdir = join_paths(pkglibdir, 'plugins')
+
+ iso_codes = dependency('iso-codes')
+ iso_codes_prefix = iso_codes.get_pkgconfig_variable('prefix')