summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorQue Quotion2018-09-25 00:50:28 +0900
committerQue Quotion2018-09-25 00:50:28 +0900
commit9ddd93251ea791964be59b282de782feb46733bd (patch)
tree2b13fe9753d0464c43696df7d9b4269de1364554
parentc506d13808346444c4d75885a588ad4a1f8c9b86 (diff)
downloadaur-9ddd93251ea791964be59b282de782feb46733bd.tar.gz
Switch to 'os-patches' git repository version
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD39
2 files changed, 26 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a0b93b66b7f4..e112965c42f1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
-pkgbase = epiphany-pantheon-bzr
- pkgdesc = A GNOME web browser based on the WebKit rendering engine, with Elementary OS patches
- pkgver = 3.27.90.1ubuntu1.r20
- pkgrel = 6
- url = http://www.gnome.org/projects/epiphany/
+pkgbase = epiphany-pantheon
+ pkgdesc = A GNOME web browser based on the WebKit rendering engine, with elementary OS patches
+ pkgver = 3.28.0.1+1ubuntu1+r21.dbc305d50
+ pkgrel = 1
+ url = https://gitlab.gnome.org/GNOME/epiphany/
arch = i686
arch = x86_64
groups = pantheon-unstable
@@ -16,7 +16,6 @@ pkgbase = epiphany-pantheon-bzr
makedepends = yelp-tools
makedepends = autoconf-archive
makedepends = appstream-glib
- makedepends = bzr
depends = webkit2gtk>=2.19.4
depends = gcr
depends = libhttpseverywhere
@@ -25,13 +24,13 @@ pkgbase = epiphany-pantheon-bzr
provides = epiphany
provides = epiphany-sync
conflicts = epiphany
- replaces = epiphany
- source = bzr+lp:~elementary-os/elementaryos/os-patch-epiphany-browser-bionic
+ replaces = epiphany-pantheon-bzr
+ source = git+https://github.com/elementary/os-patches.git#branch=epiphany-browser-bionic-patched
source = epiphany-sync
source = epiphany-sync.service
sha256sums = SKIP
sha256sums = cf90f3ea93fff8c61f82da40c8d07d5db2f33dc9a0d91408a6ffc4142bbedd20
sha256sums = ce1ac321d7bf9d88638634a141dfcb99119fc59ee44c4892e0874608e85006ba
-pkgname = epiphany-pantheon-bzr
+pkgname = epiphany-pantheon
diff --git a/PKGBUILD b/PKGBUILD
index 297ee14fc3a8..a1c3612dd0bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,45 +1,42 @@
# Maintainer: Que Quotion <quequotion@bugmenot.com>
# Contributor: Adria Arrufat <adria DOT arrufat+aur AT protonmail DOT ch>
-_pkgname=epiphany
-pkgname=$_pkgname-pantheon-bzr
-ephyver=3.27.90-1ubuntu1
-ubunturel=bionic
-pkgver=3.27.90.1ubuntu1.r20
-pkgrel=6
-pkgdesc="A GNOME web browser based on the WebKit rendering engine, with Elementary OS patches"
-url="http://www.gnome.org/projects/epiphany/"
+pkgname=epiphany-pantheon
+pkgver=3.28.0.1+1ubuntu1+r21.dbc305d50
+pkgrel=1
+pkgdesc="A GNOME web browser based on the WebKit rendering engine, with elementary OS patches"
+url="https://gitlab.gnome.org/GNOME/epiphany/"
arch=('i686' 'x86_64')
license=('GPL')
depends=('webkit2gtk>=2.19.4' gcr libhttpseverywhere libdazzle gst-libav)
makedepends=(meson docbook-xml startup-notification lsb-release
- gobject-introspection yelp-tools autoconf-archive appstream-glib bzr)
+ gobject-introspection yelp-tools autoconf-archive appstream-glib)
groups=(pantheon-unstable pantheon-qq)
-replaces=(epiphany)
+replaces=(epiphany-pantheon-bzr)
provides=(epiphany epiphany-sync)
conflicts=(epiphany)
-source=("bzr+lp:~elementary-os/elementaryos/os-patch-epiphany-browser-${ubunturel}"
+source=("git+https://github.com/elementary/os-patches.git#branch=epiphany-browser-bionic-patched"
epiphany-sync{,.service})
sha256sums=('SKIP'
'cf90f3ea93fff8c61f82da40c8d07d5db2f33dc9a0d91408a6ffc4142bbedd20'
'ce1ac321d7bf9d88638634a141dfcb99119fc59ee44c4892e0874608e85006ba')
pkgver() {
- cd "os-patch-epiphany-browser-${ubunturel}"
+ cd "os-patches"
- echo "${ephyver/-/.}.r$(bzr revno)"
+ printf "3.28.0.1+1ubuntu1+r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd "os-patch-epiphany-browser-${ubunturel}"
- [ -d build ] && rm -rf build
- arch-meson build -Denable_https_everywhere=true
- ninja -C build
+ cd "os-patches"
+ [ -d build ] && rm -rf build
+ arch-meson build -Denable_https_everywhere=true
+ ninja -C build
}
package() {
- cd "os-patch-epiphany-browser-$ubunturel"
- DESTDIR="${pkgdir}" ninja -C build install
- install -Dm 755 {"${srcdir}","${pkgdir}"/usr/bin}/epiphany-sync
- install -Dm 644 {"${srcdir}","${pkgdir}"/usr/lib/systemd/user}/epiphany-sync.service
+ cd "os-patches"
+ DESTDIR="${pkgdir}" ninja -C build install
+ install -Dm 755 {"${srcdir}","${pkgdir}"/usr/bin}/epiphany-sync
+ install -Dm 644 {"${srcdir}","${pkgdir}"/usr/lib/systemd/user}/epiphany-sync.service
}