summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorQue Quotion2017-05-19 01:07:22 +0900
committerQue Quotion2017-05-19 01:07:22 +0900
commitca24717e1a1140243d98b8305a3b5961e9357c2c (patch)
tree44e73169ace48f4c151af2a393b317093e9f2d66
downloadaur-ca24717e1a1140243d98b8305a3b5961e9357c2c.tar.gz
initial commit: epiphany with ElementaryOS patches
-rw-r--r--.SRCINFO43
-rw-r--r--PKGBUILD76
-rw-r--r--pluginsdir.diff21
-rw-r--r--webkit-update.patch11
4 files changed, 151 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4209be7196c1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,43 @@
+# Generated by mksrcinfo v8
+# Thu May 18 16:06:26 UTC 2017
+pkgbase = epiphany-pantheon-bzr
+ pkgdesc = A GNOME web browser based on the WebKit rendering engine, with ElementaryOS patchset
+ pkgver = 3.18.5.r11
+ pkgrel = 1
+ url = http://www.gnome.org/projects/epiphany/
+ arch = i686
+ arch = x86_64
+ groups = gnome
+ license = GPL
+ makedepends = intltool
+ makedepends = itstool
+ makedepends = docbook-xml
+ makedepends = startup-notification
+ makedepends = lsb-release
+ makedepends = gobject-introspection
+ makedepends = yelp-tools
+ makedepends = autoconf-archive
+ makedepends = appstream-glib
+ makedepends = bzr
+ makedepends = git
+ depends = webkit2gtk
+ depends = gcr
+ depends = gnome-desktop
+ provides = epiphany
+ conflicts = epiphany
+ replaces = epiphany
+ source = https://git.gnome.org/browse/epiphany/snapshot/epiphany-3.18.5.tar.xz
+ source = bzr+lp:~elementary-os/elementaryos/os-patch-epiphany-browser-xenial
+ source = git+https://git.gnome.org/browse/libgd
+ source = git://git.gnome.org/gvdb
+ source = pluginsdir.diff
+ source = webkit-update.patch
+ sha256sums = 8ada9f9af99902539d69fcba32607f5d8f80921d0475293088bc2f191499a8ef
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = 5fae0813c0f0e4451613ea4702b12df94c94e3545fd3eae96370446abbed2f48
+ sha256sums = f569c4a01e4fe9c207b0ed22f6fbd4d25ac29868c59f585d658aa478695f1617
+
+pkgname = epiphany-pantheon-bzr
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e2946295a224
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,76 @@
+# Maintainer: Que Quotion <quequotion@bugmenot.com>
+# Contributor: Adria Arrufat <adria DOT arrufat+aur AT protonmail DOT ch>
+
+_pkgname=epiphany
+pkgname=$_pkgname-pantheon-bzr
+pkgver=3.18.5.r11
+pkgrel=1
+pkgdesc="A GNOME web browser based on the WebKit rendering engine, with ElementaryOS patchset"
+url="http://www.gnome.org/projects/epiphany/"
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=(webkit2gtk gcr gnome-desktop)
+makedepends=(intltool itstool docbook-xml startup-notification lsb-release
+ gobject-introspection yelp-tools autoconf-archive appstream-glib bzr git)
+groups=(gnome)
+replaces=(epiphany)
+provides=(epiphany)
+conflicts=(epiphany)
+source=("https://git.gnome.org/browse/epiphany/snapshot/epiphany-3.18.5.tar.xz"
+ "bzr+lp:~elementary-os/elementaryos/os-patch-epiphany-browser-xenial"
+ "git+https://git.gnome.org/browse/libgd"
+ "git://git.gnome.org/gvdb"
+ "pluginsdir.diff"
+ "webkit-update.patch")
+sha256sums=('8ada9f9af99902539d69fcba32607f5d8f80921d0475293088bc2f191499a8ef'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ '5fae0813c0f0e4451613ea4702b12df94c94e3545fd3eae96370446abbed2f48'
+ 'f569c4a01e4fe9c207b0ed22f6fbd4d25ac29868c59f585d658aa478695f1617')
+
+pkgver() {
+ cd os-patch-epiphany-browser-xenial
+
+ echo "3.18.5.r$(bzr revno)"
+}
+
+prepare() {
+ cd $_pkgname-3.18.5
+
+ # Apply Patches
+ for i in $(grep -v '#' "$srcdir/os-patch-epiphany-browser-xenial/debian/patches/series" | sort); do
+ [[ "${i}" =~ ^# || -z "${i}" ]] || \
+ [[ "${i}" == 99_toolbar_add_bookmark_button.patch ]] || \
+ [[ "${i}" == 99_tabs_double_click_opens_new_tab.patch ]] && continue
+ msg2 "Applying $i ..."
+ patch -Np1 < "$srcdir/os-patch-epiphany-browser-xenial/debian/patches/$i"
+ done
+
+ msg2 "Plugins Directory"
+ patch -Np1 < ../pluginsdir.diff
+
+ msg2 "Minor fix"
+ patch -Np2 < ../webkit-update.patch
+
+ git submodule init
+ git config --local submodule.libgd.url "$srcdir/libgd"
+ git config --local gvdb.url "${srcdir}/gvdb/gvdb"
+ git submodule update
+}
+
+build() {
+ cd $_pkgname-3.18.5
+ ./autogen.sh --prefix=/usr --sysconfdir=/etc \
+ --localstatedir=/var --libexecdir=/usr/lib/$pkgname --enable-compile-warnings=yes
+
+ # https://bugzilla.gnome.org/show_bug.cgi?id=655517
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+
+ make
+}
+
+package() {
+ cd $_pkgname-3.18.5
+ make DESTDIR="$pkgdir" install
+}
diff --git a/pluginsdir.diff b/pluginsdir.diff
new file mode 100644
index 000000000000..59d6b6e4f4fe
--- /dev/null
+++ b/pluginsdir.diff
@@ -0,0 +1,21 @@
+--- a/embed/ephy-embed-shell.c
++++ b/embed/ephy-embed-shell.c
+@@ -671,6 +671,7 @@ ephy_embed_shell_create_web_context (EphyEmbedShell *shell)
+ g_free (cache_dir);
+
+ priv->web_context = webkit_web_context_new_with_website_data_manager (manager);
++ webkit_web_context_set_additional_plugins_directory (priv->web_context, EPHY_PLUGINS_DIR);
+ g_object_unref (manager);
+ }
+
+--- a/embed/Makefile.am.orig 2017-04-08 12:22:50.192861523 +0000
++++ b/embed/Makefile.am 2017-04-08 12:23:13.926290709 +0000
+@@ -61,6 +61,7 @@
+ libephyembed_la_CFLAGS = \
+ -DDATADIR="\"$(datadir)\"" \
+ -DSHARE_DIR=\"$(pkgdatadir)\" \
++ -DEPHY_PLUGINS_DIR=\""$(libdir)/epiphany/plugins"\" \
+ -DEPHY_WEB_EXTENSIONS_DIR=\""$(libdir)/epiphany/$(EPIPHANY_MAJOR)/web-extensions"\" \
+ $(DEPENDENCIES_CFLAGS) \
+ $(CODE_COVERAGE_CFLAGS) \
+
diff --git a/webkit-update.patch b/webkit-update.patch
new file mode 100644
index 000000000000..6f876ad80d24
--- /dev/null
+++ b/webkit-update.patch
@@ -0,0 +1,11 @@
+--- src/epiphany-3.18.5/embed/web-extension/ephy-web-overview.c 2016-03-15 08:21:57.000000000 +0900
++++ src/epiphany-3.18.5/embed/web-extension/ephy-web-overview.c.new 2017-05-19 00:22:44.197874032 +0900
+@@ -144,7 +144,7 @@
+ item->url = g_strdup (url->url);
+
+ class_list = webkit_dom_element_get_class_list (webkit_dom_node_get_parent_element (WEBKIT_DOM_NODE (item->anchor)));
+- if (class_list && webkit_dom_dom_token_list_contains (class_list, "overview-removed", NULL))
++ if (class_list && webkit_dom_dom_token_list_contains (class_list, "overview-removed"))
+ webkit_dom_dom_token_list_remove (class_list, "overview-removed", NULL);
+
+ webkit_dom_element_set_attribute (item->anchor, "href", url->url, NULL);