summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author100best2016-11-21 20:28:42 -0800
committer100best2016-11-21 20:28:42 -0800
commit4052bb9965be680a26acc7d0d37e7a2b940990ca (patch)
treeaefe277501ed3cc83125dc77acc07e357aed684b
parente2655ea331e84bdf3b2c60384d0d3a7a8ee9f969 (diff)
downloadaur-4052bb9965be680a26acc7d0d37e7a2b940990ca.tar.gz
version 3.23.2.1
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD20
2 files changed, 18 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2ec6475be0d5..0303eb8cda90 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = epiphany-unstable
pkgdesc = A GNOME web browser based on the WebKit rendering engine (unstable version)
- pkgver = 3.23.1.2
+ pkgver = 3.23.2.1
pkgrel = 1
url = https://wiki.gnome.org/Apps/Web
arch = i686
@@ -12,22 +12,17 @@ pkgbase = epiphany-unstable
makedepends = docbook-xml
makedepends = startup-notification
makedepends = gobject-introspection
+ makedepends = yelp-tools
+ makedepends = autoconf-archive
+ makedepends = appstream-glib
depends = libhttpseverywhere
- depends = libsoup
- depends = libnotify
depends = webkit2gtk
- depends = nss
- depends = iso-codes
- depends = dconf
depends = gcr
depends = gnome-desktop
- depends = libwnck3
- depends = gnome-themes-standard
- provides = epiphany=3.23.1.2
+ provides = epiphany=3.23.2.1
conflicts = epiphany
- replaces = epiphany
- source = http://ftp.gnome.org/pub/GNOME/sources/epiphany/3.23/epiphany-3.23.1.2.tar.xz
- md5sums = 4579058e42f0d1cce64f0e9c7b1ec81c
+ source = https://ftp.gnome.org/pub/GNOME/sources/epiphany/3.23/epiphany-3.23.2.1.tar.xz
+ md5sums = f2a16f7a8ded0c12ebe9ff5d4cfb9eb5
pkgname = epiphany-unstable
diff --git a/PKGBUILD b/PKGBUILD
index c785b08048eb..ad63b3474a72 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,32 @@
-# Maintainer: 100best <jm.100best@hotmail.com>
+# Maintainer: 100best <jm dot 100best at gmail dot com>
_pkgname=epiphany
pkgname=$_pkgname-unstable
-pkgver=3.23.1.2
+pkgver=3.23.2.1
pkgrel=1
pkgdesc="A GNOME web browser based on the WebKit rendering engine (unstable version)"
arch=('i686' 'x86_64')
url="https://wiki.gnome.org/Apps/Web"
license=('GPL3')
groups=('gnome')
-depends=(libhttpseverywhere libsoup libnotify webkit2gtk nss iso-codes
- dconf gcr gnome-desktop libwnck3 gnome-themes-standard)
+depends=(libhttpseverywhere webkit2gtk gcr gnome-desktop)
makedepends=(intltool itstool docbook-xml startup-notification
- gobject-introspection)
-source=(http://ftp.gnome.org/pub/GNOME/sources/$_pkgname/${pkgver:0:4}/$_pkgname-$pkgver.tar.xz)
-md5sums=('4579058e42f0d1cce64f0e9c7b1ec81c')
-replaces=("$_pkgname")
+ gobject-introspection yelp-tools autoconf-archive
+appstream-glib)
+source=(https://ftp.gnome.org/pub/GNOME/sources/$_pkgname/${pkgver:0:4}/$_pkgname-$pkgver.tar.xz)
+md5sums=('f2a16f7a8ded0c12ebe9ff5d4cfb9eb5')
provides=("$_pkgname=$pkgver")
conflicts=("$_pkgname")
build() {
- "$srcdir/$_pkgname-$pkgver/configure" --prefix=/usr --sysconfdir=/etc \
+ cd $_pkgname-$pkgver
+ ./configure --prefix=/usr --sysconfdir=/etc \
--localstatedir=/var --libexecdir=/usr/lib/$_pkgname
+
make
}
package() {
+ cd $_pkgname-$pkgver
make DESTDIR="$pkgdir" install
}