summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author100best2019-02-24 02:48:21 -0600
committer100best2019-02-24 02:48:21 -0600
commit9b9378e1e92d907fdf49a63bf4a2f07404076e33 (patch)
tree840956dd5c46295ffcec878cd3b63c055d5d0634
parentf8ca38c91bcf8480f7dc7524a1357347ca726f45 (diff)
downloadaur-9b9378e1e92d907fdf49a63bf4a2f07404076e33.tar.gz
update to version 3.31.91
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD47
2 files changed, 40 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e35a5d649654..ce5f5a244d64 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,29 @@
pkgbase = epiphany-unstable
pkgdesc = A GNOME web browser based on the WebKit rendering engine (unstable version)
- pkgver = 3.24.0
+ pkgver = 3.31.91
pkgrel = 1
url = https://wiki.gnome.org/Apps/Web
- arch = i686
arch = x86_64
groups = gnome
- license = GPL3
- makedepends = intltool
- makedepends = itstool
+ license = GPL
+ checkdepends = xorg-server-xvfb
makedepends = docbook-xml
makedepends = startup-notification
+ makedepends = lsb-release
makedepends = gobject-introspection
makedepends = yelp-tools
- makedepends = autoconf-archive
makedepends = appstream-glib
+ makedepends = git
+ makedepends = meson
depends = webkit2gtk
depends = gcr
- depends = gnome-desktop
+ depends = icu
+ depends = libdazzle
provides = epiphany
conflicts = epiphany
- source = https://ftp.gnome.org/pub/GNOME/sources/epiphany/3.24/epiphany-3.24.0.tar.xz
- md5sums = 40b21b6c4e1f9471642135d04258b2fc
+ conflicts = epiphany-git
+ source = git+https://gitlab.gnome.org/GNOME/epiphany.git#commit=d86a2ffa130c204991beaa582799676cb8ac1c03
+ sha256sums = SKIP
pkgname = epiphany-unstable
diff --git a/PKGBUILD b/PKGBUILD
index b6cfb7ddccec..72708393585a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,31 +2,42 @@
_pkgname=epiphany
pkgname=$_pkgname-unstable
-pkgver=3.24.0
+pkgver=3.31.91
pkgrel=1
pkgdesc="A GNOME web browser based on the WebKit rendering engine (unstable version)"
-arch=('i686' 'x86_64')
url="https://wiki.gnome.org/Apps/Web"
-license=('GPL3')
-groups=('gnome')
-depends=(webkit2gtk gcr gnome-desktop)
-makedepends=(intltool itstool docbook-xml startup-notification
- gobject-introspection yelp-tools autoconf-archive
-appstream-glib)
-source=(https://ftp.gnome.org/pub/GNOME/sources/$_pkgname/${pkgver:0:4}/$_pkgname-$pkgver.tar.xz)
-md5sums=('40b21b6c4e1f9471642135d04258b2fc')
-provides=("$_pkgname")
-conflicts=("$_pkgname")
+arch=(x86_64)
+license=(GPL)
+depends=(webkit2gtk gcr icu libdazzle)
+makedepends=(docbook-xml startup-notification lsb-release gobject-introspection yelp-tools
+ appstream-glib git meson)
+checkdepends=(xorg-server-xvfb)
+groups=(gnome)
+_commit=d86a2ffa130c204991beaa582799676cb8ac1c03 # tags/3.31.91^0
+source=("git+https://gitlab.gnome.org/GNOME/epiphany.git#commit=$_commit")
+sha256sums=('SKIP')
+conflicts=(epiphany epiphany-git)
+provides=(epiphany)
+pkgver() {
+ cd $_pkgname
+ git describe --tags | sed 's/-/+/g'
+}
+
+prepare() {
+ cd $_pkgname
+}
build() {
- cd $_pkgname-$pkgver
- ./configure --prefix=/usr --sysconfdir=/etc \
- --localstatedir=/var --libexecdir=/usr/lib/$_pkgname
+ arch-meson $_pkgname build \
+ -D distributor_name="Arch Linux®"
+ ninja -C build
+}
- make
+check() {
+ # ERROR:../epiphany/tests/ephy-web-app-utils-test.c:109:test_web_app_lifetime: assertion failed (g_list_length (apps) == 1): (0 == 1)
+ xvfb-run meson test -C build || :
}
package() {
- cd $_pkgname-$pkgver
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" meson install -C build
}