summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDoug Newgard2013-11-01 13:37:26 -0500
committerDoug Newgard2013-11-01 13:37:26 -0500
commitf761372f643a21710383cd198270e20c16a6082b (patch)
treeac2f6b200d8e2edc3206254a7d9fed3f33e3af65
downloadaur-f761372f643a21710383cd198270e20c16a6082b.tar.gz
Initial PKGBUILD
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD30
-rw-r--r--epour.install12
4 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8b8f28075b56
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = epour
+ pkgdesc = Torrent client based on EFL
+ pkgver = 0.5.2.0
+ pkgrel = 1
+ url = http://www.enlightenment.org
+ install = epour.install
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = python2-distutils-extra
+ depends = python2-ecore
+ depends = python2-e_dbus
+ depends = python2-elementary
+ depends = libtorrent
+ depends = hicolor-icon-theme
+ depends = desktop-file-utils
+ source = git://git.enlightenment.org/apps/epour.git#tag=epour-0.5.2.0
+ md5sums = SKIP
+
+pkgname = epour
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..71a9d16c2b38
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*~
+*/
+*.tar.*
+*.log
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bea808deb3cf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Doug Newgard <scimmia22 at outlook dot com>
+
+pkgname=epour
+pkgver=0.5.2.0
+pkgrel=1
+pkgdesc="Torrent client based on EFL"
+arch=('any')
+url="http://www.enlightenment.org"
+license=('GPL3')
+depends=('python2-ecore' 'python2-e_dbus' 'python2-elementary' 'libtorrent' 'hicolor-icon-theme' 'desktop-file-utils')
+makedepends=('git' 'python2-distutils-extra')
+install=$pkgname.install
+source=("git://git.enlightenment.org/apps/$pkgname.git#tag=epour-$pkgver")
+md5sums=('SKIP')
+
+prepare() {
+ cd "$srcdir/$pkgname"
+
+ sed -i 's/env python$/&2/' bin/epour epour/*.py epour/gui/*.py
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+
+ python2 setup.py install --root=$pkgdir
+
+# install text files
+ install -Dm644 AUTHORS "$pkgdir/usr/share/doc/$pkgname/AUTHORS"
+ install -Dm644 README "$pkgdir/usr/share/doc/$pkgname/README"
+}
diff --git a/epour.install b/epour.install
new file mode 100644
index 000000000000..83d9ec4a7ab2
--- /dev/null
+++ b/epour.install
@@ -0,0 +1,12 @@
+post_install() {
+ update-desktop-database -q
+ [[ -e /usr/bin/gtk-update-icon-cache ]] && gtk-update-icon-cache
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}