summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDennis van der Schagt2023-07-23 15:27:01 +0200
committerDennis van der Schagt2023-07-23 15:27:01 +0200
commitc8d7f876e878de105445b4d4bf5eb2c89b7d90bb (patch)
treecd5eecf9ccfc8d7e9883bd76887323cdbbbf5fcb
parente74ecd1fe2cc547d95e0e53fdafb8b496ad93ecf (diff)
downloadaur-c8d7f876e878de105445b4d4bf5eb2c89b7d90bb.tar.gz
Update to v2.11.1
Remove patch file because change has been included in latest version: https://github.com/eProsima/Fast-DDS/commit/c92d2f95b78141f16048c920e2979d0c39409865
-rw-r--r--.SRCINFO8
-rw-r--r--001-include-cstdint.patch12
-rw-r--r--PKGBUILD19
3 files changed, 7 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e4770b1fb9dd..562fb8612204 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = eprosima-fast-dds
pkgdesc = eProsima's Fast-DDS implementation
- pkgver = 2.11.0
+ pkgver = 2.11.1
pkgrel = 1
url = https://github.com/eProsima/Fast-DDS
arch = x86_64
@@ -10,9 +10,7 @@ pkgbase = eprosima-fast-dds
depends = asio
depends = tinyxml2
depends = eprosima-fast-cdr
- source = https://github.com/eProsima/Fast-DDS/archive/v2.11.0.tar.gz
- source = 001-include-cstdint.patch
- sha256sums = afaf43fbee90d6dbecbbe7c363860c4963f8db2f4be94dc7c61a27bfdf841b83
- sha256sums = 9656a7c2780040a922ecd85b9ba046ec72375a394b5ae199d570d1c1b7e82abf
+ source = https://github.com/eProsima/Fast-DDS/archive/v2.11.1.tar.gz
+ sha256sums = 3fe8b9f67a13a5d2aa40c0bd10581bd90f0a192b39c71f92ee233ffe584d3374
pkgname = eprosima-fast-dds
diff --git a/001-include-cstdint.patch b/001-include-cstdint.patch
deleted file mode 100644
index ec78e23b74a9..000000000000
--- a/001-include-cstdint.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/include/fastdds/dds/core/status/StatusMask.hpp b/include/fastdds/dds/core/status/StatusMask.hpp
-index c838ff369..2718869d7 100644
---- a/include/fastdds/dds/core/status/StatusMask.hpp
-+++ b/include/fastdds/dds/core/status/StatusMask.hpp
-@@ -24,6 +24,7 @@
- #include <fastrtps/fastrtps_dll.h>
-
- #include <bitset>
-+#include <cstdint>
- #include <sstream>
-
- //!Alias of size_t(16)
diff --git a/PKGBUILD b/PKGBUILD
index b2d2865ebdd1..56fe19ea72b7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Dennis van der Schagt <dennisschagt@gmail.com>
pkgname=eprosima-fast-dds
-pkgver=2.11.0
-pkgrel=2
+pkgver=2.11.1
+pkgrel=1
pkgdesc="eProsima's Fast-DDS implementation"
arch=('x86_64')
url="https://github.com/eProsima/Fast-DDS"
@@ -17,22 +17,11 @@ backup=()
options=()
install=
changelog=
-source=(
- "https://github.com/eProsima/Fast-DDS/archive/v${pkgver}.tar.gz"
- "001-include-cstdint.patch"
-)
+source=("https://github.com/eProsima/Fast-DDS/archive/v${pkgver}.tar.gz")
noextract=()
-sha256sums=(
- 'afaf43fbee90d6dbecbbe7c363860c4963f8db2f4be94dc7c61a27bfdf841b83'
- '9656a7c2780040a922ecd85b9ba046ec72375a394b5ae199d570d1c1b7e82abf'
-)
+sha256sums=('3fe8b9f67a13a5d2aa40c0bd10581bd90f0a192b39c71f92ee233ffe584d3374')
validpgpkeys=()
-prepare() {
- cd Fast-DDS-${pkgver}
- patch --forward --strip=1 --input="${srcdir}/001-include-cstdint.patch"
-}
-
build() {
cd "Fast-DDS-$pkgver"
cmake -B build \