summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDennis van der Schagt2023-07-07 20:09:23 +0200
committerDennis van der Schagt2023-07-07 20:09:23 +0200
commite25d744bf89c198bc018122e1abdcaa9f2b38480 (patch)
treecb72c458f49554327f5171e68764142889977028
parentb498025e94151c034203692da48f7a93ccfbf3dd (diff)
downloadaur-e25d744bf89c198bc018122e1abdcaa9f2b38480.tar.gz
Update to v2.11.0
-rw-r--r--.SRCINFO10
-rw-r--r--001-gcc-13-1.patch27
-rw-r--r--PKGBUILD19
3 files changed, 8 insertions, 48 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f2fa3d4842fd..74c49674ac01 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = eprosima-fast-dds
pkgdesc = eProsima's Fast-DDS implementation
- pkgver = 2.10.1
- pkgrel = 2
+ pkgver = 2.11.0
+ pkgrel = 1
url = https://github.com/eProsima/Fast-DDS
arch = x86_64
license = Apache
@@ -10,9 +10,7 @@ pkgbase = eprosima-fast-dds
depends = asio
depends = tinyxml2
depends = eprosima-fast-cdr
- source = https://github.com/eProsima/Fast-DDS/archive/v2.10.1.tar.gz
- source = 001-gcc-13-1.patch
- sha256sums = 2cc2682db5dc7e87684b7f23166e2f32faf8d5c4b4a8c94c6c21211a8a38f553
- sha256sums = d4e29cda89334ddadd6d619a18dfdfaaee184cd7df7ad09c2de1e2673b2a36cb
+ source = https://github.com/eProsima/Fast-DDS/archive/v2.11.0.tar.gz
+ sha256sums = afaf43fbee90d6dbecbbe7c363860c4963f8db2f4be94dc7c61a27bfdf841b83
pkgname = eprosima-fast-dds
diff --git a/001-gcc-13-1.patch b/001-gcc-13-1.patch
deleted file mode 100644
index 1f6a41dbb5c0..000000000000
--- a/001-gcc-13-1.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-diff --git a/include/fastdds/rtps/transport/TransportDescriptorInterface.h b/include/fastdds/rtps/transport/TransportDescriptorInterface.h
-index 149707736..30184d71a 100644
---- a/include/fastdds/rtps/transport/TransportDescriptorInterface.h
-+++ b/include/fastdds/rtps/transport/TransportDescriptorInterface.h
-@@ -17,7 +17,7 @@
-
- #include <fastrtps/fastrtps_dll.h>
-
--#ifdef _WIN32
-+#if defined(_WIN32) || ((__GNUC__ >= 13) && (__GNUC_MINOR__ >= 1))
- #include <cstdint>
- #endif // ifdef _WIN32
- #include <vector>
-diff --git a/include/fastrtps/types/TypeNamesGenerator.h b/include/fastrtps/types/TypeNamesGenerator.h
-index a8f45e013..152933316 100644
---- a/include/fastrtps/types/TypeNamesGenerator.h
-+++ b/include/fastrtps/types/TypeNamesGenerator.h
-@@ -3,6 +3,9 @@
-
- #include <fastrtps/fastrtps_dll.h>
-
-+#if defined(_WIN32) || ((__GNUC__ >= 13) && (__GNUC_MINOR__ >= 1))
-+#include <cstdint>
-+#endif // ifdef _WIN32
- #include <string>
- #include <vector>
-
diff --git a/PKGBUILD b/PKGBUILD
index b04574d65dd9..9428f9dcc0d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Dennis van der Schagt <dennisschagt@gmail.com>
pkgname=eprosima-fast-dds
-pkgver=2.10.1
-pkgrel=2
+pkgver=2.11.0
+pkgrel=1
pkgdesc="eProsima's Fast-DDS implementation"
arch=('x86_64')
url="https://github.com/eProsima/Fast-DDS"
@@ -17,22 +17,11 @@ backup=()
options=()
install=
changelog=
-source=(
- "https://github.com/eProsima/Fast-DDS/archive/v${pkgver}.tar.gz"
- "001-gcc-13-1.patch"
-)
+source=("https://github.com/eProsima/Fast-DDS/archive/v${pkgver}.tar.gz")
noextract=()
-sha256sums=(
- '2cc2682db5dc7e87684b7f23166e2f32faf8d5c4b4a8c94c6c21211a8a38f553'
- 'd4e29cda89334ddadd6d619a18dfdfaaee184cd7df7ad09c2de1e2673b2a36cb'
-)
+sha256sums=('afaf43fbee90d6dbecbbe7c363860c4963f8db2f4be94dc7c61a27bfdf841b83')
validpgpkeys=()
-prepare() {
- cd Fast-DDS-${pkgver}
- patch --forward --strip=1 --input="${srcdir}/001-gcc-13-1.patch"
-}
-
build() {
cd "Fast-DDS-$pkgver"
cmake -B build \