summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authord2017-12-29 17:18:42 +0100
committerd2017-12-29 17:18:42 +0100
commit27b2de16d2d267f3912c4fb5b2c4dcbbd369dccc (patch)
tree9d2509ade0faef1e123415c3b31433fb512434aa
parentc61a6f2eaa9367b575e66ad03aa69d0d4c509727 (diff)
downloadaur-27b2de16d2d267f3912c4fb5b2c4dcbbd369dccc.tar.gz
added 64 bit patch
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
-rw-r--r--bug_x86_64.patch76
3 files changed, 86 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dd0ea278c8e9..651844769095 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -13,7 +13,9 @@ pkgbase = epson-inkjet-printer-escpr2
optdepends = imagescan: scanner support
options = !libtool
source = https://download3.ebz.epson.net/dsc/f/03/00/06/66/06/cbdec7133feb477f38ebd45337be3a8fb1416c0c/epson-inkjet-printer-escpr2-1.0.9-1lsb3.2.src.rpm
+ source = bug_x86_64.patch
sha256sums = 9539a1f5cc031fb1792eb315c6771ebdb46286eeb5c756fd6371d4d54582191d
+ sha256sums = 44160b2ef140e97137d65c4db7a50cfe40399ab8691caaeaf43c08f758b8c545
pkgname = epson-inkjet-printer-escpr2
diff --git a/PKGBUILD b/PKGBUILD
index 030dbe868093..b3aa0c7b4fe6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,11 +8,17 @@ license=('GPL2')
depends=('cups' 'ghostscript')
optdepends=('imagescan: scanner support')
options=('!libtool')
-source=('https://download3.ebz.epson.net/dsc/f/03/00/06/66/06/cbdec7133feb477f38ebd45337be3a8fb1416c0c/epson-inkjet-printer-escpr2-1.0.9-1lsb3.2.src.rpm')
-sha256sums=('9539a1f5cc031fb1792eb315c6771ebdb46286eeb5c756fd6371d4d54582191d')
+source=('https://download3.ebz.epson.net/dsc/f/03/00/06/66/06/cbdec7133feb477f38ebd45337be3a8fb1416c0c/epson-inkjet-printer-escpr2-1.0.9-1lsb3.2.src.rpm'
+ 'bug_x86_64.patch')
+sha256sums=('9539a1f5cc031fb1792eb315c6771ebdb46286eeb5c756fd6371d4d54582191d'
+ '44160b2ef140e97137d65c4db7a50cfe40399ab8691caaeaf43c08f758b8c545')
prepare() {
tar xvf "$pkgname-$pkgver-$pkgrel"lsb3.2.tar.gz
+
+ cd "$pkgname-$pkgver"
+
+ patch -p1 -i "${srcdir}/bug_x86_64.patch"
}
build() {
diff --git a/bug_x86_64.patch b/bug_x86_64.patch
new file mode 100644
index 000000000000..6bd009184b5b
--- /dev/null
+++ b/bug_x86_64.patch
@@ -0,0 +1,76 @@
+diff --git a/src/filter.c b/src/filter.c
+index d13f10e..105eae9 100755
+--- a/src/filter.c
++++ b/src/filter.c
+@@ -40,6 +40,8 @@
+ #include "epson-escpr-api.h"
+ #include "epson-escpr-services.h"
+ #include "epson-escpr-mem.h"
++#include "epson-escpr-services.h"
++//#include "epson-escpage.h"
+
+ #include "err.h"
+ #include "mem.h"
+@@ -48,6 +50,11 @@
+ #include "libprtX.h"
+ #include "optBase.h"
+ #include "linux_cmn.h"
++#include "xfifo.h"
++
++extern EPS_ERR_CODE SetupJobAttrib (const EPS_JOB_ATTRIB*);
++extern EPS_ERR_CODE SendStartJob ();
++extern EPS_ERR_CODE PrintBand (const EPS_UINT8*, EPS_UINT32, EPS_UINT32*);
+
+ #define WIDTH_BYTES(bits) (((bits) + 31) / 32 * 4)
+
+@@ -431,7 +438,7 @@ main (int argc, char *argv[])
+ }
+
+ printJob.jobStatus = EPS_STATUS_ESTABLISHED;
+- int printHeight = 0;
++ EPS_UINT32 printHeight = 0;
+ ///////////////////////////////////////////////////////////////////////////////////////////////////////////
+
+ print_area_x = printJob.printableAreaWidth;
+@@ -605,7 +612,7 @@ main (int argc, char *argv[])
+ memcpy(rever_buf + k*3, startpage + pos + (bandBmp.widthBytes - 6) - k*3, 3);
+ }
+ }
+- PrintBand (rever_buf, bandBmp.widthBytes, &printHeight);
++ PrintBand ((const EPS_UINT8 *)rever_buf, bandBmp.widthBytes, &printHeight);
+ pos -= bandBmp.widthBytes;
+ }
+
+@@ -898,7 +905,7 @@ set_pips_parameter (filter_option_t *filter_opt_p, EPS_OPT *printOpt)
+
+ /* Get number of pages */
+ char page_num;
+- read (STDIN_FILENO, &page_num, 1);
++ (void)read (STDIN_FILENO, &page_num, 1);
+ debug_msg("total pages = %d\n", page_num);
+
+ /* Others */
+@@ -949,7 +956,7 @@ EPS_INT32 print_spool_fnc(void* hParam, const EPS_UINT8* pBuf, EPS_UINT32 cbBuf)
+
+ // fwrite (pBuf, cbBuf, 1, outfp);
+
+- XFIFOWrite(context, pBuf, cbBuf);
++ XFIFOWrite(context, (char *)pBuf, cbBuf);
+
+ return 1;
+ }
+diff --git a/src/mem.c b/src/mem.c
+index 4b4b118..420eaf5 100755
+--- a/src/mem.c
++++ b/src/mem.c
+@@ -24,6 +24,7 @@
+
+ #include <stdlib.h>
+ #include "mem.h"
++#include "err.h"
+
+ void *
+ mem_malloc (unsigned int size, bool_t crit)
+--
+2.15.1
+