summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Figueras2021-08-26 13:12:36 +0200
committerJoan Figueras2021-08-26 13:12:36 +0200
commitc25ff9f165b22de46a1a6fa507dc65e4a3f6cb06 (patch)
treef60c65204ef7d690e7a118343051ab4d031ef674
downloadaur-c25ff9f165b22de46a1a6fa507dc65e4a3f6cb06.tar.gz
Initial release
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD36
-rw-r--r--gt-s600.install11
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..348c4505159f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = epson-perfection-v10-v100-scanner-driver-aio
+ pkgdesc = Perfection V10/V100 Scanner Driver for Linux. All-in-one package with iscan and drivers
+ pkgver = 2.30.4
+ pkgrel = 1
+ url = http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX
+ install = gt-s600.install
+ arch = x86_64
+ license = custom:AVASYS
+ provides = iscan
+ provides = iscan-for-epson-v500-photo
+ provides = iscan-plugin-gt-s600
+ conflicts = iscan
+ conflicts = iscan-for-epson-v500-photo
+ conflicts = iscan-plugin-gt-s600
+ source = https://download2.ebz.epson.net/iscan/plugin/gt-s600/rpm/x64/iscan-gt-s600-bundle-2.30.4.x64.rpm.tar.gz
+ sha256sums = fe1356b1d5c40bc5ac985a5693166efb9e5049a78b412f49c385eb503eadf2c6
+
+pkgname = epson-perfection-v10-v100-scanner-driver-aio
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ba5de35e1673
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Joan Figueras <ffigue at gmail dot com>
+# Contributor: Vain <aurmaint1 on host: uninformativ dot de>
+# Based on PKGBUILD for iscan-plugin-gt-x770.
+
+pkgname=epson-perfection-v10-v100-scanner-driver-aio
+pkgver=2.30.4
+pkgrel=1
+_iscan=2.30.4-2
+_iscan_data=1.39.2-1
+_plugin=2.1.3-1
+pkgdesc="Perfection V10/V100 Scanner Driver for Linux. All-in-one package with iscan and drivers"
+arch=('x86_64')
+url="http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX"
+license=('custom:AVASYS')
+install=gt-s600.install
+provides=("iscan" "iscan-for-epson-v500-photo" "iscan-plugin-gt-s600")
+conflicts=("iscan" "iscan-for-epson-v500-photo" "iscan-plugin-gt-s600")
+source=("https://download2.ebz.epson.net/iscan/plugin/gt-s600/rpm/x64/iscan-gt-s600-bundle-${pkgver}.x64.rpm.tar.gz")
+sha256sums=('fe1356b1d5c40bc5ac985a5693166efb9e5049a78b412f49c385eb503eadf2c6')
+
+package() {
+ cd "$srcdir"
+ bsdtar -xf "iscan-gt-s600-bundle-${pkgver}.x64.rpm/core/iscan-${_iscan}.${CARCH}.rpm"
+ bsdtar -xf "iscan-gt-s600-bundle-${pkgver}.x64.rpm/data/iscan-data-${_iscan_data}.noarch.rpm"
+ bsdtar -xf "iscan-gt-s600-bundle-${pkgver}.x64.rpm/plugins/iscan-plugin-gt-s600-${_plugin}.${CARCH}.rpm"
+ mv usr "$pkgdir"
+
+ mv -v "$pkgdir"/usr/lib64/* "$pkgdir"/usr/lib/
+ rmdir "$pkgdir"/usr/lib64
+ mv -v "$pkgdir"/usr/sbin/* "$pkgdir"/usr/bin
+ rmdir "$pkgdir"/usr/sbin
+
+ install -m 644 -D \
+ "$pkgdir"/usr/share/doc/iscan-plugin-gt-s600-${_plugin%-*}/COPYING.EPSON.en.txt \
+ "$pkgdir"/usr/share/licenses/"$pkgname"/COPYING
+}
diff --git a/gt-s600.install b/gt-s600.install
new file mode 100644
index 000000000000..9a9966b7b4e3
--- /dev/null
+++ b/gt-s600.install
@@ -0,0 +1,11 @@
+post_install() {
+ echo "Running iscan-registry to register plugins and firmware with iscan"
+ iscan-registry -a interpreter usb 0x04b8 0x012d \
+ /usr/lib/iscan/libesint66 /usr/share/iscan/esfw66.bin
+}
+
+pre_remove() {
+ echo "Unregistering gt-s600 plugins/firmware"
+ iscan-registry -r interpreter usb 0x04b8 0x012d \
+ /usr/lib/iscan/libesint66 /usr/share/iscan/esfw66.bin
+}