summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoramagura2016-05-26 23:54:27 -0600
committeramagura2016-05-26 23:54:27 -0600
commit1c85ea01309c1f94a86b8130f400eea482ce20cd (patch)
tree35bffb216a20953b2b79512813c03f10fe68c8c4
parenta9e162465f3908082c04ab939a3af2b470ec6af9 (diff)
downloadaur-1c85ea01309c1f94a86b8130f400eea482ce20cd.tar.gz
should fix all of the problems related to epsxe and libraries and such
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD10
-rw-r--r--epsxe.sh5
3 files changed, 13 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 58a4ff3e09b9..baf8fa3b0ffa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Tue May 24 22:49:38 UTC 2016
+# Fri May 27 05:53:56 UTC 2016
pkgbase = epsxe
pkgdesc = Enhanced PSX emulator
pkgver = 2.0.2
- pkgrel = 4
+ pkgrel = 5
url = http://epsxe.com
install = epsxe.install
arch = i686
@@ -12,7 +12,6 @@ pkgbase = epsxe
depends = gtk3
depends = sdl_ttf
depends = libtinfo
- depends = libtinfo5
depends = libcurl-compat
options = !strip
source = epsxe.desktop
@@ -21,7 +20,7 @@ pkgbase = epsxe
source = http://www.epsxe.com/files/ePSXe202linux.zip
md5sums = f4bdb7ccbebc31f818d34198a5a32e29
md5sums = eb0c46b8ae1355c589792f6be1835e47
- md5sums = ebe97b79a25e2622b3595d09f5b2764d
+ md5sums = 46c247cdf67ceb4f64813ee28290badc
md5sums = 787826ee6b0f95ea2df511dd7fd29abd
pkgname = epsxe
diff --git a/PKGBUILD b/PKGBUILD
index ad2a7bda5e7a..76a11c3a71b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,21 +5,21 @@
pkgname=epsxe
_pkgname=ePSXe
pkgver=2.0.2
-pkgrel=4
+pkgrel=5
pkgdesc="Enhanced PSX emulator"
url="http://epsxe.com"
arch=('i686' 'x86_64')
#depends=(gtk2 sdl_ttf ncurses5-compat-libs libtinfo-5 libcurl-compat)
#depends_i686+=(gtk3 sdl_ttf libtinfo)
#depends_x86_64+=(lib32-gtk3 lib32-ncurses lib32-libxt lib32-sdl_ttf lib32-alsa-lib lib32-libtinfo)
-depends=(gtk3 sdl_ttf libtinfo libtinfo5 libcurl-compat)
+depends=(gtk3 sdl_ttf libtinfo libcurl-compat)
license=('unknown')
install=${pkgname}.install
options=(!strip)
source=(${pkgname}.desktop ${pkgname}.png ${pkgname}.sh)
md5sums=('f4bdb7ccbebc31f818d34198a5a32e29'
'eb0c46b8ae1355c589792f6be1835e47'
- 'ebe97b79a25e2622b3595d09f5b2764d')
+ '46c247cdf67ceb4f64813ee28290badc')
if [[ $CARCH == "x86_64" ]]; then
source+=("http://www.epsxe.com/files/ePSXe${pkgver//./}linux_x64.zip")
md5sums+=('a6e92844922182c9f03343ab3e54865a')
@@ -53,4 +53,8 @@ package () {
install -Dm 644 "${srcdir}/epsxe.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
ln -sf "$HOME/.${pkgname}rc" -T "${pkgdir}/opt/${pkgname}/.${pkgname}rc"
+
+ # libtinfo and ncurses crap
+ ln -s /usr/lib/libtinfo.so.6 "$pkgdir"/opt/"$pkgname"/libncurses.so.5
+ ln -s /usr/lib/libncursesw.so.6 "$pkgdir"/opt/"$pkgname"/libtinfo.so.5
}
diff --git a/epsxe.sh b/epsxe.sh
index b2406e40be06..85b1da65df4e 100644
--- a/epsxe.sh
+++ b/epsxe.sh
@@ -1,3 +1,4 @@
-#!/usr/bin/env bash
+#!/usr/bin/env
-LD_LIBRARY_PATH+=:/opt/epsxe /opt/epsxe/epsxe "$@"
+
+LD_LIBRARY_PATH+=:/opt/epsxe LD_PRELOAD=libcurl.so.3 /opt/epsxe/epsxe "$@"