summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoramagura2015-09-30 10:26:09 -0600
committeramagura2015-09-30 10:26:09 -0600
commite91a37caf082eb5c774488c20cbfe5a3a20f9733 (patch)
tree5b3dc276d9a58646df78b35ef681a9f00d3e07fe
parent65b6709a947c389f892189f5338ebab4e9598ac9 (diff)
downloadaur-e91a37caf082eb5c774488c20cbfe5a3a20f9733.tar.gz
updates epsxe.install
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD11
-rw-r--r--epsxe.install9
3 files changed, 16 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 848138ef027a..c44217f69c58 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = epsxe
pkgdesc = Enhanced PSX emulator
pkgver = 1.9.25
- pkgrel = 4
+ pkgrel = 6
url = http://epsxe.com
install = epsxe.install
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 2679b8a32815..fd8f7953c49e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
#
pkgname=epsxe
pkgver=1.9.25
-pkgrel=4
+pkgrel=6
pkgdesc="Enhanced PSX emulator"
url="http://epsxe.com"
arch=('i686' 'x86_64')
@@ -18,11 +18,13 @@ md5sums=('087234e20ae9147f83df24b69fc93bca'
'eb0c46b8ae1355c589792f6be1835e47'
'1d6d07e9e1c97ed2a7ce46a9b7419654'
'dc54e1e3406b0010e0552cffabb16c0f')
+_ncurses="$(pacman -Q ncurses | awk '{sub(/-[0-9]+/, "", $2); print $2}')"
+_lib32_ncurses="$(pacman -Q lib32-ncurses | awk '{sub(/-[0-9]+/, "", $2); print $2}')"
package () {
cd "$srcdir"
install -m775 -g games -d "$pkgdir/opt/$pkgname/"{plugins,bios,memcards,cfg,cdimages,cheats,patches,sstates,snap}
- install -d "$pkgdir"/usr/share/doc/"$pkgname"
+ install -d "$pkgdir"/usr/{share/doc/"$pkgname",lib}
find docs -name 'e???e_*.txt' -execdir install -m 644 -t $pkgdir/usr/share/doc/$pkgname \{\} +
# find . -name '*.cht' -execdir "install -Dm 644 -t \$pkgdir/opt/$pkgname/$pkgver/cheats\"" \{\} +
@@ -35,4 +37,9 @@ package () {
install -Dm 644 "$srcdir/epsxe.desktop" "$pkgdir/usr/share/applications/${pkgname}.desktop"
ln -sf "$HOME/.${pkgname}rc" -T "$pkgdir/opt/$pkgname/.${pkgname}rc"
+ case "$CARCH" in
+ ('x86_64') ln -s /usr/lib32/libncursesw.so."${_lib32_ncurses}" "$pkgdir"/usr/lib/libncurses.so.5;
+ ln -s /usr/lib32/libtinfo.so "$pkgdir"/usr/lib/libtinfo.so.5;;
+ ('i686') ln -s /usr/lib/libncursesw.so."${_ncurses}" "$pkgdir"/usr/lib/libncurses.so.5;;
+ esac
}
diff --git a/epsxe.install b/epsxe.install
index 0bdc25feb6e7..ef3067f137ec 100644
--- a/epsxe.install
+++ b/epsxe.install
@@ -2,13 +2,16 @@ post_install() {
cat << EOF
Add your user to group 'games' in order to play.
-
-There are launcher packages out for epsxe. Search
-AUR for epsxe-launcher-* if you want to use it.
EOF
}
+#There are launcher packages out for epsxe. Search
+#AUR for epsxe-launcher-* if you want to use it.
+
+#EOF
+#}
+
op=$1
shift
$op $*