summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoramagura2015-06-09 11:16:23 -0600
committeramagura2015-06-09 11:16:23 -0600
commit3e2ce1d6f1a4fc2004196fdfc13592aa3e95fb33 (patch)
tree58709f13dbe15585d63e9b33e7d1232e4f8a756c
parent5d489e99c1efe03b82e7babe01c4b7d81bbdcc99 (diff)
downloadaur-3e2ce1d6f1a4fc2004196fdfc13592aa3e95fb33.tar.gz
updates pkgbuild to use new depends stuff
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD49
2 files changed, 22 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dced0a51254e..5558639281e3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,18 @@
pkgbase = epsxe-plugin-gpu-xgl2
pkgdesc = Linux port of the OpenGL2 plugin
pkgver = 2.9
- pkgrel = 3
+ pkgrel = 4
url = http://www.pbernert.com
arch = i686
arch = x86_64
license = custom
+ depends = epsxe
source = http://www.pbernert.com/gpupetexgl209.tar.gz
source = http://www.pbernert.com/gpupetexgl208.tar.gz
md5sums = 61bdad38a3a616bc000664de23d00c6e
md5sums = 088c5cdc21a0807e9227d7ec4672b51d
+ depends_i686 = mesa
+ depends_x86_64 = lib32-mesa
pkgname = epsxe-plugin-gpu-xgl2
diff --git a/PKGBUILD b/PKGBUILD
index a340cb6ed81b..97bb41b367c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,55 +3,42 @@
pkgname=epsxe-plugin-gpu-xgl2
pkgver=2.9
-pkgrel=3
+pkgrel=4
pkgdesc="Linux port of the OpenGL2 plugin"
url="http://www.pbernert.com"
-[ "$CARCH" == "i686" ] && depends=('epsxe' 'mesa')
-[ "$CARCH" == "x86_64" ] && depends=('epsxe' 'lib32-mesa')
+depends=('epsxe')
+depends_i686+=('mesa')
+depends_x86_64+=('lib32-mesa')
source=(http://www.pbernert.com/gpupetexgl209.tar.gz http://www.pbernert.com/gpupetexgl208.tar.gz)
md5sums=('61bdad38a3a616bc000664de23d00c6e' '088c5cdc21a0807e9227d7ec4672b51d')
license=('custom')
arch=('i686' 'x86_64')
prepare () {
-
- cd $srcdir/
-
-
- if [[ -f "readme.txt" ]]; then
-
- rename "readme.txt" README "readme.txt"
-
- fi
-
- if [[ -f "version.txt" ]]; then
-
- rename "version.txt" changelog "version.txt"
-
- fi
-
+ cd "$srcdir"
+ [[ -f 'readme.txt' ]] && rename "readme.txt" README "readme.txt"
+ [[ -f 'version.txt' ]] && rename "version.txt" changelog "version.txt"
}
package () {
- cd $srcdir
+ cd "$srcdir"
+ install -d "$pkgdir"/opt/epsxe/{cfg,plugins}
- install -d $pkgdir/opt/epsxe/{cfg,plugins}
-
- install -t "$pkgdir/opt/epsxe/cfg" $(find . -name "cfg*" -print) $(find . -name "*.cfg" -print)
+ install -t "$pkgdir/opt/epsxe/cfg" $(find . -name "cfg*" -print) $(find . -name "*.cfg" -print)
install -t "$pkgdir/opt/epsxe/plugins" $(find . -name "*.so.*" -print)
install -d "$pkgdir/usr/share/doc/$pkgname"
- install -m 644 -t "$pkgdir/usr/share/doc/$pkgname" README changelog
-
+ install -m 644 -t "$pkgdir/usr/share/doc/$pkgname" README changelog
+
# permissions
- chown root:games $pkgdir/opt/epsxe/cfg/{cfgPeteXGL2,gpuPeteXGL2.cfg}
- chown root:games $pkgdir/opt/epsxe/plugins/libgpuPeteXGL2.so.2.0.9
- chmod 775 $pkgdir/opt/epsxe/{plugins,cfg}
- chmod 775 $pkgdir/opt/epsxe/cfg/cfgPeteXGL2
- chmod 664 $pkgdir/opt/epsxe/cfg/gpuPeteXGL2.cfg
- chmod 775 $pkgdir/opt/epsxe/plugins/libgpuPeteXGL2.so.2.0.9
+ chown root:games "$pkgdir"/opt/epsxe/cfg/{cfgPeteXGL2,gpuPeteXGL2.cfg}
+ chown root:games "$pkgdir"/opt/epsxe/plugins/libgpuPeteXGL2.so.2.0.9
+ chmod 775 "$pkgdir"/opt/epsxe/{plugins,cfg}
+ chmod 775 "$pkgdir"/opt/epsxe/cfg/cfgPeteXGL2
+ chmod 664 "$pkgdir"/opt/epsxe/cfg/gpuPeteXGL2.cfg
+ chmod 775 "$pkgdir"/opt/epsxe/plugins/libgpuPeteXGL2.so.2.0.9
}