summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNils Van Zuijlen2018-07-15 17:09:41 +0200
committerNils Van Zuijlen2018-07-15 17:09:41 +0200
commit67a428f59d26686db7d2d05c0a6017e2c1689d8d (patch)
tree24dce86bb40a9f1c1deb845ea5045c60d287b4e8
downloadaur-67a428f59d26686db7d2d05c0a6017e2c1689d8d.tar.gz
1.3.0
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD26
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2a49f3f423d9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = eqonomize-bin
+ pkgdesc = Eqonomize! is a cross-platform personal accounting software, with focus on efficiency and ease of use for the small household economy.
+ pkgver = 1.3
+ pkgrel = 1
+ url = http://eqonomize.github.io/
+ arch = x86_64
+ license = GPL3
+ depends = qt5-base
+ optdepends = qt5-charts: charts in the statistics
+ provides = eqonomize
+ conflicts = eqonomize
+ source = https://github.com/Eqonomize/Eqonomize/releases/download/v1.3.0/eqonomize-1.3-bin.tar.gz
+ source = https://raw.githubusercontent.com/Eqonomize/Eqonomize/v1.3.0/data/eqonomize.desktop
+ sha256sums = 33db98dc22c09fe7f6f94a5e0edec4ecc147505e102b5454f251884d3aa3f8e0
+ sha256sums = 3c011e0820f85d5f25eefd7db5257fb11cd7effcc1a9eaea6a6dc12db9c5ad1a
+
+pkgname = eqonomize-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..601a048622a0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Amael <nils.van-zuijlen@mailo.com>
+pkgname=eqonomize-bin
+pkgver=1.3
+pkgrel=1
+arch=('x86_64')
+pkgdesc="Eqonomize! is a cross-platform personal accounting software, with focus on efficiency and ease of use for the small household economy."
+url="http://eqonomize.github.io/"
+license=('GPL3')
+depends=('qt5-base')
+optdepends=('qt5-charts: charts in the statistics')
+provides=('eqonomize')
+conflicts=('eqonomize')
+source=("https://github.com/Eqonomize/Eqonomize/releases/download/v1.3.0/eqonomize-1.3-bin.tar.gz"
+ "https://raw.githubusercontent.com/Eqonomize/Eqonomize/v1.3.0/data/eqonomize.desktop")
+sha256sums=('33db98dc22c09fe7f6f94a5e0edec4ecc147505e102b5454f251884d3aa3f8e0'
+ '3c011e0820f85d5f25eefd7db5257fb11cd7effcc1a9eaea6a6dc12db9c5ad1a')
+
+package() {
+ mkdir -p "$pkgdir/usr/bin"
+ cp "eqonomize" "$pkgdir/usr/bin/eqonomize"
+ chmod +x "$pkgdir/usr/bin/eqonomize"
+
+ mkdir -p "$pkgdir/usr/share/applications"
+ cp "eqonomize.desktop" "$pkgdir/usr/share/applications"
+ chmod +x "$pkgdir/usr/share/applications/eqonomize.desktop"
+}