summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJ5lx2015-06-09 16:48:50 +0200
committerJ5lx2015-06-09 16:48:50 +0200
commit1de3717c2c90760f618555150d426be86cba656a (patch)
treeb5cc7cd05e21ef1e4ae9b326b5c6c0bdb27e405e
downloadaur-1de3717c2c90760f618555150d426be86cba656a.tar.gz
Initial import
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD39
-rw-r--r--equalx.install11
-rw-r--r--qmake-install.patch11
4 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..af140fd3864e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = equalx
+ pkgdesc = makes you easily write equations in LaTeX and preview them in real-time.
+ pkgver = 0.7.1
+ pkgrel = 1
+ url = http://equalx.sourceforge.net
+ install = equalx.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = qt4
+ depends = exempi
+ depends = texlive-bin
+ depends = poppler
+ optdepends = ghostscript: to export pdf and ps
+ source = http://downloads.sourceforge.net/project/equalx/EqualX-0.7/equalx-0.7.1.tar.gz
+ source = qmake-install.patch
+ md5sums = f7164b254f25fb265388b46e3fb8e464
+ md5sums = 99f99f9257f25426f9b0e38a95ab8c7f
+
+pkgname = equalx
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ff9fd2d25171
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+
+pkgname=equalx
+pkgver=0.7.1
+pkgrel=1
+pkgdesc="makes you easily write equations in LaTeX and preview them in real-time. "
+url="http://equalx.sourceforge.net"
+depends=("qt4" "exempi" "texlive-bin" "poppler")
+optdepends=("ghostscript: to export pdf and ps")
+license=("GPL3")
+source=("http://downloads.sourceforge.net/project/${pkgname}/EqualX-$(echo ${pkgver} | grep -Po "^[0-9]\.[0-9]")/${pkgname}-${pkgver}.tar.gz"
+ "qmake-install.patch")
+arch=('i686' 'x86_64')
+install=equalx.install
+md5sums=('f7164b254f25fb265388b46e3fb8e464'
+ '99f99f9257f25426f9b0e38a95ab8c7f')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+ patch -p1 -i "$srcdir/qmake-install.patch"
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ qmake-qt4 ${pkgname}.pro
+ make
+}
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make INSTALL_ROOT="$pkgdir" install
+ install -Dm755 resources/equalx.desktop \
+ "$pkgdir"/usr/share/applications/equalx.desktop
+ for _size in 16 22 24 32 48 64 128; do
+ install -Dm644 resources/icons/equalx/equalx-${_size}x${_size}.png \
+ "$pkgdir"/usr/share/icons/hicolor/${_size}x${_size}/apps/equalx-icon.png
+ done
+ install -Dm644 resources/icons/equalx/equalx.svg \
+ "$pkgdir"/usr/share/icons/hicolor/scalable/apps/equalx.svg
+}
diff --git a/equalx.install b/equalx.install
new file mode 100644
index 000000000000..2293e37d946b
--- /dev/null
+++ b/equalx.install
@@ -0,0 +1,11 @@
+post_install() {
+ [ -e $(which xdg-icon-resource) ] && xdg-icon-resource forceupdate --theme hicolor
+ update-desktop-database -q
+}
+post_upgrade() {
+ post_install
+ echo "If EqualX segfaults / crashes when starting you may have to delete ~/.config/equalx/settings.conf"
+}
+post_remove() {
+ post_install
+}
diff --git a/qmake-install.patch b/qmake-install.patch
new file mode 100644
index 000000000000..56f115bc6dea
--- /dev/null
+++ b/qmake-install.patch
@@ -0,0 +1,11 @@
+diff -aur package.pristine/equalx.pro package.new/equalx.pro
+--- package.pristine/equalx.pro 2014-11-22 18:33:32.411447229 +0100
++++ package.new/equalx.pro 2014-11-22 18:34:07.151131916 +0100
+@@ -51,6 +51,7 @@
+ src \
+ ui
+
++target.path = /usr/bin
+ INSTALLS += target
+ DISTFILES += resources/templates/* \
+ resources/icons/menu/* \