summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakob Gahde2017-06-03 16:41:37 +0200
committerJakob Gahde2017-06-03 16:41:37 +0200
commitd3f165ada64f77ba00a34986465a87cbfe5d30f7 (patch)
treee2cd62c36e6e92a7b8f23c9e4fdc69e862045f47
parent1de3717c2c90760f618555150d426be86cba656a (diff)
downloadaur-d3f165ada64f77ba00a34986465a87cbfe5d30f7.tar.gz
equalx 0.7.1-2: Fix and improve install procedure
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD52
-rw-r--r--equalx.install10
-rw-r--r--qmake-install.patch11
4 files changed, 32 insertions, 51 deletions
diff --git a/.SRCINFO b/.SRCINFO
index af140fd3864e..333a20179864 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,10 @@
+# Generated by mksrcinfo v8
+# Sat Jun 3 14:40:40 UTC 2017
pkgbase = equalx
- pkgdesc = makes you easily write equations in LaTeX and preview them in real-time.
+ pkgdesc = Makes you easily write equations in LaTeX and preview them in real-time
pkgver = 0.7.1
- pkgrel = 1
- url = http://equalx.sourceforge.net
+ pkgrel = 2
+ url = http://equalx.sourceforge.net/
install = equalx.install
arch = i686
arch = x86_64
@@ -13,9 +15,7 @@ pkgbase = equalx
depends = poppler
optdepends = ghostscript: to export pdf and ps
source = http://downloads.sourceforge.net/project/equalx/EqualX-0.7/equalx-0.7.1.tar.gz
- source = qmake-install.patch
md5sums = f7164b254f25fb265388b46e3fb8e464
- md5sums = 99f99f9257f25426f9b0e38a95ab8c7f
pkgname = equalx
diff --git a/PKGBUILD b/PKGBUILD
index ff9fd2d25171..3113f551c889 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,38 +2,38 @@
pkgname=equalx
pkgver=0.7.1
-pkgrel=1
-pkgdesc="makes you easily write equations in LaTeX and preview them in real-time. "
-url="http://equalx.sourceforge.net"
+pkgrel=2
+pkgdesc="Makes you easily write equations in LaTeX and preview them in real-time"
+url="http://equalx.sourceforge.net/"
depends=("qt4" "exempi" "texlive-bin" "poppler")
optdepends=("ghostscript: to export pdf and ps")
license=("GPL3")
-source=("http://downloads.sourceforge.net/project/${pkgname}/EqualX-$(echo ${pkgver} | grep -Po "^[0-9]\.[0-9]")/${pkgname}-${pkgver}.tar.gz"
- "qmake-install.patch")
-arch=('i686' 'x86_64')
+source=("http://downloads.sourceforge.net/project/${pkgname}/EqualX-${pkgver%.*}/${pkgname}-${pkgver}.tar.gz")
+arch=('i686' 'x86_64')
install=equalx.install
-md5sums=('f7164b254f25fb265388b46e3fb8e464'
- '99f99f9257f25426f9b0e38a95ab8c7f')
-
-prepare() {
- cd "$srcdir/$pkgname-$pkgver"
- patch -p1 -i "$srcdir/qmake-install.patch"
-}
+md5sums=('f7164b254f25fb265388b46e3fb8e464')
build() {
- cd "$srcdir/$pkgname-$pkgver"
- qmake-qt4 ${pkgname}.pro
- make
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ qmake-qt4
+ make
}
+
package() {
- cd "$srcdir/$pkgname-$pkgver"
- make INSTALL_ROOT="$pkgdir" install
- install -Dm755 resources/equalx.desktop \
- "$pkgdir"/usr/share/applications/equalx.desktop
- for _size in 16 22 24 32 48 64 128; do
- install -Dm644 resources/icons/equalx/equalx-${_size}x${_size}.png \
- "$pkgdir"/usr/share/icons/hicolor/${_size}x${_size}/apps/equalx-icon.png
- done
- install -Dm644 resources/icons/equalx/equalx.svg \
- "$pkgdir"/usr/share/icons/hicolor/scalable/apps/equalx.svg
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ install -Dm755 "equalx" "${pkgdir}/usr/bin/equalx"
+ for _symbol in $(find resources/symbols -type f); do
+ install -Dm644 "${_symbol}" "${pkgdir}/usr/share/equalx/${_symbol}"
+ done
+ install -Dm644 "resources/equalx.desktop" \
+ "${pkgdir}/usr/share/applications/equalx.desktop"
+ for _size in 16 22 24 32 48 64 128; do
+ install -Dm644 "resources/icons/equalx/equalx-${_size}x${_size}.png" \
+ "${pkgdir}/usr/share/icons/hicolor/${_size}x${_size}/apps/equalx-icon.png"
+ done
+ install -Dm644 "resources/icons/equalx/equalx.svg" \
+ "${pkgdir}"/usr/share/icons/hicolor/scalable/apps/equalx.svg
+ install -Dm644 "equalx.1" "${pkgdir}/usr/share/man/man1/equalx.1"
}
diff --git a/equalx.install b/equalx.install
index 2293e37d946b..b5ca1e58ea60 100644
--- a/equalx.install
+++ b/equalx.install
@@ -1,11 +1,3 @@
-post_install() {
- [ -e $(which xdg-icon-resource) ] && xdg-icon-resource forceupdate --theme hicolor
- update-desktop-database -q
-}
post_upgrade() {
- post_install
- echo "If EqualX segfaults / crashes when starting you may have to delete ~/.config/equalx/settings.conf"
-}
-post_remove() {
- post_install
+ echo "If EqualX segfaults / crashes when starting you might have to delete ~/.config/equalx/settings.conf"
}
diff --git a/qmake-install.patch b/qmake-install.patch
deleted file mode 100644
index 56f115bc6dea..000000000000
--- a/qmake-install.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -aur package.pristine/equalx.pro package.new/equalx.pro
---- package.pristine/equalx.pro 2014-11-22 18:33:32.411447229 +0100
-+++ package.new/equalx.pro 2014-11-22 18:34:07.151131916 +0100
-@@ -51,6 +51,7 @@
- src \
- ui
-
-+target.path = /usr/bin
- INSTALLS += target
- DISTFILES += resources/templates/* \
- resources/icons/menu/* \