summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraki-nyan2023-04-02 19:58:55 +0200
committeraki-nyan2023-04-02 19:58:55 +0200
commita0dc3af0dc2af0b0457c576f857a9e669ba03afe (patch)
treefe4181bee4d4c83fa75b00a3563c2c129d919da0
downloadaur-a0dc3af0dc2af0b0457c576f857a9e669ba03afe.tar.gz
Bumped eqy-nightly Version to 20230402_cc91b45
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD37
-rw-r--r--PKGBUILD.in37
4 files changed, 99 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..315f36aa9354
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = eqy-nightly
+ pkgdesc = Equivalence Checking with Yosys
+ pkgver = 20230402_cc91b45
+ pkgrel = 1
+ epoch = 1
+ url = https://github.com/YosysHQ/eqy
+ arch = any
+ license = custom:ISC
+ makedepends = git
+ makedepends = gcc
+ makedepends = yosys-nightly
+ depends = yosys-nightly
+ depends = sby-nightly
+ depends = python
+ depends = python-click
+ options = !strip
+ source = eqy::git+https://github.com/YosysHQ/eqy.git#commit=cc91b45
+ sha256sums = SKIP
+
+pkgname = eqy-nightly
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ff301b174ab6
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!PKGBUILD
+!PKGBUILD.in
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8cf6851313ff
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Aki-nyan <aur@catgirl.link>
+
+pkgname=eqy-nightly
+pkgver=20230402_cc91b45
+pkgrel=1
+epoch=1
+pkgdesc="Equivalence Checking with Yosys"
+arch=("any")
+url="https://github.com/YosysHQ/eqy"
+license=("custom:ISC")
+groups=()
+options=("!strip")
+depends=("yosys-nightly" "sby-nightly" "python" "python-click")
+optdepends=()
+makedepends=("git" "gcc" "yosys-nightly")
+conflicts=()
+replaces=()
+source=(
+ "eqy::git+https://github.com/YosysHQ/eqy.git#commit=cc91b45"
+)
+sha256sums=(
+ "SKIP"
+)
+
+_PREFIX="/usr"
+
+build() {
+ cd "${srcdir}/eqy"
+ make PREFIX="${_PREFIX}"
+}
+
+package() {
+ cd "${srcdir}/eqy"
+ make PREFIX="${_PREFIX}" DESTDIR="${pkgdir}" install
+ install -Dm644 COPYING "${pkgdir}/usr/share/licenses/eqy/LICENSE"
+ cd ..
+}
diff --git a/PKGBUILD.in b/PKGBUILD.in
new file mode 100644
index 000000000000..6329271029b0
--- /dev/null
+++ b/PKGBUILD.in
@@ -0,0 +1,37 @@
+# Maintainer: Aki-nyan <aur@catgirl.link>
+
+pkgname=eqy-nightly
+pkgver=@EQY_VER@
+pkgrel=1
+epoch=1
+pkgdesc="Equivalence Checking with Yosys"
+arch=("any")
+url="https://github.com/YosysHQ/eqy"
+license=("custom:ISC")
+groups=()
+options=("!strip")
+depends=("yosys-nightly" "sby-nightly" "python" "python-click")
+optdepends=()
+makedepends=("git" "gcc" "yosys-nightly")
+conflicts=()
+replaces=()
+source=(
+ "eqy::git+https://github.com/YosysHQ/eqy.git#commit=@EQY_HASH@"
+)
+sha256sums=(
+ "SKIP"
+)
+
+_PREFIX="/usr"
+
+build() {
+ cd "${srcdir}/eqy"
+ make PREFIX="${_PREFIX}"
+}
+
+package() {
+ cd "${srcdir}/eqy"
+ make PREFIX="${_PREFIX}" DESTDIR="${pkgdir}" install
+ install -Dm644 COPYING "${pkgdir}/usr/share/licenses/eqy/LICENSE"
+ cd ..
+}