summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFiras Zaidan2020-04-06 20:53:41 +0200
committerFiras Zaidan2020-04-06 20:53:41 +0200
commit651f125ec62c8ddb5f0d0ef39effb2513019b258 (patch)
tree5a9b54ba7134a01dc6fd09bb6daba2c4ec1c2304
downloadaur-erd.tar.gz
Add PKGBUILD for version `0.2.1.0`
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD50
2 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ea85521ac9b7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = erd
+ pkgdesc = A utility for generating entity-relationship diagrams from plain-text descriptions
+ pkgver = 0.2.1.0
+ pkgrel = 1
+ url = https://github.com/BurntSushi/erd
+ arch = i686
+ arch = x86_64
+ license = Unlicense
+ makedepends = ghc
+ depends = ghc-libs
+ depends = haskell-base
+ depends = haskell-bytestring
+ depends = haskell-containers
+ depends = haskell-directory
+ depends = haskell-filepath
+ depends = haskell-gitrev
+ depends = haskell-graphviz
+ depends = haskell-parsec
+ depends = haskell-raw-strings-qq
+ depends = haskell-text
+ depends = haskell-yaml
+ source = https://hackage.haskell.org/packages/archive/erd/0.2.1.0/erd-0.2.1.0.tar.gz
+ sha512sums = bb21d17401c4b4d9e3c7c6293f4550141b29502c8244a4487ff99ec19b18b3db3c4e322fdf246230304ee8509e4cb2aa250caecf119421fbfa085f97723ca638
+
+pkgname = erd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a4bb9eacee24
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Firas Zaidan <firas@zaidan.de>
+
+pkgname=erd
+pkgdesc='A utility for generating entity-relationship diagrams from plain-text descriptions'
+pkgver=0.2.1.0
+pkgrel=1
+
+url='https://github.com/BurntSushi/erd'
+license=('Unlicense')
+arch=('i686' 'x86_64')
+depends=('ghc-libs'
+ 'haskell-base'
+ 'haskell-bytestring'
+ 'haskell-containers'
+ 'haskell-directory'
+ 'haskell-filepath'
+ 'haskell-gitrev'
+ 'haskell-graphviz'
+ 'haskell-parsec'
+ 'haskell-raw-strings-qq'
+ 'haskell-text'
+ 'haskell-yaml')
+makedepends=('ghc')
+source=("https://hackage.haskell.org/packages/archive/$pkgname/$pkgver/$pkgname-$pkgver.tar.gz")
+sha512sums=('bb21d17401c4b4d9e3c7c6293f4550141b29502c8244a4487ff99ec19b18b3db3c4e322fdf246230304ee8509e4cb2aa250caecf119421fbfa085f97723ca638')
+
+build() {
+ cd ${pkgname}-${pkgver}
+
+ runhaskell Setup configure -O \
+ --enable-shared \
+ --enable-executable-dynamic \
+ --disable-library-vanilla \
+ --prefix=/usr \
+ --dynlibdir=/usr/lib \
+ --docdir="/usr/share/doc/${pkgname}" \
+ --datasubdir="${pkgname}" \
+ --libsubdir=\$compiler/site-local/\$pkgid \
+ --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
+ --ghc-option='-pie'
+ runhaskell Setup build
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+
+ runhaskell Setup.hs copy --destdir="${pkgdir}"
+ rm -r "${pkgdir}/usr/share/doc"
+ install -Dm 644 UNLICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}