summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZack Buhman2015-08-17 15:39:17 -0500
committerZack Buhman2015-08-17 15:39:17 -0500
commit4780e74e3658be1f3c714a5a3fe1409e0135d5af (patch)
treedddafc816d314b9c6f7c22236fc43e67ec70aaa2
downloadaur-4780e74e3658be1f3c714a5a3fe1409e0135d5af.tar.gz
initial
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD23
-rw-r--r--erebor-ca.install11
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a1e8900ea24c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by makepkg 4.2.1
+# Sat May 2 15:30:21 UTC 2015
+pkgbase = erebor-ca
+ pkgdesc = Erebor Certificate Authority
+ pkgver = 2
+ pkgrel = 1
+ url = https://buhman.org/
+ install = erebor-ca.install
+ arch = any
+ license = GPL
+ depends = ca-certificates-utils
+ source = https://buhman.org/erebor-ca/erebor-ca.pem
+ source = https://buhman.org/erebor-ca/erebor-ca.pem.sig
+ md5sums = 1b190f39c21c607c65cf01fb57d314e1
+ md5sums = SKIP
+
+pkgname = erebor-ca
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4f67fff390ab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Zack Buhman <zack@buhman.org>
+
+pkgname=erebor-ca
+pkgver=2
+pkgrel=1
+pkgdesc="Erebor Certificate Authority"
+url='https://buhman.org/'
+arch=('any')
+license=('GPL')
+depends=('ca-certificates-utils')
+
+install=erebor-ca.install
+source=('https://buhman.org/erebor-ca/erebor-ca.pem'
+ 'https://buhman.org/erebor-ca/erebor-ca.pem.sig')
+md5sums=('1b190f39c21c607c65cf01fb57d314e1'
+ 'SKIP')
+validpgpkeys=('5F1B59099FA4D372EC9B30714A8337182ED3B474')
+
+package() {
+ local _certdir="$pkgdir/usr/share/ca-certificates/trust-source/anchors"
+ install -d "$_certdir"
+ install -t "$_certdir" -m644 *.pem
+}
diff --git a/erebor-ca.install b/erebor-ca.install
new file mode 100644
index 000000000000..3ab161946733
--- /dev/null
+++ b/erebor-ca.install
@@ -0,0 +1,11 @@
+post_install() {
+ usr/bin/update-ca-trust
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}