summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMorten Linderud2021-01-07 21:41:23 +0100
committerMorten Linderud2021-01-07 21:41:23 +0100
commit227fc6f7788792b5a4e51a202683ec5aacc4de73 (patch)
treec06bc81376c97f33327fbdb10c8407da6fd5dbf0
downloadaur-227fc6f7788792b5a4e51a202683ec5aacc4de73.tar.gz
import from community
-rw-r--r--.SRCINFO18
-rw-r--r--ChangeLog180
-rw-r--r--PKGBUILD28
3 files changed, 226 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..14e9ee88b299
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = eric
+ pkgdesc = A full-featured Python and Ruby IDE in PyQt
+ pkgver = 20.9
+ pkgrel = 2
+ url = https://eric-ide.python-projects.org/
+ changelog = ChangeLog
+ arch = any
+ license = GPL3
+ depends = python-qscintilla-qt5
+ depends = python-pyqtwebengine
+ depends = python-pyqtchart
+ depends = qt5-svg
+ conflicts = eric-common
+ replaces = eric-common
+ source = https://downloads.sourceforge.net/eric-ide/eric6-20.9.tar.gz
+ sha512sums = ffdab3b51f0c782d79d99387d6e54bc4b5b05a40a61972731516efedbb276ea1bb9632ffe65fced25642c900a77d9240aed8d31cb3fe238292278a2fd9d53e73
+
+pkgname = eric
diff --git a/ChangeLog b/ChangeLog
new file mode 100644
index 000000000000..7ceef206f3c9
--- /dev/null
+++ b/ChangeLog
@@ -0,0 +1,180 @@
+19.06-1:
+upstream update
+
+19.03-1:
+upstream update
+
+19.01-1:
+upstream update
+
+18.11-1:
+upstream update
+
+18.10-1:
+upstream update
+
+18.08-1:
+upstream update
+
+18.06-1:
+upstream update
+
+18.05-1:
+upstream update
+
+18.04-1:
+upstream update
+
+18.03-1:
+upstream update
+
+18.02-1:
+upstream update
+
+18.01-1:
+upstream update
+
+17.12-1:
+upstream update
+
+17.11.1-1:
+upstream update
+
+17.11-1:
+upstream update
+
+17.10-1:
+upstream update
+
+17.09-1:
+upstream update
+
+17.08-1:
+upstream update
+
+17.07-1:
+upstream update
+
+17.06-1:
+upstream update
+
+17.05-1:
+upstream update
+
+17.04.1:
+upstream update
+
+17.03.1:
+upstream update
+
+17.03:
+upstream update
+
+17.02-1:
+* upstream update
+* drop qt4 versions as soon as they depend on qtwebkit
+
+17.01-1:
+upstream update
+
+16.12-1:
+upstream update
+
+16.11-1:
+upstream update
+
+6.1.11-1:
+upstream update
+
+6.1.10-1:
+upstream update
+
+6.1.9-1:
+upstream update
+
+6.1.8-1:
+upstream update
+
+6.1.7-1:
+upstream update
+
+6.1.6-1:
+upstream update
+
+6.1.5-1:
+upstream update
+
+6.1.4-2:
+drop install file, move to pacman hooks
+
+6.1.4-1:
+upstream update
+
+6.1.3-1:
+upstream update
+
+6.1.2-1:
+upstream update
+
+6.1.1-1:
+upstream update
+
+6.1.0-1:
+upstream update
+
+6.0.11-1:
+upstream update
+
+6.0.10-1:
+upstream update
+
+6.0.9-2:
+python3.5 rebuild
+
+6.0.9-1:
+upstream update
+
+6.0.8-1:
+upstream update
+
+6.0.7-1:
+upstream update
+
+6.0.6-1:
+upstream update
+
+6.0.5-1:
+upstream update
+
+6.0.4-1:
+upstream update
+
+6.0.3-1:
+upstream update
+
+6.0.2-1:
+upstream update
+
+6.0.1-2:
+* fix FS#43573
+* fix API path
+
+6.0.1-1:
+upstream update
+
+6.0.0-1:
+* upstream update
+* split to qt5 and qt4 packages
+
+5.5.2-1:
+upstream update
+
+5.5.1-1:
+upstream update
+
+5.5.0-1:
+* upstream update
+* create python2-eric package
+
+5.4.7-1:
+upstream update. Create eric-common package
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..20255d91db4a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Evgeniy Alekseev <arcanis at archlinux dot org>
+# Contributor: Ray Rashif <schiv at archlinux dot org>
+# Contributor: Brad Fanella <bradfanellaat archlinux dot us>
+# See .contrib for older/other contributors
+
+pkgname=eric
+pkgver=20.9
+pkgrel=2
+pkgdesc="A full-featured Python and Ruby IDE in PyQt"
+arch=('any')
+url="https://eric-ide.python-projects.org/"
+license=('GPL3')
+depends=('python-qscintilla-qt5' 'python-pyqtwebengine' 'python-pyqtchart' 'qt5-svg')
+conflicts=(eric-common)
+replaces=(eric-common)
+source=("https://downloads.sourceforge.net/eric-ide/eric6-$pkgver.tar.gz")
+sha512sums=('ffdab3b51f0c782d79d99387d6e54bc4b5b05a40a61972731516efedbb276ea1bb9632ffe65fced25642c900a77d9240aed8d31cb3fe238292278a2fd9d53e73')
+changelog=ChangeLog
+
+package_eric() {
+ cd eric6-$pkgver
+ python install.py -c -b "/usr/bin" -i "${pkgdir}"
+
+ # fix paths in desktop files
+ find "${pkgdir}" -name '*.desktop' -exec sed -i "s|${pkgdir}||g" {} \;
+}
+
+# vim:set ts=2 sw=2 et: