summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartinJindra2022-04-16 02:15:05 +0200
committerMartinJindra2022-04-16 02:15:05 +0200
commit517bc293e6f4aa5b2eeaf50de1f18b94e35ab468 (patch)
tree1307777394c8bd1efd2ba6d70b5ef8315108d68b
parent25547d6a7cfc8aa6897f16b9a5a0817813f5c2ca (diff)
downloadaur-517bc293e6f4aa5b2eeaf50de1f18b94e35ab468.tar.gz
Update to 22.4
Signed-off-by: MartinJindra <mjindra@derchef.email>
-rw-r--r--PKGBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fb4b1f21b407..8f7ffc2c290f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,29 @@
# Maintainer: Xavion <Xavion (dot) 0 (at) Gmail (dot) com>
+# Co-Maintainer: derchef <mjindra (at) derchef (dot) email>
# Contributor: Evgeniy Alekseev <arcanis at archlinux dot org>
# Contributor: Ray Rashif <schiv at archlinux dot org>
# Contributor: Brad Fanella <bradfanellaat archlinux dot us>
# See .contrib for older/other contributors
-
pkgname=eric
-pkgver=21.11
+pkgver=22.4
pkgrel=1
pkgdesc="A full-featured Python and Ruby IDE in PyQt"
arch=('any')
url="https://${pkgname}-ide.python-projects.org/"
license=('GPL3')
-depends=('python-qscintilla-qt5' 'python-pyqt5-webengine' 'python-pyqt5-chart' 'qt5-svg' 'python-editorconfig' 'python-asttokens')
+depends=('python-qscintilla-qt6' 'python-pyqt6-webengine' 'python-pyqt6-charts' 'qt6-svg' 'python-editorconfig' 'python-asttokens')
makedepends=('python-pip')
conflicts=(${pkgname}-common)
replaces=(${pkgname}-common)
-source=("https://downloads.sourceforge.net/${pkgname}-ide/${pkgname}6-${pkgver}.tar.gz")
+source=("https://downloads.sourceforge.net/${pkgname}-ide/${pkgname}7-${pkgver}.tar.gz")
+sha256sums=('420d04388ef365f6d886975b29e37d7bd8aa7fdcd9e4f18187adacb5a31f105b')
package_eric() {
- cd "${pkgname}6-${pkgver}"
+ cd "${pkgname}7-${pkgver}"
- python install.py -c -b "/usr/bin" -i "${pkgdir}"
+ python install.py -c -b "/usr/bin" -i "${pkgdir}"
- # fix paths in desktop files
- find "${pkgdir}" -name '*.desktop' -exec sed -i "s|${pkgdir}||g" {} \;
+ # fix paths in desktop files
+ find "${pkgdir}" -name '*.desktop' -exec sed -i "s|${pkgdir}||g" {} \;
}
-sha256sums=('fdc62c8360b704d4ad38aba56898917f4d5ad1f5a01adc4d1a67648b23c28418')