summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxDShot2023-08-05 20:13:53 +0300
committerxDShot2023-08-05 20:13:53 +0300
commit94d6817e8f4e4580b14298464f09e71ab65de8fc (patch)
tree52df9f22fbe0c9af3f90f2089310e9e8cc0a6576
parentc4b09310141b1d7c15c34e0a275a5009823dd33b (diff)
downloadaur-94d6817e8f4e4580b14298464f09e71ab65de8fc.tar.gz
update
new submodules switch to embree3 added python-sphinx-furo
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD45
2 files changed, 36 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6ea3c1438e48..496c28ae40f8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,27 @@
pkgbase = ericw-tools-git
pkgdesc = Quake/Hexen 2 Map compiling tools
- pkgver = 0.18.2.rc1.r356.g6e96ae7c
+ pkgver = 0.18.2.rc1.r2115.g9f7ba657
pkgrel = 1
url = https://ericwa.github.io/ericw-tools
arch = x86_64
license = GPL3
makedepends = cmake
makedepends = git
- depends = embree
+ makedepends = python-sphinx
+ makedepends = python-sphinx-furo
+ depends = embree3
depends = groff
+ depends = tbb
provides = ericw-tools
conflicts = ericw-tools
- source = ericw-tools::git+https://github.com/ericwa/ericw-tools.git
+ source = ericw-tools::git+https://github.com/ericwa/ericw-tools.git#branch=brushbsp
source = fmt::git+https://github.com/fmtlib/fmt.git
- source = googletest::git+https://github.com/google/googletest.git
source = json::git+https://github.com/ArthurSonzogni/nlohmann_json_cmake_fetchcontent.git
+ source = nanobench::git+https://github.com/martinus/nanobench
+ source = pareto::git+https://github.com/alandefreitas/pareto.git
+ source = doctest::git+https://github.com/doctest/doctest
+ sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 18f4922fee41..90509f1dba94 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,28 @@
_pkgname=ericw-tools
pkgname=${_pkgname}-git
-pkgver=0.18.2.rc1.r356.g6e96ae7c
+pkgver=0.18.2.rc1.r2115.g9f7ba657
pkgrel=1
pkgdesc="Quake/Hexen 2 Map compiling tools"
arch=('x86_64')
url="https://ericwa.github.io/ericw-tools"
_giturl="https://github.com/ericwa/ericw-tools"
license=('GPL3')
-depends=('embree' 'groff')
-makedepends=('cmake' 'git')
+depends=('embree3' 'groff' 'tbb')
+makedepends=('cmake' 'git' 'python-sphinx' 'python-sphinx-furo')
provides=(${_pkgname})
conflicts=(${_pkgname})
-source=("${_pkgname}::git+${_giturl}.git"
+source=("${_pkgname}::git+${_giturl}.git#branch=brushbsp"
"fmt::git+https://github.com/fmtlib/fmt.git"
- "googletest::git+https://github.com/google/googletest.git"
"json::git+https://github.com/ArthurSonzogni/nlohmann_json_cmake_fetchcontent.git"
+ "nanobench::git+https://github.com/martinus/nanobench"
+ "pareto::git+https://github.com/alandefreitas/pareto.git"
+ "doctest::git+https://github.com/doctest/doctest"
)
sha256sums=('SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
+ 'SKIP'
'SKIP')
pkgver() {
@@ -27,30 +31,31 @@ pkgver() {
}
prepare() {
- cd "${_pkgname}/3rdparty/"
- rm -r "fmt"
- ln -s "${srcdir}/fmt"
- rm -r "googletest"
- ln -s "${srcdir}/googletest"
- rm -r "json"
- ln -s "${srcdir}/json"
+ cd $_pkgname
+ git config submodule.lib/fmt.url ../fmt
+ git config submodule.3rdparty/json.url ../json
+ git config submodule.3rdparty/nanobench.url ../nanobench
+ git config submodule.3rdparty/pareto.url ../pareto
+ git config submodule.3rdparty/doctest.url ../doctest
+ git submodule update
}
build() {
- cd ${_pkgname}
- rm -rf build
- mkdir build
- cd build
- cmake ..
- make
+ cmake -S ${_pkgname} -B build \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ cmake --build build
}
package() {
_files=(qbsp vis light bspinfo bsputil)
for _i in "${_files[@]}"
do
- install -Dm755 ${_pkgname}/build/${_i}/${_i} "$pkgdir"/usr/bin/${_i}
- install -Dm644 ${_pkgname}/build/man/${_i}.html -t "${pkgdir}"/usr/share/doc/${_pkgname}
+ install -Dm755 build/${_i}/${_i} "$pkgdir"/usr/bin/${_i}
done
+
+ cd build/docs/docs/sphinx/
+ rm -r .doctrees/ .buildinfo
+ find . -type f -exec install -Dm644 "{}" "${pkgdir}"/usr/share/doc/${_pkgname}/{} \;
}