summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxDShot2021-08-30 14:53:49 +0300
committerxDShot2021-08-30 14:53:49 +0300
commitc5da595839cff400966477d8b885781340046aaa (patch)
treefab540a0b86d76bdb9b31c90d5e6c307a6fa6906
downloadaur-c5da595839cff400966477d8b885781340046aaa.tar.gz
initial
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD44
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f4d8f015acb4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ericw-tools-git
+ pkgdesc = Quake/Hexen 2 Map compiling tools
+ pkgver = v0.18.2.rc1.r149.g968a840
+ pkgrel = 1
+ url = http://ericwa.github.io/ericw-tools
+ arch = x86_64
+ license = GPL3
+ makedepends = cmake
+ depends = embree
+ depends = groff
+ conflicts = ericw-tools
+ source = ericw-tools::git+https://github.com/ericwa/ericw-tools.git
+ sha256sums = SKIP
+
+pkgname = ericw-tools-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a1e83af89562
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.pkg*
+src/*
+pkg/*
+ericw-tools/*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..157431b68c55
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+_pkgname=ericw-tools
+pkgname=${_pkgname}-git
+pkgver=v0.18.2.rc1.r149.g968a840
+pkgrel=1
+pkgdesc="Quake/Hexen 2 Map compiling tools"
+arch=('x86_64')
+url="http://ericwa.github.io/ericw-tools"
+_giturl="https://github.com/ericwa/ericw-tools"
+license=('GPL3')
+depends=('embree' 'groff')
+makedepends=('cmake')
+conflicts=(${_pkgname})
+source=("${_pkgname}::git+${_giturl}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${_pkgname}
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd ${_pkgname}
+ # HACK fixes cmake not able to find embree license
+ touch light/EMBREE_LICENSE-NOTFOUND
+ git submodule update --init --recursive --force
+}
+
+build() {
+ cd ${_pkgname}
+ mkdir build
+ cd build
+ cmake ..
+ make
+}
+
+package() {
+ _files=(qbsp vis light bspinfo bsputil)
+ for _i in "${_files[@]}"
+ do
+ install -Dm755 ${_pkgname}/build/${_i}/${_i} "$pkgdir"/usr/bin/${_i}
+ install -Dm644 ${_pkgname}/build/man/${_i}.html -t "${pkgdir}"/usr/share/doc/${_pkgname}
+ done
+}
+