summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatheus2023-04-19 06:57:11 +0200
committerMatheus2023-04-19 06:57:11 +0200
commit72994e82deaa678418e916e7e326579c0f5a5239 (patch)
tree410db9c6e3ceed238c238b4b5d5ce709dc193614
parentb2ff62505aad5d5b889f9ef8b6e1a0075ba34f6d (diff)
downloadaur-72994e82deaa678418e916e7e326579c0f5a5239.tar.gz
Plugins removed.
-rwxr-xr-xPKGBUILD115
-rwxr-xr-xerpnext.install2
2 files changed, 1 insertions, 116 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 70b1ef974ccf..56b915a8bf29 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,8 +6,6 @@
# Contributor: Matheus <matheusgwdl@protonmail.com>
readonly _version_frappe="v14.33.0"
-readonly _version_health="v14.0.0"
-readonly _version_hrms="v14.2.2"
pkgname="erpnext"
pkgver="14.22.0"
@@ -35,125 +33,12 @@ sha512sums=("bbe29f6dc3d87a3ec0089c63ce4146d550172264c4a3a232f3f5a9868d0aae13ff9
build()
{
- # Frappe
cd "${srcdir}"/ || exit 1
bench init --frappe-branch "${_version_frappe}" "${pkgname}"
-
- # ERPNext
cd "${srcdir}"/"${pkgname}"/ || exit 1
bench get --branch v"${pkgver}" --resolve-deps "${pkgname}" "${url}.git"
bench new-site --db-name "${pkgname}" --set-default "${pkgname}"
bench --site "${pkgname}" install-app "${pkgname}"
-
- # Plugins
- # TODO Clone a version where possible.
- ## The installation of some plugins requires running processes.
- tmux new-session -s erpnext-build "cd ${srcdir}/ && bench start"
-
- ## Agriculture
- if [[ "${ERPNEXT_AGRICULTURE}" == "ON" ]]; then
- bench get --resolve-deps agriculture https://github.com/frappe/agriculture.git
- bench --site "${pkgname}" install-app agriculture
- fi
-
- ## Education
- if [[ "${ERPNEXT_EDUCATION}" == "ON" ]]; then
- bench get --resolve-deps education https://github.com/frappe/education.git
- bench --site "${pkgname}" install-app education
- fi
-
- ## ERPNext France
- if [[ "${ERPNEXT_ERPNEXT_FRANCE}" == "ON" ]]; then
- bench get --resolve-deps erpnext-france https://github.com/frappe/erpnext_france.git
- bench --site "${pkgname}" install-app erpnext-france
- fi
-
- ## ERPNext Italy
- if [[ "${ERPNEXT_ERPNEXT_ITALY}" == "ON" ]]; then
- bench get --resolve-deps erpnext-italy https://github.com/frappe/erpnext_italy.git
- bench --site "${pkgname}" install-app erpnext-italy
- fi
-
- ## ERPNext KSA
- if [[ "${ERPNEXT_ERPNEXT_KSA}" == "ON" ]]; then
- bench get --resolve-deps erpnext-ksa https://github.com/frappe/erpnext_ksa.git
- bench --site "${pkgname}" install-app erpnext-ksa
- fi
-
- ## ERPNext shipping
- if [[ "${ERPNEXT_ERPNEXT_SHIPPING}" == "ON" ]]; then
- bench get --resolve-deps erpnext-shipping https://github.com/frappe/erpnext-shipping.git
- bench --site "${pkgname}" install-app erpnext-shipping
- fi
-
- ## ERPNext South Africa
- if [[ "${ERPNEXT_ERPNEXT_SOUTH_AFRICA}" == "ON" ]]; then
- bench get --resolve-deps erpnext-south-africa https://github.com/frappe/erpnext_south_africa.git
- bench --site "${pkgname}" install-app erpnext-south-africa
- fi
-
- ## ERPNext UAE
- if [[ "${ERPNEXT_ERPNEXT_UAE}" == "ON" ]]; then
- bench get --resolve-deps erpnext-uae https://github.com/frappe/erpnext_uae.git
- bench --site "${pkgname}" install-app erpnext-uae
- fi
-
- ## ERPNext USA
- if [[ "${ERPNEXT_ERPNEXT_USA}" == "ON" ]]; then
- bench get --resolve-deps erpnext-usa https://github.com/frappe/erpnext_usa.git
- bench --site "${pkgname}" install-app erpnext-usa
- fi
-
- ## Exotel integration
- if [[ "${ERPNEXT_EXOTEL_INTEGRATION}" == "ON" ]]; then
- bench get --resolve-deps exotel-integration https://github.com/frappe/exotel_integration.git
- bench --site "${pkgname}" install-app exotel-integation
- fi
-
- ## Health
- if [[ "${ERPNEXT_HEALTH}" == "ON" ]]; then
- bench get --branch "${_version_health}" --resolve-deps health https://github.com/frappe/health.git
- bench --site "${pkgname}" install-app healthcare
- fi
-
- ## Hospitality
- if [[ "${ERPNEXT_HOSPITALITY}" == "ON" ]]; then
- bench get --resolve-deps hospitality https://github.com/frappe/hospitality.git
- bench --site "${pkgname}" install-app hospitality
- fi
-
- ## HRMS
- if [[ "${ERPNEXT_HRMS}" == "ON" ]]; then
- bench get --branch "${_version_hrms}" --resolve-deps hrms https://github.com/frappe/hrms.git
- bench --site "${pkgname}" install-app hrms
- fi
-
- ## Non-profit
- if [[ "${ERPNEXT_NON_PROFIT}" == "ON" ]]; then
- bench get --resolve-deps non-profit https://github.com/frappe/non_profit.git
- bench --site "${pkgname}" install-app non-profit
- fi
-
- ## Taxjar integration
- if [[ "${ERPNEXT_TAXJAR_INTEGRATION}" == "ON" ]]; then
- bench get --resolve-deps taxjar-integration https://github.com/frappe/taxjar_integration.git
- bench --site "${pkgname}" install-app taxjar-integration
- fi
-
- ## Twilio integration
- if [[ "${ERPNEXT_TWILIO_INTEGRATION}" == "ON" ]]; then
- bench get --resolve-deps twilio-integration https://github.com/frappe/twilio-integration.git
- bench --site "${pkgname}" install-app twilio-integration
- fi
-
- ## Webshop
- if [[ "${ERPNEXT_WEBSHOP}" == "ON" ]]; then
- bench get --resolve-deps webshop https://github.com/frappe/webshop.git
- bench --site "${pkgname}" install-app webshop
- fi
-
- ## End the processes.
- tmux send-keys -t erpnext-build C-c
}
package()
diff --git a/erpnext.install b/erpnext.install
index cd27f6d2e207..81f0187aa2b9 100755
--- a/erpnext.install
+++ b/erpnext.install
@@ -8,5 +8,5 @@ declare -r green="\033[0;32m"
pre_install()
{
- echo -e "${green}Configuration for plugins is available via the setting of environment variables.${clear_colour}"
+ echo -e "${green}Plugins need to be installed manually.${clear_colour}"
}