summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatheus2023-04-19 06:45:14 +0200
committerMatheus2023-04-19 06:45:14 +0200
commitb2ff62505aad5d5b889f9ef8b6e1a0075ba34f6d (patch)
treeb6fe9bff88cedf7dfb6c781bebad8dc7db3a50df
parentd02b07c9aca29f9e1959ee691d64193e7e724502 (diff)
downloadaur-b2ff62505aad5d5b889f9ef8b6e1a0075ba34f6d.tar.gz
Error fix.
-rwxr-xr-x.SRCINFO1
-rwxr-xr-xPKGBUILD4
2 files changed, 3 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9d416a84f1d3..ae9155df5b90 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,6 +9,7 @@ pkgbase = erpnext
makedepends = python-build
makedepends = python-installer
makedepends = python-virtualenv
+ makedepends = tmux
depends = frappe-bench
depends = libmaxminddb
depends = nodejs
diff --git a/PKGBUILD b/PKGBUILD
index c04175db9613..70b1ef974ccf 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,7 +17,7 @@ arch=("x86_64")
url="https://github.com/frappe/${pkgname}"
license=("GPL3")
depends=("frappe-bench" "libmaxminddb" "nodejs" "python" "python-pycups")
-makedepends=("python-build" "python-installer" "python-virtualenv")
+makedepends=("python-build" "python-installer" "python-virtualenv" "tmux")
optdepends=("apache: HTTP server"
"certbot: Creates SSL certificates."
"mariadb: Database"
@@ -48,7 +48,7 @@ build()
# Plugins
# TODO Clone a version where possible.
## The installation of some plugins requires running processes.
- tmux new-session -s erpnext-build "bench start"
+ tmux new-session -s erpnext-build "cd ${srcdir}/ && bench start"
## Agriculture
if [[ "${ERPNEXT_AGRICULTURE}" == "ON" ]]; then