summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorX3n0m0rph592021-12-11 00:55:04 +0100
committerX3n0m0rph592021-12-11 00:55:04 +0100
commit383c871fcbaeb670175edff9282882261eb2d22e (patch)
tree555f674287c063f311d6e3dd2d5fdac98a65b9aa
parent38c24b56b06e88a6bbe548312fa8d26bd40280e5 (diff)
downloadaur-383c871fcbaeb670175edff9282882261eb2d22e.tar.gz
New snapshot
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD32
-rw-r--r--eruption.install10
3 files changed, 37 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ea660f3ab5ef..127c3b548c75 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = eruption-git
pkgdesc = Linux user-mode input and LED driver for keyboards, mice and other devices
- pkgver = 0.1.22.r28.g1ba264c
+ pkgver = 0.1.22
pkgrel = 1
url = https://github.com/X3n0m0rph59/eruption
install = eruption.install
@@ -19,6 +19,7 @@ pkgbase = eruption-git
depends = libpulse
depends = luajit
depends = lua51-socket
+ depends = gtksourceview4
provides = eruption
conflicts = eruption-roccat-vulcan
conflicts = eruption-roccat-vulcan-git
@@ -26,7 +27,7 @@ pkgbase = eruption-git
backup = etc/eruption/eruption.conf
backup = usr/share/eruption/scripts/lib/themes/*
backup = usr/share/eruption/scripts/lib/macros/*
- source = eruption::git+https://github.com/X3n0m0rph59/eruption.git#commit=1ba264c91fae74993144ea9d2944a390adb84dfe
+ source = eruption::git+https://github.com/X3n0m0rph59/eruption.git#commit=b99cc397e057b6f2df5ea9b065c4bdd65c68fb3d
sha512sums = SKIP
pkgname = eruption-git
diff --git a/PKGBUILD b/PKGBUILD
index dce79af7b8f4..03804fa84ef4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,14 @@
pkgname='eruption-git'
_pkgname='eruption'
pkgdesc='Linux user-mode input and LED driver for keyboards, mice and other devices'
-pkgver=0.1.22.r28.g1ba264c
-pkgrel=1
+pkgver='0.1.22'
+pkgrel='1'
epoch=
arch=('i686' 'x86_64')
url='https://github.com/X3n0m0rph59/eruption'
license=('GPL3+')
groups=()
-depends=('libevdev' 'hidapi' 'systemd-libs' 'dbus' 'libpulse' 'luajit' 'lua51-socket')
-#depends=('libevdev' 'hidapi' 'systemd-libs' 'dbus' 'libpulse' 'luajit' 'lua51-socket' 'gtksourceview3')
+depends=('libevdev' 'hidapi' 'systemd-libs' 'dbus' 'libpulse' 'luajit' 'lua51-socket' 'gtksourceview4')
makedepends=('git' 'rust' 'xorg-server-devel' 'libxrandr' 'gtk3')
checkdepends=()
optdepends=()
@@ -22,7 +21,7 @@ backup=(etc/eruption/eruption.conf usr/share/eruption/scripts/lib/themes/* usr/s
options=()
install='eruption.install'
changelog=
-source=('eruption::git+https://github.com/X3n0m0rph59/eruption.git#commit=1ba264c91fae74993144ea9d2944a390adb84dfe')
+source=('eruption::git+https://github.com/X3n0m0rph59/eruption.git#commit=b99cc397e057b6f2df5ea9b065c4bdd65c68fb3d')
noextract=()
sha512sums=('SKIP')
@@ -84,10 +83,13 @@ package() {
install -m 755 "target/release/eruption" "$pkgdir/usr/bin/"
install -m 755 "target/release/eruptionctl" "$pkgdir/usr/bin/"
+ install -m 755 "target/release/eruption-hwutil" "$pkgdir/usr/bin/"
install -m 755 "target/release/eruption-netfx" "$pkgdir/usr/bin/"
+ install -m 755 "target/release/eruption-cmd" "$pkgdir/usr/bin/"
install -m 755 "target/release/eruption-util" "$pkgdir/usr/bin/"
install -m 755 "target/release/eruption-debug-tool" "$pkgdir/usr/bin/"
install -m 755 "target/release/eruption-hotplug-helper" "$pkgdir/usr/bin/"
+ install -m 755 "target/release/eruption-audio-proxy" "$pkgdir/usr/bin/"
install -m 755 "target/release/eruption-process-monitor" "$pkgdir/usr/bin/"
install -m 755 "target/release/eruption-gui" "$pkgdir/usr/bin/"
@@ -98,11 +100,15 @@ package() {
install -m 755 "support/systemd/eruption-suspend.sh" "$pkgdir/usr/lib/systemd/system-sleep/eruption"
install -m 644 "support/config/eruption.conf" "$pkgdir/etc/eruption/"
+ install -m 644 "support/config/audio-proxy.conf" "$pkgdir/etc/eruption/"
install -m 644 "support/config/process-monitor.conf" "$pkgdir/etc/eruption/"
install -m 644 "support/systemd/eruption.service" "$pkgdir/usr/lib/systemd/system/"
install -m 644 "support/systemd/eruption.preset" "$pkgdir/usr/lib/systemd/system-preset/50-eruption.preset"
+ install -m 644 "support/systemd/eruption-audio-proxy.service" "$pkgdir/usr/lib/systemd/user/"
+ install -m 644 "support/systemd/eruption-audio-proxy.preset" "$pkgdir/usr/lib/systemd/user-preset/50-eruption-audio-proxy.preset"
+
install -m 644 "support/systemd/eruption-process-monitor.service" "$pkgdir/usr/lib/systemd/user/"
install -m 644 "support/systemd/eruption-process-monitor.preset" "$pkgdir/usr/lib/systemd/user-preset/50-eruption-process-monitor.preset"
@@ -117,24 +123,36 @@ package() {
install -m 644 "support/policykit/org.eruption.policy" "$pkgdir/usr/share/polkit-1/actions/"
install -m 644 "support/man/eruption.8" "$pkgdir/usr/share/man/man8/"
+ install -m 644 "support/man/eruption-cmd.8" "$pkgdir/usr/share/man/man8/"
+ install -m 644 "support/man/eruption-hwutil.8" "$pkgdir/usr/share/man/man8/"
install -m 644 "support/man/eruption.conf.5" "$pkgdir/usr/share/man/man5/"
install -m 644 "support/man/process-monitor.conf.5" "$pkgdir/usr/share/man/man5/"
install -m 644 "support/man/eruptionctl.1" "$pkgdir/usr/share/man/man1/"
install -m 644 "support/man/eruption-netfx.1" "$pkgdir/usr/share/man/man1/"
+ install -m 644 "support/man/eruption-audio-proxy.1" "$pkgdir/usr/share/man/man1/"
install -m 644 "support/man/eruption-process-monitor.1" "$pkgdir/usr/share/man/man1/"
+ install -m 644 -T "support/shell/completions/en_US/eruption-cmd.bash-completion" "$pkgdir/usr/share/bash-completion/completions/eruption-cmd"
+ install -m 644 -T "support/shell/completions/en_US/eruption-hwutil.bash-completion" "$pkgdir/usr/share/bash-completion/completions/eruption-hwutil"
install -m 644 -T "support/shell/completions/en_US/eruption-debug-tool.bash-completion" "$pkgdir/usr/share/bash-completion/completions/eruption-debug-tool"
install -m 644 -T "support/shell/completions/en_US/eruption-netfx.bash-completion" "$pkgdir/usr/share/bash-completion/completions/eruption-netfx"
+ install -m 644 -T "support/shell/completions/en_US/eruption-audio-proxy.bash-completion" "$pkgdir/usr/share/bash-completion/completions/eruption-audio-proxy"
install -m 644 -T "support/shell/completions/en_US/eruption-process-monitor.bash-completion" "$pkgdir/usr/share/bash-completion/completions/eruption-process-monitor"
install -m 644 -T "support/shell/completions/en_US/eruptionctl.bash-completion" "$pkgdir/usr/share/bash-completion/completions/eruptionctl"
+ install -m 644 -T "support/shell/completions/en_US/eruption-cmd.fish-completion" "$pkgdir/usr/share/fish/completions/eruption-cmd.fish"
+ install -m 644 -T "support/shell/completions/en_US/eruption-hwutil.fish-completion" "$pkgdir/usr/share/fish/completions/eruption-hwutil.fish"
install -m 644 -T "support/shell/completions/en_US/eruption-debug-tool.fish-completion" "$pkgdir/usr/share/fish/completions/eruption-debug-tool.fish"
install -m 644 -T "support/shell/completions/en_US/eruption-netfx.fish-completion" "$pkgdir/usr/share/fish/completions/eruption-netfx.fish"
+ install -m 644 -T "support/shell/completions/en_US/eruption-audio-proxy.fish-completion" "$pkgdir/usr/share/fish/completions/eruption-audio-proxy.fish"
install -m 644 -T "support/shell/completions/en_US/eruption-process-monitor.fish-completion" "$pkgdir/usr/share/fish/completions/eruption-process-monitor.fish"
install -m 644 -T "support/shell/completions/en_US/eruptionctl.fish-completion" "$pkgdir/usr/share/fish/completions/eruptionctl.fish"
+ install -m 644 -T "support/shell/completions/en_US/eruption-cmd.zsh-completion" "$pkgdir/usr/share/zsh/site-functions/_eruption-cmd"
+ install -m 644 -T "support/shell/completions/en_US/eruption-hwutil.zsh-completion" "$pkgdir/usr/share/zsh/site-functions/_eruption-hwutil"
install -m 644 -T "support/shell/completions/en_US/eruption-debug-tool.zsh-completion" "$pkgdir/usr/share/zsh/site-functions/_eruption-debug-tool"
install -m 644 -T "support/shell/completions/en_US/eruption-netfx.zsh-completion" "$pkgdir/usr/share/zsh/site-functions/_eruption-netfx"
+ install -m 644 -T "support/shell/completions/en_US/eruption-audio-proxy.zsh-completion" "$pkgdir/usr/share/zsh/site-functions/_eruption-audio-proxy"
install -m 644 -T "support/shell/completions/en_US/eruption-process-monitor.zsh-completion" "$pkgdir/usr/share/zsh/site-functions/_eruption-process-monitor"
install -m 644 -T "support/shell/completions/en_US/eruptionctl.zsh-completion" "$pkgdir/usr/share/zsh/site-functions/_eruptionctl"
@@ -263,12 +281,16 @@ package() {
install -m 644 "eruption/src/scripts/lib/hwdevices/keyboards/corsair_strafe.lua" "$pkgdir/usr/share/eruption/scripts/lib/hwdevices/keyboards/"
install -m 644 "eruption/src/scripts/lib/hwdevices/mice/generic_mouse.lua" "$pkgdir/usr/share/eruption/scripts/lib/hwdevices/mice/"
install -m 644 "eruption/src/scripts/lib/hwdevices/mice/roccat_kone_aimo.lua" "$pkgdir/usr/share/eruption/scripts/lib/hwdevices/mice/"
+ install -m 644 "eruption/src/scripts/lib/hwdevices/mice/roccat_kain_2xx.lua" "$pkgdir/usr/share/eruption/scripts/lib/hwdevices/mice/"
install -m 644 "eruption/src/scripts/lib/hwdevices/mice/roccat_kone_xtd.lua" "$pkgdir/usr/share/eruption/scripts/lib/hwdevices/mice/"
install -m 644 "eruption/src/scripts/lib/hwdevices/mice/roccat_burst_pro.lua" "$pkgdir/usr/share/eruption/scripts/lib/hwdevices/mice/"
install -m 644 "eruption/src/scripts/lib/hwdevices/mice/roccat_kone_aimo_remastered.lua" "$pkgdir/usr/share/eruption/scripts/lib/hwdevices/mice/"
install -m 644 "eruption/src/scripts/lib/hwdevices/mice/roccat_kone_pure_ultra.lua" "$pkgdir/usr/share/eruption/scripts/lib/hwdevices/mice/"
install -m 644 "eruption/src/scripts/lib/hwdevices/mice/roccat_kova_aimo.lua" "$pkgdir/usr/share/eruption/scripts/lib/hwdevices/mice/"
+ install -m 644 "eruption/src/scripts/lib/hwdevices/mice/roccat_kova_2016.lua" "$pkgdir/usr/share/eruption/scripts/lib/hwdevices/mice/"
install -m 644 "eruption/src/scripts/lib/hwdevices/mice/roccat_nyth.lua" "$pkgdir/usr/share/eruption/scripts/lib/hwdevices/mice/"
+ install -m 644 "eruption/src/scripts/lib/hwdevices/misc/roccat_elo_71_air.lua" "$pkgdir/usr/share/eruption/scripts/lib/hwdevices/misc/"
+ install -m 644 "eruption/src/scripts/lib/hwdevices/misc/roccat_aimo_pad.lua" "$pkgdir/usr/share/eruption/scripts/lib/hwdevices/misc/"
install -m 644 "eruption/src/scripts/examples/simple.lua" "$pkgdir/usr/share/eruption/scripts/examples/"
install -m 644 "support/sfx/typewriter1.wav" "$pkgdir/usr/share/eruption/sfx/"
diff --git a/eruption.install b/eruption.install
index 1bd1c793bf71..22b459e6ce73 100644
--- a/eruption.install
+++ b/eruption.install
@@ -2,15 +2,17 @@ post_install() {
setcap cap_net_admin+ep /usr/bin/eruption-process-monitor
systemctl daemon-reload
- # systemctl --global daemon-reload
+ systemctl --global daemon-reload
systemctl reload dbus.service
udevadm control --reload-rules
systemctl preset eruption
+ systemctl preset eruption-audio-proxy
systemctl preset eruption-process-monitor
systemctl enable --now eruption.service
+ systemctl --global enable --now eruption-audio-proxy.service
# systemctl --global enable --now eruption-process-monitor.service
}
@@ -24,11 +26,13 @@ post_upgrade() {
udevadm control --reload-rules
systemctl try-restart eruption.service
- # systemctl --global try-restart eruption-process-monitor.service
+ systemctl --global try-restart eruption-audio-proxy.service
+ systemctl --global try-restart eruption-process-monitor.service
}
pre_remove() {
- # systemctl --global stop eruption-process-monitor.service
+ systemctl --global stop eruption-process-monitor.service
+ systemctl --global stop eruption-audio-proxy.service
systemctl stop eruption.service
}