summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Keen2015-06-13 00:04:47 -0400
committerKyle Keen2015-06-13 00:04:47 -0400
commitc968cbfe086378c62bb842a5beffa8b9bc0ea506 (patch)
tree2bcaea51c6928958a269eb220dfebd0bd1d63d16
downloadaur-erusfont.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD23
-rw-r--r--erusfont.install21
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..43765a720b4c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = erusfont
+ pkgdesc = A bitmap font for programming and terminal/tty use, greatly inspired from montecarlo and gohufont, many thanks to their creator
+ pkgver = 0.7
+ pkgrel = 1
+ url = http://perdu.com/
+ install = erusfont.install
+ arch = any
+ license = custom:WTFPL
+ depends = xorg-fonts-encodings
+ depends = xorg-fonts-alias
+ depends = xorg-font-utils
+ depends = fontconfig
+ source = http://kmkeen.com/tmp/erusfont.src.tar.gz
+ md5sums = b9b47d2d6743c608b709a4a5dce86033
+
+pkgname = erusfont
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c6c7e7f71bfd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Kyle Keen <keenerd@gmail.com>
+# Contributor: Erus
+
+pkgname=erusfont
+pkgver=0.7
+pkgrel=1
+pkgdesc='A bitmap font for programming and terminal/tty use, greatly inspired from montecarlo and gohufont, many thanks to their creator'
+arch=(any)
+url=http://perdu.com/
+license=(custom:WTFPL)
+depends=('xorg-fonts-encodings' 'xorg-fonts-alias' 'xorg-font-utils' 'fontconfig')
+#optdepends=('xorg18-localfontdir-conf: If you are lazy and dont want to create yourself a 4line file in your xorg.conf.d')
+install=$pkgname.install
+source=('http://kmkeen.com/tmp/erusfont.src.tar.gz')
+md5sums=('b9b47d2d6743c608b709a4a5dce86033')
+
+package() {
+ cd "$srcdir/$pkgname"
+ install -Dm644 erusfont.psf.gz "$pkgdir/usr/share/kbd/consolefonts/erusfont.psf.gz"
+ install -Dm644 erusfont.pcf.gz "$pkgdir/usr/share/fonts/local/erusfont.pcf.gz"
+ install -Dm644 erusfontbold.pcf.gz "$pkgdir/usr/share/fonts/local/erusfontbold.pcf.gz"
+ install -Dm644 COPYING-LICENSE "$pkgdir/usr/share/licenses/$pkgname/COPYING-LICENSE"
+}
diff --git a/erusfont.install b/erusfont.install
new file mode 100644
index 000000000000..dffbae112794
--- /dev/null
+++ b/erusfont.install
@@ -0,0 +1,21 @@
+post_install() {
+ echo "Updating font cache... "
+ fc-cache -fs >/dev/null 2>&1
+ mkfontscale /usr/share/fonts/local
+ mkfontdir /usr/share/fonts/local
+ xset fp rehash >/dev/null 2>&1
+ echo "Make sure that you add /usr/share/fonts/local/ to xorg.conf under the"
+ echo "\"Files\" section"
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ fc-cache -fs >/dev/null 2>&1
+ mkfontscale /usr/share/fonts/local
+ mkfontdir /usr/share/fonts/local
+ xset fp rehash >/dev/null 2>&1
+}
+