summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraksr2017-10-03 15:38:39 +0200
committeraksr2017-10-03 15:38:39 +0200
commitdd06065d29b2d4a7d67f9e002c5fed2dd6260e39 (patch)
tree4271e802280cb520746f11647bef7dc213da89ee
downloadaur-dd06065d29b2d4a7d67f9e002c5fed2dd6260e39.tar.gz
Start.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD48
-rw-r--r--es.install12
3 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f80d21b89c6b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Tue Oct 3 13:38:38 UTC 2017
+pkgbase = es-shell-git
+ pkgdesc = A extensible shell with higher-order functions, derived from the Plan 9 shell, rc.
+ pkgver = 0.9.1.r2.ge65327f
+ pkgrel = 1
+ url = https://github.com/wryun/es-shell
+ install = es.install
+ arch = i686
+ arch = x86_64
+ license = Public Domain
+ makedepends = git
+ source = es-shell-git::git+https://github.com/wryun/es-shell.git
+ md5sums = SKIP
+
+pkgname = es-shell-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3c1405ea022c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: aksr <aksr at t-com dot me>
+pkgname=es-shell-git
+pkgver=0.9.1.r2.ge65327f
+pkgrel=1
+epoch=
+pkgdesc="A extensible shell with higher-order functions, derived from the Plan 9 shell, rc."
+arch=('i686' 'x86_64')
+url="https://github.com/wryun/es-shell"
+license=('Public Domain')
+categories=()
+groups=()
+depends=('')
+makedepends=('git')
+optdepends=()
+checkdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+changelog=
+install=${pkgname%-*-*}.install
+source=("$pkgname::git+https://github.com/wryun/es-shell.git")
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ git describe --tags | sed -E 's/([^-]*-g)/r\1/;s/-/./g;s/^v//'
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ aclocal
+ autoconf
+ libtoolize -qi
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ make prefix="$pkgdir/usr" install
+ mkdir -p "$pkgdir/usr/share/doc/${pkgname%-*-*}"
+ install -m644 README initial.es mksignal esdebug \
+ doc/usenix-w93.ps doc/ERRATA doc/TODO "$pkgdir/usr/share/doc/${pkgname%-*-*}"
+}
+
diff --git a/es.install b/es.install
new file mode 100644
index 000000000000..e20c0be8d5bb
--- /dev/null
+++ b/es.install
@@ -0,0 +1,12 @@
+post_install() {
+ grep -qe '^/usr/bin/es$' /etc/shells || echo '/usr/bin/es' >> /etc/shells
+}
+
+post_upgrade() {
+ post_install
+}
+
+pre_remove() {
+ sed -ri '\|^/usr/bin/es$|d' /etc/shells
+}
+