summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-12-04 11:47:20 +0800
committerzxp198210052023-12-04 11:47:20 +0800
commit315ed87bf9ec1239d8e57a78be85e98f4cf72c2a (patch)
treea0fc7c91bbcea7447395dfa0eee4e17df6ae7fe8
parent37d81b7ee4851465d4894dcf9666f4d50995dc27 (diff)
downloadaur-315ed87bf9ec1239d8e57a78be85e98f4cf72c2a.tar.gz
update to 1.16.3
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD15
-rw-r--r--escrcpy.sh17
3 files changed, 28 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2d359e62f385..7f6fa2d54746 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = escrcpy-bin
pkgdesc = 使用图形化的 Scrcpy 显示和控制您的 Android 设备,由 Electron 驱动
- pkgver = 1.16.1
+ pkgver = 1.16.3
pkgrel = 1
url = https://github.com/viarotel-org/escrcpy
arch = aarch64
@@ -9,15 +9,15 @@ pkgbase = escrcpy-bin
depends = electron27
depends = hicolor-icon-theme
depends = scrcpy
- provides = escrcpy=1.16.1
+ provides = escrcpy=1.16.3
conflicts = escrcpy
- source = LICENSE-1.16.1::https://raw.githubusercontent.com/viarotel-org/escrcpy/v1.16.1/LICENSE
+ source = LICENSE-1.16.3::https://raw.githubusercontent.com/viarotel-org/escrcpy/v1.16.3/LICENSE
source = escrcpy.sh
sha256sums = 608449f39836e08b54dbe679e78fefbd8b2a4f77ac6fc16bf7320d1e89e4bb10
- sha256sums = 941cb7196d03283a6e65a2271f0c8381a9ec8176f38ce9dc9916f3f89b29a720
- source_aarch64 = escrcpy-1.16.1-aarch64.deb::https://github.com/viarotel-org/escrcpy/releases/download/v1.16.1/Escrcpy-1.16.1-linux-arm64.deb
- sha256sums_aarch64 = 9b7800b1efa13dcbbd781f63b6ea513b22b9c0e01130b4262e0fc9d6d229516f
- source_x86_64 = escrcpy-1.16.1-x86_64.deb::https://github.com/viarotel-org/escrcpy/releases/download/v1.16.1/Escrcpy-1.16.1-linux-amd64.deb
- sha256sums_x86_64 = 5359a8074e6214feae8c1721b23dfab31d49df4a5184ded6856017ebee46c668
+ sha256sums = 8915ca75d453698df81f7f3305cce6869f4261d754d90f0c3724b73c7b24ca84
+ source_aarch64 = escrcpy-1.16.3-aarch64.deb::https://github.com/viarotel-org/escrcpy/releases/download/v1.16.3/Escrcpy-1.16.3-linux-arm64.deb
+ sha256sums_aarch64 = 55e39f515b6def9b101cd72ba1985e0413f8fe2abad8881b6067b8258c5b956d
+ source_x86_64 = escrcpy-1.16.3-x86_64.deb::https://github.com/viarotel-org/escrcpy/releases/download/v1.16.3/Escrcpy-1.16.3-linux-amd64.deb
+ sha256sums_x86_64 = 42eb191d6156b5d4ad20e1d84884215f99563f2382486e88c457f92b8b539ac2
pkgname = escrcpy-bin
diff --git a/PKGBUILD b/PKGBUILD
index 657614cdd54e..0e975c88b074 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=escrcpy-bin
_pkgname=Escrcpy
-pkgver=1.16.1
+pkgver=1.16.3
+_electronversion=27
pkgrel=1
pkgdesc="使用图形化的 Scrcpy 显示和控制您的 Android 设备,由 Electron 驱动"
arch=(
@@ -13,7 +14,7 @@ license=('MIT')
conflicts=("${pkgname%-bin}")
provides=("${pkgname%-bin}=${pkgver}")
depends=(
- 'electron27'
+ "electron${_electronversion}"
'hicolor-icon-theme'
'scrcpy'
)
@@ -24,10 +25,14 @@ source=(
"${pkgname%-bin}.sh"
)
sha256sums=('608449f39836e08b54dbe679e78fefbd8b2a4f77ac6fc16bf7320d1e89e4bb10'
- '941cb7196d03283a6e65a2271f0c8381a9ec8176f38ce9dc9916f3f89b29a720')
-sha256sums_aarch64=('9b7800b1efa13dcbbd781f63b6ea513b22b9c0e01130b4262e0fc9d6d229516f')
-sha256sums_x86_64=('5359a8074e6214feae8c1721b23dfab31d49df4a5184ded6856017ebee46c668')
+ '8915ca75d453698df81f7f3305cce6869f4261d754d90f0c3724b73c7b24ca84')
+sha256sums_aarch64=('55e39f515b6def9b101cd72ba1985e0413f8fe2abad8881b6067b8258c5b956d')
+sha256sums_x86_64=('42eb191d6156b5d4ad20e1d84884215f99563f2382486e88c457f92b8b539ac2')
build() {
+ sed -e "s|@electronversion@|${_electronversion}|" \
+ -e "s|@appname@|${pkgname%-bin}|g" \
+ -e "s|@appasar@|app.asar|g" \
+ -i "${srcdir}/${pkgname%-bin}.sh"
bsdtar -xf "${srcdir}/data.tar.xz"
sed "s|/opt/${_pkgname}/${pkgname%-bin} %U|${pkgname%-bin}|g" -i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
cd "${srcdir}/opt/${_pkgname}/resources/extra/linux"
diff --git a/escrcpy.sh b/escrcpy.sh
index b2507a2428fc..2ec4412e5c4f 100644
--- a/escrcpy.sh
+++ b/escrcpy.sh
@@ -1,11 +1,14 @@
#!/bin/bash
-_ELECTRON=/usr/bin/electron27
-APPDIR="/usr/lib/escrcpy"
-export PATH="${APPDIR}:${PATH}"
-#export LD_LIBRARY_PATH="${APPDIR}/usr/lib:${LD_LIBRARY_PATH}"
-_ASAR="${APPDIR}/app.asar"
+set -e
+_APPDIR="/usr/lib/@appname@"
+export PATH="${_APPDIR}:${PATH}"
+export ELECTRON_IS_DEV=0
+export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
+_ASAR="${_APPDIR}/@appasar@"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec ${_ELECTRON} ${_ASAR} "$@"
+ cd "${_APPDIR}"
+ exec electron@electronversion@ "${_ASAR}" "$@"
else
- exec ${_ELECTRON} ${_ASAR} --no-sandbox "$@"
+ cd "${_APPDIR}"
+ exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
fi \ No newline at end of file