summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-12-20 09:11:23 +0800
committerzxp198210052023-12-20 09:11:23 +0800
commit7a7396eea6ffade390e4819331fe1f2f720852be (patch)
tree4955a16bd76f63eb7e044f94b0813127853a9566
parent315ed87bf9ec1239d8e57a78be85e98f4cf72c2a (diff)
downloadaur-7a7396eea6ffade390e4819331fe1f2f720852be.tar.gz
update to 1.16.7
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD8
-rw-r--r--escrcpy.sh9
3 files changed, 18 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7f6fa2d54746..4afbb87c2a02 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = escrcpy-bin
pkgdesc = 使用图形化的 Scrcpy 显示和控制您的 Android 设备,由 Electron 驱动
- pkgver = 1.16.3
+ pkgver = 1.16.7
pkgrel = 1
url = https://github.com/viarotel-org/escrcpy
arch = aarch64
@@ -9,15 +9,15 @@ pkgbase = escrcpy-bin
depends = electron27
depends = hicolor-icon-theme
depends = scrcpy
- provides = escrcpy=1.16.3
+ provides = escrcpy=1.16.7
conflicts = escrcpy
- source = LICENSE-1.16.3::https://raw.githubusercontent.com/viarotel-org/escrcpy/v1.16.3/LICENSE
+ source = LICENSE-1.16.7::https://raw.githubusercontent.com/viarotel-org/escrcpy/v1.16.7/LICENSE
source = escrcpy.sh
sha256sums = 608449f39836e08b54dbe679e78fefbd8b2a4f77ac6fc16bf7320d1e89e4bb10
- sha256sums = 8915ca75d453698df81f7f3305cce6869f4261d754d90f0c3724b73c7b24ca84
- source_aarch64 = escrcpy-1.16.3-aarch64.deb::https://github.com/viarotel-org/escrcpy/releases/download/v1.16.3/Escrcpy-1.16.3-linux-arm64.deb
- sha256sums_aarch64 = 55e39f515b6def9b101cd72ba1985e0413f8fe2abad8881b6067b8258c5b956d
- source_x86_64 = escrcpy-1.16.3-x86_64.deb::https://github.com/viarotel-org/escrcpy/releases/download/v1.16.3/Escrcpy-1.16.3-linux-amd64.deb
- sha256sums_x86_64 = 42eb191d6156b5d4ad20e1d84884215f99563f2382486e88c457f92b8b539ac2
+ sha256sums = 5ce46265f0335b03568aa06f7b4c57c5f8ffade7a226489ea39796be91a511bf
+ source_aarch64 = escrcpy-1.16.7-aarch64.deb::https://github.com/viarotel-org/escrcpy/releases/download/v1.16.7/Escrcpy-1.16.7-linux-arm64.deb
+ sha256sums_aarch64 = 423652a95216f20e47a079777b30fbd06c7ebd5b3b3ceff0081ccdc2206c2406
+ source_x86_64 = escrcpy-1.16.7-x86_64.deb::https://github.com/viarotel-org/escrcpy/releases/download/v1.16.7/Escrcpy-1.16.7-linux-amd64.deb
+ sha256sums_x86_64 = 51634b69de1aae56dcad2023dce93c1db186d89aaf568ed33d3cadf24f5955e8
pkgname = escrcpy-bin
diff --git a/PKGBUILD b/PKGBUILD
index 0e975c88b074..200bf39e3af3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=escrcpy-bin
_pkgname=Escrcpy
-pkgver=1.16.3
+pkgver=1.16.7
_electronversion=27
pkgrel=1
pkgdesc="使用图形化的 Scrcpy 显示和控制您的 Android 设备,由 Electron 驱动"
@@ -25,9 +25,9 @@ source=(
"${pkgname%-bin}.sh"
)
sha256sums=('608449f39836e08b54dbe679e78fefbd8b2a4f77ac6fc16bf7320d1e89e4bb10'
- '8915ca75d453698df81f7f3305cce6869f4261d754d90f0c3724b73c7b24ca84')
-sha256sums_aarch64=('55e39f515b6def9b101cd72ba1985e0413f8fe2abad8881b6067b8258c5b956d')
-sha256sums_x86_64=('42eb191d6156b5d4ad20e1d84884215f99563f2382486e88c457f92b8b539ac2')
+ '5ce46265f0335b03568aa06f7b4c57c5f8ffade7a226489ea39796be91a511bf')
+sha256sums_aarch64=('423652a95216f20e47a079777b30fbd06c7ebd5b3b3ceff0081ccdc2206c2406')
+sha256sums_x86_64=('51634b69de1aae56dcad2023dce93c1db186d89aaf568ed33d3cadf24f5955e8')
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname%-bin}|g" \
diff --git a/escrcpy.sh b/escrcpy.sh
index 2ec4412e5c4f..c77c53567639 100644
--- a/escrcpy.sh
+++ b/escrcpy.sh
@@ -1,14 +1,17 @@
-#!/bin/bash
+#!/bin/sh
set -e
_APPDIR="/usr/lib/@appname@"
+_ASAR="${_APPDIR}/@appasar@"
export PATH="${_APPDIR}:${PATH}"
-export ELECTRON_IS_DEV=0
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
-_ASAR="${_APPDIR}/@appasar@"
+export ELECTRON_IS_DEV=0
+export NODE_ENV=production
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
cd "${_APPDIR}"
exec electron@electronversion@ "${_ASAR}" "$@"
+ exit
else
cd "${_APPDIR}"
exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
+ exit
fi \ No newline at end of file