summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjose17112019-02-09 12:33:15 +0100
committerjose17112019-02-09 12:33:15 +0100
commit669e16287b73b04b507962a62a8ddd87f8508e50 (patch)
treec011cd3a1f247e7b68f8932d2703a3b447fb9dff
downloadaur-669e16287b73b04b507962a62a8ddd87f8508e50.tar.gz
Adopted from aur3
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD40
-rw-r--r--esd37
-rw-r--r--esd-0.2.38-alsa-drain.patch11
4 files changed, 115 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4c5a63d3ac78
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+# Generated by mksrcinfo v8
+# Sat Feb 9 11:32:58 UTC 2019
+pkgbase = esd-oss
+ pkgdesc = Enlightened Sound Daemon without ALSA dependence
+ pkgver = 0.2.41
+ pkgrel = 1
+ url = http://www.tux.org/~ricdude/EsounD.html
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ depends = audiofile
+ depends = tcp-wrappers
+ provides = esd=0.2.41
+ provides = esound=0.2.41
+ conflicts = esd
+ conflicts = esound
+ options = !libtool
+ backup = etc/esd.conf
+ source = http://ftp.gnome.org/pub/GNOME/sources/esound/0.2/esound-0.2.41.tar.bz2
+ source = esd-0.2.38-alsa-drain.patch
+ source = esd
+ md5sums = 8d9aad3d94d15e0d59ba9dc0ea990c6c
+ md5sums = 3de93efcd1bc196a3585e6aef50eac48
+ md5sums = a4c76e7c7f75b201ea7ab6fb15b47472
+
+pkgname = esd-oss
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9a36178c0c37
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Jose Riha <jose 1711 gmail com>
+# Contributor: Teo Mrnjavac <teo.mrnjavac@gmail.com>
+# Contributor: Jan de Groot <jgc@archlinux.org>
+# Contributor: lh <jarryson@gmail.com>
+# Contributor: Devin Cofer <ranguvar{AT]archlinux[DOT}us>
+
+pkgname=esd-oss
+pkgver=0.2.41
+pkgrel=1
+pkgdesc="Enlightened Sound Daemon without ALSA dependence"
+url="http://www.tux.org/~ricdude/EsounD.html"
+arch=('i686' 'x86_64')
+license=('LGPL')
+depends=('audiofile' 'tcp-wrappers')
+source=(http://ftp.gnome.org/pub/GNOME/sources/esound/0.2/esound-${pkgver}.tar.bz2
+ esd-0.2.38-alsa-drain.patch
+ esd)
+md5sums=('8d9aad3d94d15e0d59ba9dc0ea990c6c'
+ '3de93efcd1bc196a3585e6aef50eac48'
+ 'a4c76e7c7f75b201ea7ab6fb15b47472')
+provides=("esd=$pkgver" "esound=$pkgver")
+conflicts=('esd' 'esound')
+backup=('etc/esd.conf')
+options=('!libtool')
+
+build() {
+ cd ${srcdir}/esound-${pkgver}
+ patch -Np1 -i ${srcdir}/esd-0.2.38-alsa-drain.patch || return 1
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --disable-static \
+ --with-audiofile --with-libwrap --disable-alsa --disable-artstest
+ export LDFLAGS='-lm'
+ make -e
+}
+
+package() {
+ cd ${srcdir}/esound-${pkgver}
+ make DESTDIR=${pkgdir} install
+ install -m755 -d ${pkgdir}/etc/rc.d
+ install -m755 ${srcdir}/esd ${pkgdir}/etc/rc.d/esd
+}
diff --git a/esd b/esd
new file mode 100644
index 000000000000..d90ef55fac63
--- /dev/null
+++ b/esd
@@ -0,0 +1,37 @@
+#!/bin/bash
+
+. /etc/rc.conf
+. /etc/rc.d/functions
+
+PID=`pidof -o %PPID /usr/bin/esd`
+case "$1" in
+ start)
+ stat_busy "Starting Esound Daemon"
+ if [ -z "$PID" ]; then
+ /usr/bin/esd -nobeeps &
+ fi
+ if [ ! -z "$PID" -o $? -gt 0 ]; then
+ stat_fail
+ else
+ add_daemon esd
+ stat_done
+ fi
+ ;;
+ stop)
+ stat_busy "Stopping Esound Daemon"
+ [ ! -z "$PID" ] && kill $PID &> /dev/null
+ if [ $? -gt 0 ]; then
+ stat_fail
+ else
+ rm_daemon esd
+ stat_done
+ fi
+ ;;
+ restart)
+ $0 stop
+ sleep 1
+ $0 start
+ ;;
+ *)
+ echo "usage: $0 {start|stop|restart}"
+esac
diff --git a/esd-0.2.38-alsa-drain.patch b/esd-0.2.38-alsa-drain.patch
new file mode 100644
index 000000000000..f2fb716ba5ed
--- /dev/null
+++ b/esd-0.2.38-alsa-drain.patch
@@ -0,0 +1,11 @@
+--- esound-0.2.38/audio_alsa09.c.old 2007-06-11 12:22:24.000000000 +0200
++++ esound-0.2.38/audio_alsa09.c 2007-06-11 12:22:49.000000000 +0200
+@@ -486,7 +486,7 @@ void esd_audio_flush(void)
+ }
+
+ if (alsa_playback_handle != NULL)
+- snd_pcm_drain( alsa_playback_handle );
++ snd_pcm_drop( alsa_playback_handle );
+
+ if (alsadbg)
+ print_state();