summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Sinclair2017-04-08 15:18:35 -0400
committerAdrian Sinclair2017-04-08 15:18:35 -0400
commit77cfceccfdbe0cb7c243e9d9f5a6a5e6559b4927 (patch)
tree7847201c75e703c9a476b7c7c6120109ef799458
downloadaur-77cfceccfdbe0cb7c243e9d9f5a6a5e6559b4927.tar.gz
v2.2.0
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..154f75181eb7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = eslint-plugin-import
+ pkgdesc = Import with safety (eslint)
+ pkgver = 2.2.0
+ pkgrel = 1
+ url = https://github.com/benmosher/eslint-plugin-import
+ arch = any
+ license = MIT
+ makedepends = npm
+ depends = nodejs
+ depends = eslint
+ noextract = eslint-plugin-import-2.2.0.tgz
+ source = http://registry.npmjs.org/eslint-plugin-import/-/eslint-plugin-import-2.2.0.tgz
+ md5sums = 7d94b1cd89f2f4eacd01e823d44e3f16
+
+pkgname = eslint-plugin-import
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a02f59545143
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Adrian Sinclair <adrian@transloadit.com>
+
+pkgname=eslint-plugin-import
+pkgver=2.2.0
+pkgrel=1
+pkgdesc='Import with safety (eslint)'
+arch=('any')
+url='https://github.com/benmosher/eslint-plugin-import'
+license=('MIT')
+depends=('nodejs' 'eslint')
+makedepends=('npm')
+source=(http://registry.npmjs.org/$pkgname/-/$pkgname-$pkgver.tgz)
+noextract=($pkgname-$pkgver.tgz)
+md5sums=('7d94b1cd89f2f4eacd01e823d44e3f16')
+
+package() {
+ npm install -g --user root --prefix "$pkgdir"/usr "$srcdir"/$pkgname-$pkgver.tgz
+ rm -r "$pkgdir"/usr/etc
+
+ # Fix permissions
+ find "$pkgdir/usr" -type d -exec chmod 755 '{}' +
+
+ install -dm755 "${pkgdir}/usr/share/licenses/${pkgname}"
+ ln -s ../../../lib/node_modules/$pkgname/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}