summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrkcf2019-01-11 17:20:58 -0700
committerrkcf2019-01-11 17:20:58 -0700
commite37d99b3e2b1eeaf0a424ca97a95cc0f6f4f4e3e (patch)
treed5467d9bc2925aaca7516721aee0a7f6c75d64b2
parent60592d959aaed81de569f863f6f5e0c118b25e72 (diff)
downloadaur-e37d99b3e2b1eeaf0a424ca97a95cc0f6f4f4e3e.tar.gz
update to v8.0.1
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD14
2 files changed, 13 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d633a431f0e9..88cef73efd4d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
pkgbase = eslint-plugin-node
- pkgdesc = Additional eslint rules for node
- pkgver = 4.2.2
+ pkgdesc = Additional ESLint rules for Node.js
+ pkgver = 8.0.1
pkgrel = 1
- url = https://github.com/mysticatea/eslint-plugin-react
+ url = https://github.com/mysticatea/eslint-plugin-node
arch = any
license = MIT
makedepends = npm
- depends = nodejs
depends = eslint
- noextract = eslint-plugin-node-4.2.2.tgz
- source = http://registry.npmjs.org/eslint-plugin-node/-/eslint-plugin-node-4.2.2.tgz
- md5sums = 8da5ff5a455ad21e32778a909ea6648d
+ noextract = eslint-plugin-node-8.0.1.tgz
+ source = http://registry.npmjs.org/eslint-plugin-node/-/eslint-plugin-node-8.0.1.tgz
+ md5sums = f85a9a7c2e505f40aeb2e69e13e31881
pkgname = eslint-plugin-node
diff --git a/PKGBUILD b/PKGBUILD
index 56f3c0c07d18..a937d6fa5626 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,21 @@
-# Maintainer: Adrian Sinclair <adrian@transloadit.com>
+# Maintainer: Andrew Steinke <rkcf@rkcf.me>
+# Contributor: Adrian Sinclair <adrian@transloadit.com>
pkgname=eslint-plugin-node
-pkgver=4.2.2
+pkgver=8.0.1
pkgrel=1
-pkgdesc='Additional eslint rules for node'
+pkgdesc='Additional ESLint rules for Node.js'
arch=('any')
-url='https://github.com/mysticatea/eslint-plugin-react'
+url='https://github.com/mysticatea/eslint-plugin-node'
license=('MIT')
-depends=('nodejs' 'eslint')
+depends=('eslint')
makedepends=('npm')
source=(http://registry.npmjs.org/$pkgname/-/$pkgname-$pkgver.tgz)
noextract=($pkgname-$pkgver.tgz)
-md5sums=('8da5ff5a455ad21e32778a909ea6648d')
+md5sums=('f85a9a7c2e505f40aeb2e69e13e31881')
package() {
npm install -g --user root --prefix "$pkgdir"/usr "$srcdir"/$pkgname-$pkgver.tgz
- rm -r "$pkgdir"/usr/etc
# Fix permissions
find "$pkgdir/usr" -type d -exec chmod 755 '{}' +